Plugin Delay Compensation (See Pic)

cubase plugin  list latency.jpg
Have a look at the picture. As you can see there’s some pretty hefty delay comp in some of those plugs. I’ve experienced that cubase doesn’t compensate for vst3 and vst2’s. I’ve been creating tracks noticing timing and feel looses dramatically on inserts and instruments. A combination of both can bring nightmares. So I’m curious to know, How do you guys compensate? Manually adjusting track delay - + to get the desired result? Not using the offending plugins totally? I just remember it not being this bad. Sometimes my tracks just lose it’s tightness in small increments for each track. Invisible to the eye, have to rely on ears… Bouncing to audio to adjust is not an option. Will require more warping and sliding part and regions around to fit taste. I know I’m all over the place with this, but it’s surprises me how this issue has me checking tempo/clock/asio and anything else to I can to stop the bleeding…LOL. Maybe someone will shed some light on a brother. :wink:

PDC happens automatically in Cubase - unless you have pressed the “Constrain Delay Compensation” button, which will turn off the PDC for plugs that have latency larger than the threshold time (in ms) you set in prefs.

I hear you, but if that was the case, turning off PDC would yield no result.(plugin disabled). Here’s a scenario. I’m using a plugin on an insert track. PDC latency in the plugin is 2048. In order for me to get it back in the pocket, I have to use the track delay to -48 in milliseconds to play as expected. If cubase was doing the right thing and working as expected, I wouldn’t have to use track delay. Right :question:

Sadly, this is an issue i’ve learned to live with.

I no longer know if it’s my ears or Cubase but I always think there’s something out of sync.

Then just when you’ve got everything lined up with the kick drum you load up a synth with a BPM synced arpeggio which actually sounds ‘out’ to the other instruments but because it’s linked to BPM you have to shifty every other track to match the arpeggio…

…and after all that, even the BPM synced arpeggio doesnt line up with the metronome click…

Thanks for the share. I’ve been plagued with this since sx2-CB7.5. This has gone on long enough. I know there are many more who experience this same behavior.

All I can say is: PDC works! Even with plugins that add a lot of latency. Never a problem. Don’t say I just wouldn’t hear it. At least with parallel compression and stuff like that I definately would… but it’s always spot on, all day long, up and down :wink:

Maybe plugins that do not report a correct value to Cubase?

Thanks! I completely understand it works for you. That would leave me to discard offending plugins (update/Trash) them. Can’t say I wanna do that or can do that. So I’m leaning on track delay in milliseconds to help aid this issue. Which is a bummer. The more combinations of plugins yield different offset times per track. Not a good look if The groove or feel is what your after. Dealing with all audio tracks is not the problem, works as expected. Combine instruments and audio tracks and then let the games begin.

PDC works fine here with audio and midi/instruments here, as well. I wonder - are you using a mix of time bases in your tracks? Constrain delay compensation is actually something different than PDC…it compensates so that midi isn’t recorded too early - perhaps try either turning it off or on for all tracks.

Thanks for the feedback. I know how it works. If I have a live bass player jam to some drums in the track and its in the pocket. Once recorded, Insert let’s say a A.O.M Invisible_Limiter plugin. That bass track is no longer in sync as it was originally recorded.(CDC OR PDC doesn’t matter) Bypass it or remove it and its back to normal. I’m trying to find solutions to overcome this. I used that plugin as a reference. It could be midi or audio or plugins. It could be that I’m a perfectionist and timing is everything when recreating the 70’s sound. I’m glad it works for some of you, it’s not for me. Next move will be to upload a youtube video demonstrating this issue and show the community what I’m talking about.
So far one person TKW wrote:
Sadly, this is an issue i’ve learned to live with.

It’s driving me up the wall…

Of course timing is crucial, would drive me crazy as well… Try to find the plugins causing the problems (I guess there’s the problem) and replace them by something that works.

No offence, but this information isn’t correct. Constrain delay compensation disables the plug ins which latency exceeds the delay compensation threshold set in the preferences.

To KDEF2004 have you had the opportunity to check the plug ins you suspect causing these timing issues in another DAW?
Like marQs said, it could well be the plugs don’t report the correct latency to the host. Especially because you can correct the introduced delay, which looks like the introduced latency is consistent.
Nice beats by the way :sunglasses:

Sorry - you’re right - I was thinking of the “ASIO latency” switch which is on each midi/instrument track…

Yes, I’ve narrowed it down to a few plugins not playing nice with cubase. Will have to use track delay to compensate. I appreciate the feedback. Thanks!

I’m pretty much using C7 just for mixing, and I’m experiencing not a correct delay compensation too in projects with great latency.
In those project also the freeze function acts the same way.

I read this thread, would you guys be so kind to tell me where I can find the compensation limit in the preference? I’m not able to find it. :slight_smile:

I’d like to experiment with that and see what happens.

Capture.JPG

Sure check the pic

Take a look at :
http://www.voxengo.com/product/latencydelay/

Nice! will check it out. Thanks

Thanks KDEF for the time you took to take the screenshot. :slight_smile:
I saw that window, but I had thought it wasn’t related to the “regular” delay compensation, but to the “force dalay compensation” function while tracking.

the automation in Cubase is not tight.

when you have two inserts which lower the volume and you switch them bypassing you still hear the signal in between the switches.

Yes, Cubase automation timing is not 100% accurate. It actually varies depending on the size of buffer you have. The higher the buffer setting, the earlier your automation will be.

RE: PDC, I have also noticed a few plugins where the delay compensation does not work correctly. Can’t remember which ones just at the moment but I’ve definitely experienced this with a couple of Waves plugins. I think there are certain plugins that create too much latency for the PDC system to cope with. It’s quite rare in my experience though.