I’m using cubasis on ipad 2. I’ ve been having latency and crackling issues. I’ m not sure if polyphony has anything to do with it. It was set at 32. Not sure if increasing it to 48, which is the max on the ipad 2, would help.

If anything you would need to decrease the polyphony rather than increase it.
I know if you’re running audiobus at the same time you can increase the buffer (and latency) to take some processing power off the CPU

also from the manual:

Q: I’m having performance issues.
There are many different ways to increase your device’s performance:
• If you are working with a large project containing a lot of notes, try
the polyphony settings in the setup menu.
• Combine effects: Avoid using multiple insert effects of the same
type. Try using one send effect for multiple tracks, if possible. You
can still adjust the each track’s mix individually. The reverb effect is
a prime example, as it requires the most CPU and is best used as
a send or even a master insert.
• Quit apps running in the background. To terminate an app, double
tap the home button, tap and hold the app’s icon and select the red
minus symbol. (or double tap the home button and swipe up for iOS7)
• Disconnect your device from any unnecessary networks / cables.
Even when your device is not actively syncing with a computer,
small amounts of information are always exchanged.

Hope that helps. Freeze tracks if you can and make sure to close any applications you are done using (bounce to audio first if needed). Those are big things.

That helped.