Pops and crackles

One audio track for guitar with Mercuriall U530 insert.
One instance of Addictive Drums running simple mallets beat.
Pops and crackles like and old man after a dose of beans.
Buffer set to 96. Sample rate 44.1
Check my sig for PC specs.

I gave away using my DAW and retreated to just playing for a while due to issues like this. I thought I bought a big enough computer to do Cubase standing on its ear.

Came back tonight for another try and lots of frustration and not much playing.


Increase your Audio Device Buffer Size, please.

Good chance your issue is related to a larger issue that is affecting both mac and windows users, which results in cpu spikes and audio pops/dropouts. Seems to be related to multithreading and/or GPU driver issues.

Or maybe your buffer… Is too small, lol. I’m erring on the side of the former, based on all the comments under ‘issues’ and my own frustrating experience.


You could also test your system by using LatencyMon utility.

Thanks, I got erroneous advice to REDUCE the buffer from a YouTube video.
Looking at the dynamic audio performance visual monitor, average load is OK but real-time peak keeps going into the red at 96 samples (which the UR44 GUI tells me equates to 4.996ms input and 5.941ms output latencies

I tried setting buffer to 256 samples and the real-time peak still bounces into the red (inpout latency 9.592, output latency 11.565)

Then I tried setting buffer to 768 samples. The real-time peak then stayed out of the red but input latency is then 22.2ms and output latency 26.168.

None of this is within what I expected from my system. Note I have 2 audio tracks (guitar via Hi-Z) and one virtual instrument track (Addictive Drums)

I will try LatencyMon

Do these buffer sizes, latencies and real time system peaks look reasonmable (see sig for PC spec)?

Recording one guitar audio track with one insert. Playing one audio guitar track & one instance of Addictive Drums.

96 samples = 4.996ms input & 5.941ms output latencies (real time peak monitor bouncing into red)
256 samples = 9.592ms input & 11.565ms output latencies (real time peak monitor bouncing into red)
768 samples = 22.2ms input & 26.168ms output latencies (real time peak monitor OK)

I’ve never been able to successfully stop the peaks, consistently anyway, no matter what I do.

I’ve already put my foot in my mouth once a few weeks ago and announced on these forums that I had solved the issue (Cubase had defaulted to 32bit processing precision, and I switched it to 64 which seemed to solve it for many hours of testing), and then 2 hours after making the post the peaks and audio pops came back.

I’ve tried every buffer setting from 96 to 512, and the peaks don’t seem affected by buffer size in my case. I’m really frustrated here and support hasn’t responded back to me in 2 weeks now, after asking for “my help in troubleshooting and sharing feedback with them”.

So we just bought a Maschine mk3 and are producing more outside Cubase I guess. If this isn’t resolved in a timely manner, this will damage my 20+ year confidence in Cubase in a way that may never be recovered. I waited years to buy a new pro license, and… I guess I chose the wrong time? No idea.

As already stated, there seems to be something deeper going on with later versions of Cubase. That said, you should be able to manage a LOT of load on a 256 buffer size. Your latency is about double mine on that setting, which is a bit strange. I would suggest some experimenting with turning on/off the ASIO guard as well as its level of activity. Also set the computer to Steinberg’s power scheme (all these settings are in the ASIO setup of your studio setup menu). Also, just to be sure, verify that the correct ASIO driver is selected for your audio card so your system hasn’t defaulted to the generic one.

Last but not least; deactivate and where possible remove any protection software and see what happens. This unfortunately includes Windows Defender, but is especially applicable to third party software. Real time anti virus protection and the like has a tendency to do absolute murder on real time audio production.



Many thanks for the detailed response. I will try for a bit longer.

I really didn’t think getting the basic functionality of this DAW to work would be so complex. I just thought “Buy a big fast computer with plenty of RAM (from a builder who has built DAW PCs for many clients) and I’ll be OK”

I can’t even record one audio track consistently without a lot of mucking around and huge problems. It’s unusable as it is.

I’ve got Reaper, might try that to see if the same problems occur. Shame about all the $ spent. I just want to make music, all this pfaffing around is getting in my way, not helping me. Pretty frustrated to be honest. I’ve got tertiary IT qualifications so can usually work out how to use an application. Not having much success with this one.

More persistence required :slight_smile:

You should be able to record no problem without issue…I’ve got a five plus year old PC and never have problems. I know having an RME audio interface helps but even when i use my old Steinberg interface I don’t see these problems unless I try to run at very low buffers.

Is the higher latency causally causing you a problem? Unless you’re using some of the inserts in real time it shouldn’t affect things greatly, surely?

I would say if your realtime monitor is bouncing into the red and if you’re then hearing dropouts or artefacts with just two tracks as described that is not at all reasonable. Have you tried the earlier suggestion to run an external program to check your machine? I have certainly experienced some usb drivers, or bluetooth or wifi drivers to take a big chunk of PC real time audio processing ability away. You should be getting much much better performance, irrespective of any general optimising that Steinberg may still be able to implement (unless Addictive Drums is a ludicrous resource hog - I’ve never used it).

Good luck with your troubleshooting.


After huge amounts of frustration and denials of this issue by brand-managers on this forum, the workaround, for me (x299, i7 7800x, win10 pro, cubase 10.5) was to totally disable all virtual cores. Now the ASIO internal overload issue is 100% gone, processing load is on average 30-40% less than before, and if this issue had been PROPERLY DOCUMENTED, presented in a bulletin, or a pinned post, ALL OF my frustration and anger here would have been avoided.

Good luck with troubleshooting, indeed. Try that one thing and let me know.