Possible anomaly re: slash regions

Well, there’s hope for us yet! I just got a transcription gig and decided to spend an hour with the inimitable Dan Kreider, boning up and getting up to speed in 3.5.

In preparation for our session, I was seeing something strange and Dan was able to replicate it. I created a 4 bar slash region. The handles appear when I create the region and I can already grab a handle and move it back and forth to reveal the ‘underlying’ normal notation bar. I then tried to change the 3rd bar only back into a ‘normal’ notation bar. Should be simple. Choose the first slash in the bar I want to revert. As expected, that bar and the next one turn dark green. Then use the Scissors tool and just drag the handles back and forth to reveal the ‘underlying’ normal notation bar. But when I do this, the handle just blinks and disappears.

As mentioned, Dan tried on his install as well. Can anyone else replicate this?

Kind of. I think the problem is that if you cut a slash region you have the start handle for the second region and the end handle for the first region in exactly the same spot. This means that using the mouse to drag the handles doesn’t work correctly, because it’s ambiguous as to which handle you’re trying to drag.

If you can get in the habit of using keyboard commands (Alt-right/left to move the thing and Shift-Alt-right/left to extend or contract the thing) then you won’t rub up against this issue.

I think the optimal approach in your example would be to select the first slash of bar four, hit U, then use Shift-Alt-Left to retract the first slash region.

1 Like

Hi Leo, thanks as always for the help. I tried selecting the first slash in bar 4 and dragging backwards to retract the Bar 3 slash region but again, the leftmost handle just disappeared as soon as I clicked on it.

I then tried selecting the first slash in the bar I want to empty (Bar 3) then using Shift-Alt-Left. This started working although I had to use Shift-Alt-Left several times, I guess because of the grid I have set up. But the process stopped one sixteenth note short, I just couldn’t get that last sixteenth note out of there. See attached (or not… seems attachments are only through Hyperlinks?)

I found a workaround by simply using Shift-B to bring up the Bars Popover, using -1 to get rid of the 3rd bar in the 4-bar slash region, then doing the same using +1. The added bar shows as a 'regular bar.

The attachment hasn’t shown up, I’m afraid. You should just be able to drag and drop your image (or whatever it is) straight onto the message box here.

I maybe wasn’t clear enough. Follow this exact sequence:

  1. Select the first slash of bar 4.
  2. Type U.
  3. Type Shift-Alt-Left as many times as necessary, dependent on your rhythmic grid resolution.

Note that a slash region that encompasses one (or more) complete bar(s) will show its end handle at the downbeat of the following bar.

Above is what I saw last time.

Okay, I have no idea why it worked this time, the instructions you gave the first time were exactly the same but now it worked. I must have made an error. In any case it seems like it will be faster to just use the Bar Popover to delete the bar and re-add it as this method requires multiple Shift-Alt-Left clicks. That is unless I can temporarily change the grid to whole notes with one click. But I’ll figure this out on my own!

Thanks again Leo! I may be contacting you about another matter on the advice of DS.

All valid, but the issue that mset is referring to, which I experienced as well, is specifically the unpredictability of dragging the circular handles. Sometimes they simply vanish, other times they work. It was admittedly odd.

@dankreider I explained that one further up…

You certainly can assign keyboard shortcuts to set the rhythmic grid resolution to specific values. It’s not something I’ve ever bothered to do, but I know of a few people who really rate it as a way to work.

I understand that, Leo. What I’m pointing out is that it’s not working correctly, IMO.

For what it is worth, I also find working with these handles to be quite unpredictable. Usually, once I’ve moved them once with the keyboard, the handles respond properly to dragging with the mouse.
I’d be glad if the team could look into streamlining this a bit more… :wink:

All the best,