Possible bug adding tr

Hi all,

an animated GIF says more than a thousand words:

tr anomaly

As you see, the trill gets added at the start of the flow (not duplicated where I entered it).

Just this project/flow?

No, but this is the first time I got it on film.

I’ve had a fiddle and I think that I can reproduce this:

  • You need to be inputting notes into bars that already contain music (as per the gif)
  • Shift-N for note entry
  • Shift-O > tr for a trill
  • Select a pitch (I tried using MIDI keyboard and computer keyboard)
1 Like

So it is probably a bug!
My scenario was exactly the same as yours, except that I was entering notes with qwerty only.

I can’t replicate the problem with your directions. I’ve filled measures exactly like the OP and then in the soprano voice, I’ve invoked the note input caret, and right after that invoked the ornament popover and added a trill. At that point, I have to advance the caret to get the trill to appear by pressing the space key. It appears where the caret had been, not at the beginning of the flow. Are there details I’m missing?

The only thing I did different was instead of pressing space after entering tr into the popover, I entered a pitch with QWERTY or keyboard.

Also, I only tried this in my piano instrument and not anywhere else.

EDIT: When I press space instead of a pitch it works as normal.

I did not try pressing space – as Daniel, I entered a pitch.
In what circumstances would one need to press space? I think I never did that.

If you want to enter a trill over a note that is already at that rhythmic position

That’s how I would normally add a trill (or an ornament etc) while notating with the QWERTY keyboard.

1 Like

Me too