"pppp" too long to place correctly

Picture shows the situation:

The pppp should be on the right of the decrescendo. I believe the length of the text is causing it to flip to the left.
Admittedly, I’m unaware of any notation to signal “fade out to silence” that the VSTi will interpret. The ‘diminuendo’ notation causes the playback to sound as if it were staccato, and very short.
I’ve tried the text alignment options, placing above, scale, custom scale settings and nothing fixes.

hopefully someone will point out something obvious on the first reply which usually happens. Alas my knowledge is limited as a new user and Elements has no engraving options to fix something like this.

kindest regards to you all for dealing with my plebiness,

You could try setting the ‘Niente’ property on the hairpin instead of adding ‘pppp’, which is another way of indicating that the dynamic should die away to silence.

That did it! You’re amazing. Thankyou