PreSonus Faderport 8 not working with Cubase 10.5 or 11

I’ve been using my PreSonus Faderport 8 on and off with Cubase for a couple years now, and I’ve never been able to get it to work right. I’ve gone through all the setup stuff and tried multiple variations, but while many things work quite a number of others don’t. Some examples include:

  • The “Click” button (F6) never does anything. I can even custom configure it in the Studio / Studio Setup / Mackie Control section, assigning custom commands, and the button never does anything. This is true of a number of the other “function” buttons as well, and I know the buttons are good because they work properly with PreSonus Studio One.
  • The “ARM” button doesn’t do anything.
  • The Play/Pause button transport control will start playback but will not pause.

I’ve tried changing the Mackie control mode but neither “Compatibility” nor “Cubase” make the device work properly. I’ve tried multiple different USB ports of different sorts and that makes no difference. The articles I read suggest that it all worked fine until around Cubase 9.x but that problems have existed since. I even found a site (in Spanish) that claimed to have developed a “patch” that fixes all such issues, but that site seems defunct, and articles posted claim that the new “Cubase” compatibility option for Mackie Control fixes the issues, but it doesn’t.

Again let me stress: I know there is nothing wrong with the Faderport 8 unit itself as everything works properly with PreSonus Studio One. It is also updated to the latest firmware as of 12/20/2020.

In short, my question is this: has anybody managed to get a PreSonus Faderport 8 working properly in Cubase in total? And if so, how? Thanks in advance.

1 Like

Unfortunately I don’t have a FaderPort, so I can’t comment to the specifics of your situation.

However, in my never ending quest for the ultimate external controller setup, I’ve encountered similar frustrations to yours. And my bottom-line sentiment has become to abandon the Mackie protocol and configure my external controllers as Generic Remote.

Doing that is obviously more work at the beginning, but it does give a lot more flexibility. So there’s a long term reward for the extra work.

Can you configure your FaderPort as not using the Mackie protocol? If yes, that would make it easier to configure it as Cubase Generic Remote.

…and have you tried it using the Mackie HUI protocol? It’s mentioned on their site as well.

But I do agree with Nico5, for the same reasons.

1 Like

First, thanks to @Nico5 and @steve for the helpful replies. Let me say to both that:

  1. I’ve already tried using the FP8 in Mackie HUI mode, but that results in even less stuff working properly. Between MCU and HUI, the former seems the better choice.
  2. I just started investigating using it as a Generic Remote, having just read a few articles on the PreSonus site on how they added a new special “MIDI Mode” in a recent firmware update, but so far I’m having trouble figuring out what some of the controls do.

In particular, for example, the click button is one I desperately wish to work. Maybe that’s silly of me, but I am constantly turning click on and off during my normal workflow, so having a dedicated button is a big deal to me. While using a monitoring tool like MIDI-OX usually lets me figure out exactly what data a given control surface is sending, in this case the “Click” (F6) button on the FP8 shows nothing.

I’m not exactly a n00b when it comes to MIDI, but I’m a bit baffled insofar as it seems to send nothing at all: no program change, no note data, no controller data, no sysex, etc. I find this to be the case for some of the other controls as well, though most of them send easy-to-capture note on/off, controller data, etc. I find it a little baffling. Any resources folks have would be appreciated, as it seems like coming up with my own full-blown MIDI definition is my best hope.

If I understand the FaderPort 8 manual correctly, you may have to tell the faderPort to be in some sort of Midi Mode and then also tell Cubase to send and receive on different USB ports (“Presonus FP8 MIDIIN2” and “Presonus FP8 MIDIOUT2”)

Side note: When trying to trace what Cubase sends to the Generic Remote, loopMIDI is a great utility that allows you tore-route messages from midi software to other midi software (e.g. from Cubase to Midi-OX): https://www.tobias-erichsen.de/software/loopmidi.html

1 Like

First, thanks for the details on setting up MIDI mode. That’s exactly what I started trying to work with. And I can verify, for any interested parties, that the “shortcut” now possible (i.e., pressing both shift keys to toggle MIDI mode on from any other mode of operation) does seem properly to leverage what I configure in MIDI mode.

Aha! The version of the FP8 manual I found on the PreSonus site was also out of date! That newer version shows me on page 60 that the “Click” button sends MIDID CC 30, though I don’t see that in my MIDI monitor at all. I’ll have to monkey around with it a bit more and see if I can figure that out. Thanks for the info.

1 Like

Hi, in the documentation they make it clear that “Click” won’t work in Cubase.
I think that this is simply impossible because Cubase doesn’t allow you to control the bpm or the click volume via variables in your Remote Device. In other words there is no way to map the bpm or click controls in Cubase to an external MIDI controller (and in particular Faderport).

Besides that, the MIDI mode in Faderport is broken (the faders send the correct CC values to the host but when the host sends them values they are not updated correctly) however this is not Steinberg’s fault but Presonus’ (the same problem occurs with Studio One). I’ve posted a question in their forum with detailed seps to reproduce it: https://answers.presonus.com/62143/bug-faderport8-not-updating-its-faders-correctly-midi-mode Feel free to add comments on it or to vote it!

Regarding the @drmq post, thanks for the information, but I think perhaps I was unclear. I’m not trying to set the BPM or click volume, I’m simply trying to toggle the click on or off. That particular feature is a command named “Activate Metronome” under the “Transport” set of functions and should be able to be mapped to any control surface. For what it’s worth, PreSonus is responding to my support request, so if I get any information worth sharing I’ll post it here.

3 Likes

How did you get on with this? I have bought the Faderport 16 predominantly for mixing but also critically for input of CC values during recording.
And I cannot get it (Midi Mode) to work. The additional Midi port values which are supposed to be assigned to a generic midi controller in Cubase don’t show up, even after the Faderport firmware update. So it seems Cubase 10.5 is incompatible with Presonus Faderport 16 Midi Mode.
In fact its not even clear if Transport Controls are still available while in Midi Mode?
The comments about Click are correct, Click on/off is not supported in Cubase.
I am on Cubase 10.5 and Mac Catalina.
The entire Midi Mode and workflow subject in FP16/ Cubase is not documented anywhere.
Time to look at dedicated Midi CC controllers which do native Midi CC messaging I think.

Thank you for your post. It reminds me I need to get back to the Faderport and see if I can get a custom assignment working in MIDI mode. Here are the details from my notes:

  1. Presonus basically told me they never claimed all of the controls are supposed to work with all the other DAWs. They’ve basically washed their hands of it and (I believe) marketed it in a very misleading way. They have no intention of helping me or you or anyone else getting all those pesky buttons working with anything other than their StudioOne software. I’m sorry to be the bearer of those bad tidings.
  2. I bought another Steinberg CC121 and completely forgot about my Faderport. But as I said above, I appreciate your post because I’d like to see if I can get anything working in MIDI mode. My initial experiments, using a MIDI monitor, suggested that the Faderport does send MIDI data for all the buttons I tried.

If you just bought it, I’d either try to get PreSonus to provide you support for your use case, learn to live with only the faders working, or return the item if you can. I still need to figure out if I want to sell mine, so I’ll see if I can get it working in MIDI mode and get back to this thread, now that you’ve reminded me.

Agree your comments. I’ve lodged an issue with Presonus to resolve Midi mode/ Cubase however as a consumer I don’t think I should have to go that route for standard capability.
So my view is that Faderport16 midi mode is an after thought, specifically to catch up in the market. It doesn’t work, or doesn’t work well and I’m too too busy to pursue them.
My conclusion is that the FP16 is a terrific mixing surface and it certainly works well.
In midi mode it’s a lost cause, I’ll get an Icon Platform M+ or JL Cooper fader master for dedicated CC control, and just be happy with 2 devices.

I have good news and bad… well, maybe not even bad news, just admitting my own ignorance. First, the good news: the PreSonus Faderport 8 most certainly does transmit useful MIDI data when in the new MIDI mode. You can set it up to work as a Mackie-style controller with Cubase and then hit the two shift keys to put it in MIDI mode. I was able to capture the data it sends via the MIDI-OX utility easily enough.

Now here’s the part where I ran into the wall of my own ignorance: I can’t figure out how to make use of this data in Cubase. I’m using Cubase Pro v11.x (the latest patch). I added a new “Generic Remote” and deleted all the existing controls that come with that template. I made sure I set it to use “MIDIIN2 (PreSonus FP8)” as its MIDI Input and “MIDIOUT2 (PreSonus FP8)” as its MIDI Output. Once I did that, I found I could add a control, hit one of the buttons I care about mapping–the “Click (F6)” button in this case–and the Studio Setup dialog nicely “learned” that control just fine. The data values in that dialog matched what I saw in MIDI-OX: MIDI channel 6, address 30 (that’s the “1E” hexadecimal value shown in MIDI-OX under “DATA1”) and so forth.

I could then go down to the bottom half of the dialog box and configure it to do something in a variety of ways. I’ve tried setting the device to “Transport” and then the value/action being “metronomeOn”, I’ve tried setting the device to “Command” and then the category to “Transport” and the value/action to “Activate Metronome” (which incidentally is the command I’ve used on one of the function buttons on my CC-121, which works like a champ). But nothing I configure here seems to make Cubase actually do anything.

Can somebody weigh in with any ideas what I might be doing wrong? I feel like if I can just figure out some basics, I should be able to put together a complete PreSonus Faderport 8 device profile and share it. Thanks in advance!

Eureka! I’ve got it working. Or at least, I have a single button working as I’d like, but I think the general principle will work to enable all the other controls I wish were active. What I wrote yesterday was absolutely on point. The one thing I was missing was configuring the “Flags” column in the top half of the dialog. Once I configured that for “Receive”, which as I understand it means the action to be carried out as defined in the bottom half will be triggered any time the given MIDI information is received, the “Click (F6)” button on my PreSonus Faderport 8 toggles the metronome click in Cubase just like my CC121. I have a working beginning for using my FP8 properly with Cubase. Now I just need to figure out the other controls.