Printing exceeds printable area in landscape

I want to print my full score in landscape mode. I’m using “letter” sized paper. I have set the page size properties to letter and landscape.
If I print directly from Dorico 5, the right side of the page is cut off. (Johnny Mandel becomes John; all the staves are truncated.
If I export to PDF and print that, it fits correctly.
If I set the printer to Custom Scale and enter 90%, I get “Johnny Mand”.
If I set scaling to “Fit to paper”, it cuts off the right side.
Dorico acts like somewhere deep inside, A4 is hard-coded.
I can use the workaround of printing to PDF and printing that, but hopefully this will be a quick fix.

Just making sure that you set the right format in Layout Options->Page Setup and also in the Print Dialog?

1 Like

I don’t have this problem, so I’m guessing that something is amiss in how you’ve set up your document.

When you say that you “set the page size properties” do you simply mean in print mode? What is the layout’s page size set to in the layout options?

That’s a round-about way of asking: are you trying to get Dorico to fit a square peg in a round hole? (Differently-sized document onto a letter page)

The fact is, you can ask Dorico to print any sized document on any size paper that your printer has, so just because you set it one place (print mode) doesn’t mean it is ideally configured for that paper size. There could also be an error with your print drivers, for instance.

Please see attached photos

What happens if you do a Custom Scale of 100%?

“Fit to Paper” usually means it will be either scaled or cropped to fit the print area. Most printers can’t go all the way to the edge.

1 Like

Same thing. If I scale to 86% it fits horizontally

And are the margins the correct size? (e.g. is the distance from the edge of the system to the edge of the paper the same as the distance you set in Layout Options for the margin?)

Can you supply a sample document? Something doesn’t add up.

1 Like

The margins are larger than what is set in Layout.
In Layout, all the Page

margins are 0.583", and Music Frame Margins are Top: 0.556" Bottom 0.417" (I’m not sure what those do)

if I measure the printed page, I get almost a full inch. (left edge to system) If I measure the right edge to where it is truncated, I get 13/16 inch.

I’m not sure how to supply a sample document. I can either send the .dorico file or a scan of the printed page.

Send the Dorico project itself, provided it’s smaller than 4MB. If it’s not, try saving a copy of the project via File > Save As and apply the Silence playback template, which will reduce the size of the project somewhat. If that doesn’t shrink it enough, go to File > Project Info and scroll down to the bottom of the dialog, then turn off the option to generate thumbnails when saving the project, and save the project again. Now it should be small enough to attach here.

Here you go. Thanks for your help!

Perhaps it’s useful to know that this was a Finale project, exported to musicxml, and imported into Dorico.

A Time For Love.dorico (1.45 MB)

I see that you’ve set a Border round the printed page in “Annotations”. When I open your document, I see the border of your page running up and down the short sides, but not on the long sides. As if the page is the correct height, but not wide enough.

As soon as I re-apply “US Letter” in the right-hand panel, then the page fits correctly. Similarly, I Can set the Scale to 100%, and the page prints correctly.

Maybe turn off the Border? Otherwise, I think this is a problem with your printer driver.

Yes, I had turned on the border just to see where it printed. Is there a difference between “Letter” and “US Letter”? I selected only Letter.

I updated my print driver and set the scale to 100%, then printed the first 2 pages. They are still cut off on the right side. You can see these changes in the attached.
I’m happy to provide more information and I appreciate your assistance.
Perhaps I’ll just need to print to PDF and print that, as that works correctly.

A Time For Love.dorico (2.08 MB)

The names (and their sizes) in that list are supplied by the printer driver to Dorico. I have different drivers.

I presume you’ve checked your printer’s control panel and default config for anything weird? And is it printing correctly from every other app, using the default settings?

My old HP Printer used to have a setting for “Crop and something” or “Scale and something”, if page sizes didn’t match. (Sorry, can’t remember what the something was.)

Thanks. All the settings I can find simply say that Letter is 8.5 x 11. All the margins on that page are shown as 0.0, and nothing is editable.

Maybe someday I’ll get a new printer and it will work…

Thanks for your help!