Printing from the Score Editor

I’m printing a load of parts for musicians - sometimes I want to print the whole score from the page mode which is fine… but sometimes I want to print just a section of midi.

Sometimes that works fine by selecting the midi part - opening the score editor and pressing print…however sometimes it takes me into the page mode after I press print… any ideas why?

So it seems to be - if it’s the only midi part on the track I can print up solely that section - is that right? ie without bars of rests leading up to that part.

Hi,

You can always print from the Page Mode only. If you are in the Page Mode already, you can print it. If you are not in the Page Mode, Cubase switches to the Page Mode automatically once you call Print function.

The Score Editor (some as other editors in Cubase) are MIDI Part-based, not MIDI/Instrument Track-based. This means, the Score Editor always shows the content of the MIDI Part. If you have multiple MIDI Parts at one MIDI Track, you have to select all of them to be able to print all data on the track. And vice versa. If you want to print just a bit of the MIDI Part, just cut/split the MIDI Part and isolate the notes, you want to print.

The problem I find is that I cut the midi part and open the page mode and then print - I get several pages of rests - then the part I want.

If I create a new track and copy just the midi part i want on to that part i seem to be able to print outside of page mode and it simply prints the section I want which is preferable.

good.pdf (13.8 KB)
bad.pdf (23.1 KB)

Hi,

If you want to print only the 78-81 bars, change the size of the MIDI Part. Reduce it to the 78-81 bars.

Yeah I’ve done that - and that’s when I get the rests. It only seems to work without the rests if there is only one midi part on the track.

I guess you’re saying to me glue all the parts together and then reduce the size of the midi part to just the bars I need - but it’s useful to have the differing sections as separate parts.

I’ll just continue to do what I’m doing - create a new midi track and copy the part over - print the part. Move on to next part.

Hi,

Sorry, maybe I didn’t get you. What’s your goal then?

I wanted to be able to end up with a printable part like the ‘good’ file above without have to create a new midi track and copy the midi part over from the original so it’s the only midi part on the track.

Apologies if I’m not being clear. I’ve got a workable solution now anyway - I didn’t initially realise it had to be the only midi part on the midi track.

Hi,

Then just cut he MIDI Part for the bars 78-81, that’s it. You could have multiple MIDI Parts on the track. If you select only the MIDI Part, which is at bars 78-81, you an print just this MIDI Part.

Thats what I’m saying though Martin - When I do that it gives me several pages of rests up to that point which is the ‘bad’ file

Hi,

One more thing. Are you aware of this Preferences: Score > Editing > Unlock Layout When Wditing Single Parts.

You can find more about it in the manual.

Does it help to your use case?

Aha! Thankyou Martin. Thats what I’m looking for.

Hi,

Actually, the thanks come to @steve. :wink:

2 Likes

Hi @Manike, just a question: are you using Cubase 10.5?

No I’m using Cubase 11

Thanks @steve

Hi,

I have tested this. Here is the description in the manual.

It works for me in the Page Mode. It doesn’t work in the non-page mode, what is an expected behaviour, I would say.

Actually it works, if you open the Score editor in the Page Mode. Then you can even switch to the non-page mode and it works. But if you open the Score editor in the non-page mode and then enable the Page Mode, it doesn’t work.