Printing to pdf - Text frames don't display in Acrobat Reader but do display in other pdf readers

I’m working on a theatrical project that requires me to send rough drafts in pdf to the writers & producer from time to time. To help them know where I am in the script I make a text frame in Engraving mode with white background to the text, copy the relevant script into the frame and position it on to a part of the score that has empty bars.

I’ve found that if I then use the Print to Graphics dialogue in Dorico, Acrobat Reader won’t display the text frames in the resulting file (though everything else is fine), and instead I get this error message.

However, the same file will display perfectly in Foxit Reader & FlexiPDF. Not a huge problem except where the recipients are using Acrobat, which unfortunately they mostly are…

The current workaround is to do something that I think we’ve been advised against somewhere else on the forum, namely use the Printer dialogue to print to ‘Microsoft Print to PDF’, and this produces a file that displays perfectly in Acrobat.

Is this a bug, or am I not doing something right?

I tried this and it works for me on Windows with the latest version of Adobe Reader (2019.012.20035.)

Maybe your clients have an old version of Adobe?

Can you post a problem PDF to see if other people here can read it? (You will have to make a zip file).

IIRC Microsoft “print to PDF” tends to create enormous PDFs - I don’t know what other problems it might have.

Thanks Rob
This is just the first page. I have the same version of Acrobat as you.
01 - Full score - Scene 6 1st page (46.9 KB)
On my computer It displays the error message with Acrobat, but opens correctly with Foxit, and also with Chrome & Edge both of which appear as options if you right click & select ‘Open with’.
I noticed this when checking before sending to the client(s) so I sent them the Microsoft version instead, though it’s surely unlikely to be just an idiosyncrasy of my computer!

It displays correctly for me. Adobe Acrobat Pro 11.

I get the same error as you in with your score in Adobe Reader (not Pro!), but it opens fine in Sumatra PDF reader, to add to the list of “successes”.

But I just made this demo and that opens OK in Adobe Reader for me…
White text background (17 KB)

It opens fine in Preview — important if anyone is using a Mac.

Ahhh - I wonder if your problem is a font issue, not specific to text boxes.

Scanning through your PDF you have Bravura, Bravura Text, Academico, Academico bold, and then

<< /Type /Font
/Subtype /CIDFontType2

which is (1) apparently installed just for your user account, not globally (which seems to have caused problems with some other fonts) and (2) not shipped with Dorico or Windows (though Wikipedia says it is shipped with MacOS).

What happens if you change the font to Academico, or a standard Windows font?

I don’t have American Typewriter on my Windows PC.

Yes! That’s it!
Changing the text box font to Academico seems to give perfect results.
The librettists have decided to use American Typewriter for this project & currently prefer to have all the text in that font so I had to source & install it. But they are Apple tarts & use Macs. They’re going to have to accept Academico for the musical documents from now on!
Many thanks to you all for helping sort this.

Try installing the font for all users, not just for your user account. That might be enough to fix it.

Thanks. What I’ve learned so far is that right clicking on the font file gives an option to install for all users, which I hadn’t seen before.
However, doing that doesn’t actually make any difference to the inability of Acrobat Reader to see the text in a Windows environment, even though other non-Adobe pdf reading apps have no problem.
Now that I know this happens I can work around it & it’s not that big a deal. Just something to remember in future.
Or is there something about the way Dorico creates pdfs that does this (seeing as how it doesn’t happen in Microsoft Print to pdf)?
Anyway, not really worth worrying about right now!

Sorry, a few weeks late but just saw this thread and found something interesting while testing on Windows 10. If I open Steve’s file in Acrobat Pro DC and go to Properties/Fonts here is what I find:

Only Academico is actually embedded in the file. Any other font must be local and as I don’t have the American Typewriter font Rob mentioned either, it doesn’t display for me.

When I open the file Rob posted, here are the embedded fonts:

I’m assuming everything is embedded correctly in Rob’s file. I decided to test some exports of my own and was very surprised to find that if I select Adobe PDF as my printer, and create the PDF by “printing” to file, NO fonts at all are embedded! In my Adobe PDF Printing Preferences defaults, I have “Rely on system fonts only” unchecked by default, but I get the same result from Dorico with this checked or unchecked. When creating a PDF using Adobe PDF as the printer from literally every other program I have installed on my system (including Finale), the fonts are embedded correctly.

If I create a PDF from Dorico using Graphics/Export then all fonts are embedded correctly. Obviously this is the way to go for me when creating PDFs in Dorico, plus there’s the benefit of the filename options. I am curious though what Dorico is doing that is bypassing the font embedding settings when using Adobe PDF. As far as I can tell, here’s no way to print from Dorico while accessing the printing preferences, so I’m not sure how it is actually using the Adobe PDF settings. It seems like it is overriding the “Rely on system fonts only” setting and not embedding anything. Does anyone else get these same results?

Fred, this comes up fairly frequently. The long and short of it is that unless you have a very good reason (such as needing to use stretched/kerned characters) you should use Dorico’s Graphics Export function.

Got it, I definitely will, thanks!