Pro 9.5 'Edit in place' Instance crash

Using a short cut to activate ‘Edit in Place’ (Cubase default: ctrl shift I) causes crash.

Hard to pin down exact steps of cause. I’ve listed in order, 1 after the other, what i believed to be the cause before ruling it out.

  1. Hardware tracks set up as VST.
  2. Only if not activating edit in place via the little button first.
  3. If the project doesn’t have ‘Edit in Place’ button added to the tracks in the setting menu.
  4. Old projects
  5. Projects loaded that hadn’t already been saved before a crash with the new settings of ‘Edit in Place’ button been added.

Opening an old project and testing the short cut key on 1 (as above) caused an instant crash every time. Once I saved the project before crashing it, with the ‘Edit in place’ button added from the setting menu, this ceased to be the case. The crash everytime must of been due to that setting reverting. as settings changed before a crash aren’t saved.

When i load a fresh project with ‘Edit in place’ button already added to the track in the settings, it’s harder to recreate the crash.

Have the same problem on Mac. I had success recreating the crash which seems to be load dependant. Here’s a link to my thread: https://www.steinberg.net/forums/viewtopic.php?f=253&t=127736

You can try opening a project that you know has crashed and try to crash it by deleting a larger midi clip from a track and then swiftly opening in-place editor for the same track. To verify try also to do the same thing but wait a couple of seconds before opening the in-place editor and it should not crash.

I’ll have to try that later.

More crashes today. Here’s a crashlog.
crash1.zip (32.3 KB)

Same problem here. Windows 7

I have this too - windows 7.

Hey, I found this on Google when I had this issue on a fresh install, for future visitors, this issue was resolved in version 9.510