Probable bug Dorico 3, Windows 10 - 64bit.

Hello,
I installed on my computer, with Windows vers. 10 to 64bit, Dorico version 3, but I found a problem that, comparing myself with a friend who owns Mac and Dorico vers. 3, he does not have.
Seeing what I’m talking about in the video is easier.
Is there any solution?

Thanks

Adriano Trasatti



https://www.youtube.com/watch?v=Ln-lMGlzl8s&feature=youtu.be

I don’t understand. You typed a B natural, then you added a key signature of F major. Dorico shows the natural next to the B, because you now have a Bb in the key signature. What’s the “bug”?

Adding a key signature does not transpose or otherwise edit the existing music.

If I pass from a score in C major (without changes in key) to F major (1 B flat), the Si does not become bequadro.
Do you agree?

Yes, that’s correct. Let me repeat: adding a key signature does not change the pitches of existing notes.

Dorico is working correctly, and it is exactly the same on Mac as on Windows.

I had the example repeated by a friend of mine who has a mac and there is no change. The Si remains without the bequadro.

Dorico works the same way on Windows and Mac in this (and every other) regard: adding a key signature does not change the pitch of existing notes.

It could be that your friend’s Notation Options are set to never show accidentals, but that would be an unusual (by which I mean dangerous) way of writing.

I do not know what to say.
In the video it is clear that the bequadro is added, when it should not be so.

If you want to change a B natural to a B flat, you need to do so manually. Dorico will not rewrite your original music when you add a key signature. It’s the way it’s supposed to work, and it’s the way it always will work.

He did the same procedure I did:
new document, creating a staff for piano, inserting notes without time or tone.
Then insert the key and it does not happen that the bequadro is inserted.

Yeah, but he could have saved his Notation Options as Default, meaning that every new document starts with those settings.

I’m very happy to demonstrate Dorico’s behaviour on a Mac later today, but it wouldn’t prove anything, just as your friend’s demonstration doesn’t prove anything.

The way that Dorico is behaving on your computer is correct.

Correct?
So if I transcribe a score in C and then I want to transport it to F major, do I have to expect all Si to have the bequadro?

No, you use the Transpose function. Adding a key signature is not the same thing as transposing.

Ok, but it seems strange to me that the procedure done on two different operating systems gives different answers.

The only explanation is that your friend has set Notation Options, or has explicitly set that accidental to hide.

Again, I’m very happy to demonstrate Dorico on Mac working exactly the same way as Dorico on your Windows computer. This is nothing to do with Mac vs Windows.

Okay, my inexperience with Dorico will make me have these doubts.
Many thanks to everyone.

just to echo pianoleo, I think you’re wanting to transpose from C to F major in which case the whole score would go up a fourth (or down a fifth) then of course the Bb would fit. But it looks like you’re sorted now!

The fact is that I noticed that if I insert the notes without tone, the natural si appears.
If I subsequently insert the key of F Major, the bequadro appears.
While if first of all, I insert the tonality and subsequently the notes, the si does not have the bequadro.
And this made me believe that there was a mistake.