Probleam with Arturia mkII 88 Note in Cubase

Hello to you, I hope you can help me,
I recently bought the Arturia KeyLab Mkii 88 notes and voila, when I open applications like Piano V2 or Analog lab I have no problem, my piano works fine, my Substain pedal works very well too and the result is really great by the way the latest update (1.3.1) is installed. The problem happens when I open these applications in Cubase 13, My Substain pedal doesn’t react, the piano transposes itself when I’m playing. And by the way, I have a key that doesn’t work at all (the D key of the third octave). The MIDI control center (application by Arturia) detects my piano at the start, and when I come back to it nothing is connected. Here I am, trapped and looking for a million tutorials to solve this problem. The problem is that all my peripherals are up to date, and everything works fine with arturia’s software except the midi control center which detects and disconnects my piano, is this normal?Is there a step I forgot? I don’t know what to do because I can’t record right now because even after 1 minute of piano in Cubase 13 the piano transposes itself going from one octave to another, but only on Cubase. By the way, I’ve tried to get the DAW to work and I can’t. Does there have a specific way to configure the arturia keylab mkii 88 in Cubase? Thanks in advance -Brandon Scott

Did you follow Arturia’s procedure for installing in Cubase ?

Configure Keylab MKII with Cubase

1 Like

Welcome to this forum!

You have to follow the instructions found in the link below, in order to use the DAW implementation by Arturia:

Here’s a screenshot from the link:

The reason I focused on DAW is because if you for example don’t setup the ports of it properly, can result into strange things, possibly as the ones you’ve described earlier (the D3 not working).

If you have Cubase open at the same time, the midi ports of the Keylab are occupied by it, and since they don’t have multiple instance capability, it can’t be found by the MIDI Control Center. However, if this thing happens even when you have Cubase closed, then I’m afraid there are other problems, such as defective USB cable and/or power supply.

My midi port configuration

Ok, here I am, I followed the tutorial for the DAW! Great it works indeed my D3 key works now, I still have the problem of variations, when I play the volume of the piano can go down or up I don’t understand… By the way, my pan (the buttons to go up or down to the right of the paino) don’t work properly either, I just have to touch one and all that mixing… Lately, when I press my effects pedal, my audio track mutes? What is it?

Sorry, I don’t understand this. Talking about the faders maybe?

Could you post a screenshot of your MIDI Ports Setup as @Freudon did earlier so we can have a look?

I check too for the pedal of Substain, Its now make my track muting with the pedal

I see that you have a midi remote connected to your MIDIIN port of the Keylab. Is this something you’ve created yourself? Most probably this causes your issues.

I took it off, it didn’t do anything, what can I do to fix these problems, I’m still searching…