Problem changing chord symbol G7(♭9) increasing size of "♭"

I am taking a Jazz Harmony course, and the prof recommended I increase the size of the accidentals (ex. the ♭ in G7(♭9)). He also liked the Finale Jazz fonts and not the Dorico ones. MuseJazz emulates the Finale Jazz font pretty closely, so I added the MuseJazz bravura font into Dorico and am using JazzText for chord symbols (since I also own an older Finale, which has JazzText bundled).

To make the flat symbol larger for the (♭9) in the chord symbol editor I found the “♭9” was one unit (instead of the ♭ and 9 being separate), and after double-clicking on the “♭9” part to open it in the glyph editor, I had to delete the combined “♭9” glyph and add the separate units “♭” and “9”. I did that successfully, and that changed the appearance of that chord symbol. However, I quickly found that it did not affect the appearance of the other G7(♭9) chord symbols in the piece. I also cannot copy and paste my updated G7(♭9) symbol anywhere else. I can take the original G7(♭9) chord symbol with the smaller “♭” and copy and paste it elsewhere, but not the one I modified with the larger “♭”. I assume I have happened across some sort of corner case bug due to the way I am doing this edit.

My modified G7(♭9) chord symbol is at the end of bar 16 - I cannot copy and paste it to other bars, if I paste it shows no chord symbol there. The original G7(♭9) symbol is at the end of bar 20 - that one I can copy and paste and the chord symbol appears where I paste.
Piano Voicing Exercise adding (479 KB)

Don’t edit the symbol in Engrave mode, which will only change that one symbol, edit it in Engraving Options/Chord Symbols/Project Default Appearances. After you have changed the b9 composite character to your liking, it will then update everywhere that composite is used, unless you have an individual override that you have done in Engrave mode.

Thanks - that solves the issues.

How can I make Dorico change the appearance (size, position) of every “b” in alterations of chord symbols (7(b9), (b9 b13), different roots)?
Changing the “Chord Music Font”-size is not appropriate, because it changes the size of every musical symbol of used in chord symbols (e.g. slashes for alternating root notes).
I’d request the option to apply defaults for chord elements independently of their root-rotes, so that editing the appearance of C7(b9) is also affecting D7(b9) etc. At least a “copy appearance to all roots” or something like that would be useful. Options for scaling chord-element-sizes (not only spaces between them) more individually would also be welcome.

At the moment you can’t do this, because each alteration – e.g. b9, b13, etc. – is a single unit that has the flat accidental “baked in”. But you should find that if you work through chords that have these alterations in the Project Default chord Symbol Appearances dialog, you can edit each alteration such that the flat is sized and positioned as you want it.

Daniel, thanks for your reply.
For my understanding, may I ask two further questions:

  1. If I change the “Chord Music Font” size, e.g. in a 7(b9)-chord the “b” gets sized independently of the “9”, so what does “baked in” mean exactly? It doesn’t seem to be a special glyph…
  2. If I follow your method of changing settings in “Project Default chord Symbol Appearances dialog”, I have to do it for every root and every chord type/quality? (e.g. C7(b9), C7(b9b13, D7(b9) end E7(b9) need a separate treatment)
  1. You can indeed change the size of the ‘Chord symbol music font’ font style’, but this will of course also change the size of all accidentals, diminished circles, etc. in all chord symbols.

  2. You don’t need to change ‘b9’ for each chord symbol independently. When you input e.g. Cm7b9 into that dialog and select the b9 component in the main editor, look at the grid below the main editor: you will see a ‘b9’ component there. Select that and then click the pencil icon in the action bar to edit that component, which will update it everywhere it’s used.

I might be wrong, but I’ve messed around with customizing chord symbols a lot and I think the “baking in” process is a bit more complicated than initially appears. I’m pretty sure Dorico automatically changes the flat accidental glyph based on the value of the scale factor specified in Chord Symbol/Design before scaling it. This is of course a very desirable thing for Dorico to do, as you would want the flat symbol to be optically sized with the 9, but it means there are multiple flats in play here, depending on your settings.

Here is the flat at 75%

… and here it is at 76%

Those are obviously two totally separate glyphs. My hunch is Dorico is using comp.csymAccidentalFlat for all values 76% and higher and comp.csymAccidentalFlatSmall for values 75% and lower. If you are rebuilding your comp.chordsymbol.kAltered.9.kFlat composite character, be aware there are two possible flats here. Dorico will continue to scale the flat you select, but just be sure you have selected the correct one that you want for your chosen optical size.

Thank you for your help and patience.
Unfortunately I can’t edit the component “b9” because, unlike the other elements, it doesn’t appear in the grid as you can see in this short gif-movie:

If I edit directly by double-clicking the “b9” and change the appearance, only every Cm7b9-chord is affected but no m7b9-chord with a different root.

Maybe I am missing the obvious…?

Thanks again for your help!

After you enter C7b9 in your Project Default Chord Symbol Appearances window (in Engraving Options not clicking on the actual chord symbol in Engrave mode) and double-click on the b9, you are no longer just editing C7b9, you are actually editing your comp.chordsymbol.kAltered.9.kFlat composite character, so your edits will be reflected wherever that composite character is used. You can even delete the C7b9 from your Project Default Chord Symbol Appearances list after editing, as all you really needed was a way to edit the comp.chordsymbol.kAltered.9.kFlat composite character which Dorico will then use for all b9 chords with a single alteration.

To access the b9 that doesn’t appear in the grid below it, double click it to go to the editing window for comp.chordsymbol.kAltered.9.kFlat. On the right hand side click the Composite tab and add either comp.csymAccidentalFlat or comp.csymAccidentalFlatSmall, then add your 9 from the Text tab. Delete the original alteration and position yours as needed. Sometimes I find positioning 2 characters in this window is a little buggy and not always WYSIWYG so you may need to go back and forth a couple of times between Edit Chord Symbol Component window and the Project Default Chord Symbol Appearances window to get everything lined up correctly. On Windows10 I find the display bugs are even worse when editing a double stacked alteration but YMMV. The Project Default Chord Symbol Appearances window is how it will look in the score so don’t necessarily worry if you have to make it look slightly different in the Edit Chord Symbol Component window to get it to display correctly.

Fred, you’re quite right that there are two sets of accidental characters that Dorico uses based on the scale factor defined in Engraving Options, and the threshold is indeed at 75%. The bolder one is designed to compensate for the thinning of the strokes as the accidentals are reduced in size.

Fred, thank you for your explanation.
I did exactly what you describe before and I understand the way this is expected to work - but on my computer, it does not work!

Please watch the short clip, which hopefully illustrates my problem.
You can see, that C7b9 works as expected while D7b9 does not…
(I’ve made the b “too large” here to emphasize the effect.)

Unfortunately, you’re right, Andreas. In order to make sure you are editing the actual default component, it must appear in the grid below the main editor, rather than only within the main editor itself. If you edit it from the main editor, you are editing that individual instance, rather than the default component. I’ll look into why the default component doesn’t appear in the grid below the editor.

Sorry Andreas, I swear that used to work! You are correct that it doesn’t seem to now.