Problem editing with EDO-24 accidentals

Have tried various searches but can’t seem to find the answer.
I need to edit standard 12-EDO accidentals to 24-EDO microtonal accidentals but can’t seem to do so.
I’m in write mode.
The piece has no key signature. I set the tonality system to 24-EDO (that reveals the panel of microtonal intervals).
I select a note in the flow (doesn’t matter if it’s inflected with a flat, sharp or just natural) then click on the accidental I want.

Dorico switches me back to 12-EDO, replaces the 24-EDO accidentals with 12-EDO and indicates the 12-EDO accidental already applied to the note I want to change.

Obviously I’ve missed a step somewhere.
Any help would be most appreciated. Thank you.

Once you’ve selected your tonality system from the dropdown, select a key signature from further down the right panel - probably by setting the number of flats and sharps to none - then click it and drop it onto the score.

If it has no accidentals it’ll show as a non-printable red signpost (assuming signposts are visible). Nonetheless, until it’s there, the tonality system doesn’t exist in your piece, just as if you select a dynamic from the dynamics section of the right panel it doesn’t exist in your piece until you click it onto the page.

Many thanks indeed. Solved.