Problem import midi from EZDrummer2 to Cubase

I´ve got big trubles.
I use EZdrummer to create drumtracks to my songs. But now when I import the midi file to Cubase it´s sounds all wrong.
The tempo and the patterns are all off.
It´s seems that thou the tempo is correct (190 bpm ) the midi file has been stretched out.

I need help

Sorry for my english :unamused:

A few questions that might assist us to solve…

  1. Are you dragging files from the EZD2 browser into Cubase or actually importing a file into Cubase?
  2. Is this happening on only one project?
  3. Did you mistakenly change the Cubase track from “Musical” to “Linear” time?
  4. Is your EZD2 version updated to the latest which is v 2.1.7?
  5. Are you importing to a Cubase “Instrument Track”?
  6. You mentioned that the BPM matches but, does the timing match (ex: 3/4 or 4/4)?
  7. Is the “Preview Original Tempo” button activated in the EZD2 browser?
  8. What Cubase version and computer OS are you using?

Regards :sunglasses:


  1. Tried both dragging and imort the midifile.
  2. No. Tried to create a new projekt. Even tried to import in an old projekt.
  3. Think not
  4. Yes
  5. Yes
  6. No it´s not
  7. LE AI elements 9 – Windows 10

Even tried to factory reset Cubase.
The funny part in this is that i´ve not used Cubase in 6 month. and now when I´ve got my creativity back it f*cks up.

A couple more suggestions/thoughts (hopefully it is the 1st one that solves your issue)…

  • Make sure that “Follow Host” is enabled in the EZD2 browser (a few buttons to the right of the EXD2 transport).
  • Set Cubase to “Run as Administrator”.
  • In the Cubase>Studio>Studio Setup>VST Audio System menu make sure that “Externally clocked” is not checked.
  • What audio interface are you using and are the latest drivers installed for it?
  • Make sure that your audio interface clock source is set to “Internal” timing and that it and your Cubase projects are sync’d to the same sample rate.

Regards :sunglasses:

Think I solved the problem.
“Broken” ASIO Driver
I changed to a DirektX driver and Woila

Thx for your support

Glad you got it sorted. :wink:

Regards :sunglasses: