Problem of exporting patches (program change) in the inspector and in the track

Hello to all

Problem of exporting patches (program change) in the inspector and in the track.
My keyboard is a Tyros, I have installed the device (Yamaha Tyros) in the MIDI device manager.
I tried with several MIDI files, in Cubase 9.5, Cubase 10 and Cubase 11 but the problem persists.
Is this a bug in my OSX 10.14 because when I test in Windows 7, it works?

IMPORT Midi Files to Cubase:
My active Import Options :
Extract First Patch
Extract First Volume/Pan
Import Markers

Thanks for your help


Is your problem on the Import to Cubase or Export from Cubase side, please?

If it’s on the export side, please double-check the Preferences > MIDI > MIDI File > Export Options. Make sure the Eport Inspector Patch is enabled. Export Inserts and Export Sends has to be disabled in this case.

Thank you for this quick answer,
This is for importing MIDI files.

I tried with several MIDI files, in Cubase 9.5, Cubase 10 and Cubase 11 but the problem persists.
Is it a bug in my OSX 10.14 because when I do the test in Windows 7 with Cubase 9.5, it works?
NB : I have activated in the “MIDI file import options” :
x Extract first Patch

On the other hand, for the export of Volume/Pan events it works well, I see them in the MIDI inspector


So, you don’t see the Patch in the Inspector after the Import, am I right?

Yes, that’s right, it’s off


Thanks. Are you sure the Extract Firts Patch option is enabled in the Import Options dialog, right?

Yes, it is well activated.
But I see the program changes in the list editor, is this normal.
Because when the extraction option is activated, the first patch (program change) should not be
in the list editor, but in the track inspector?


You are right. This MIDI Message should be removed from the 1st MIDI Part and it should shown in the Inspector instead.

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Could you share the MIDI File? I could test in on macOS 10.15 here.

I managed to boot into safe boot mode by [Disable preferences], I have important
some MIDI files but the problem persists.
NB: whatever the file, I have the same problem (5.4 KB)


Sorry, I got an error while unzipping the file:
Inappropriate file type or format.

Here, I created it with winrar this time (4.7 KB)

I also send you some pictures.
As you can see, the export options are well activated, and the patches still do not appear in the inspector and in the track.
Everything is off
I’m starting to despair, I’ll try to install Cubase virtually with Parallels Desktop


Could you use native macOS Archive function instead of the Winrar, please?

At the last screenshot, I can see the Patch name is there.

Indeed, the names of the patches are in the track but the extraction is not done towards the program selector, all is turned off whereas in Windows 7, I find well the patches in the inspector and in the track.
Here is the compressed midi file in OSX ; (5.1 KB)


Could you attach the screenshot from Windows 7 for comparison, please?

Hi again Martin,
In fact, I have the same problem under Windows 7, the first events of MIDI Volume and Pan are well extracted and converted (see screenshot 1) but the first events of Program Change and Bank Select are not converted into parameters in the inspector.
There is an anomaly which misled me, if you choose a program (acoustic bass) for channel 1 for example, when you open the same midid file or another one, you find in the inspector the program “acoustic bass” which is not normal.
Do you have this type of behavior at home.
If so, I have the impression that all versions of Cubase are affected by this double problem…


If I import your *.mid file, I can see the Program Change and the Bank Select messages in the Inspector.

See attached screenshot, please.

And why the name of the patches of the devices installed “in the MIDI device manager” or even screenshot “Capture 2”, in my case “Yamaha Tyros” do not appear as parameters in the inspector, it should be the case?
Try to assign a “MIDI device” patch on your side to a MIDI port in the MIDI device manager and check if you can see the patch name in the MIDI inspector please and tell me what you find.

And if I choose trumpet in the bass track, I close Cubase, I open again this MIDI file or another one, the trumpet instrument remains in channel 1.
Is this a normal behavior?


It seems, you are not using the latest Cubase 11, right?

Is the Yamaha Tyros the only one MIDI Port you have available? Does Cubase set this MIDI Port as the default one for the newly created MIDI track?