Problem Recording VST track

I am having problems actually recording a VST track in Cubase LE4. I can hear the VST when I am playing/recording, but the recording does not actually record anything. I have “record enabled” enabled, all MIDI routing seems to be correct, etc. Furthermore, when I record EZDrummer in Cubase, it does record…but when I use other VSTs (Arturia, Native Instruments) nothing records…I attached a screenshot of my Cubase in hopes of identifying the issue. Thanks

Any help? I went through the Getting Started and other Cubase manuals, which while thorough, don’t anticipate this problem…I followed the setup instructions in Getting Started. I was able to record external audio into Cubase, but cannot record VST instruments—I can play/hear the VST instrument fine (so it is not necessarily a general MIDI issue)—it is recording where I have the issue.

Hoping someone here can help. Steinberg responded that since this is an OEM product (or some similar acronym), they have nothing to do with it—so good luck with the product you purchased from us.

If someone out there can help, I’d really appreciate it—this is insanely frustrating to come home from work and tinker with it for an hour or two every night, and so far work on it half of Saturday getting no further than I was before.

We really need more information here. The screenshot is a good start. I recommend switching to something included in Cubase. I am not familiar with your version but if it has Prologue or some version of Halion/Halion Sonic try that as the synth. I am not familiar with Sample Tank or how it works. In your photo, there is an instrument track with a MIDI Part but, yes, it looks to have no MIDI notes in it. To be clear, you do realize that the instrument track records the MIDI notes that you play and NOT the audio sound produced by the VST instrument, correct? Also, (sorry :blush: ) you are pressing “record” on the transport? Not just arming the record on the track and pressing play?

Thanks. You are correct, it is not recording MIDI notes. On a previous computer, I was able to record VSTs without problem so I understand that Cubase is only recording a MIDI note which is triggering the VST—I understand it is not recording audio. Now, Cubase is not recording those MIDI notes when I record, but I can of course hear the VST instrument when I am playing/recording—its just nothing is being recorded.

Also, yes I am pressing the record button when I record. I have record enabled selected, but am also pressing the record button. Like I said in my 2nd post, I was able to record external audio. Like I said in my 1st post, I am able to record midi notes with EZDrummer—however, with EZDrummer, the patterns are already created…you click/drag/drop a pattern into Cubase, so that may be helpful in diagnosing the issue.

I got some more screen shots, as I think it is probably a setting in the setup or maybe a driver issue. Pictures include (1) another screen shot of the main Cubase screen with a VST instrument loaded—this picture was taken after I attempted to record, so you can see no midi notes recorded; (2) device setup screen; (3) midi device screen; (4) vst connections screen. Sorry, I know you recommended using HALion which I do have, but HALion seems to have its own issues, so I used the vst instrument Arturia Jupiter 8V in this scenario. This issue happens with all my VST instruments—I have been trying to fix the issue with Native Instruments’ FM8, and as you noted, I was also using SampleTank for orchestral samples in the first screenshot.

THANK YOU for your help—means a lot to me.

This screenshot was blocked from my last post for some reason.

Also, may be helpful for you to know what PC/Audio/MIDI setup I am using:

PC: Intel i72600 8GB RAM 3.4ghz
Windows 7 64-bit
Midi input: M-Audio Keystation 88es
Midi output/soundcard: Alesis MultiMix8 USB 2.0

If the track had not recorded anything, the MIDI part would disappear after pressing “stop”. Have you checked “Device → device setup → MIDI port setup” “use system timestamp” for your MIDI ports.
Or you maybe have a note record filter activated.

Are you trying to record using the keyboard on the VSTi? If so, you can’t. If no, provide a screenshot of MIDI Port Config. You should set up your device there to not be included in All MIDI Inputs and select that specific port as the input of the track.

Thanks for the suggestions. When I record, no MIDI notes are showing as being recorded—I can see the output/monitor showing activity as I play, but no MIDI notes are actually showing/recorded on the track.

I went to Devices:Device Mgr: MIDI Port Setup and selected the Use System Timestamp for MIDI ports and this had no effect.

How would I check/change the MIDI note filter issue you mentioned?

If screenshots of anything else would be useful, please let me know. Thanks

I was refering to the virtual keyboard, not a physical one. In your SS, the record and monitor buttons aren’t enabled. Like I said, the Emulated Ports are probably what’s needed.

What happened to your last post? :confused:

MashedMitten, I am using an external MIDI keyboard for this. I think I attached a screenshot of what you referenced. I have tried rendering the first row inactive and activating some of the other rows in trial/error, and was unable to render the other rows active.

Thanks for the help everyone…I’m feeling much less depressed about the situation now.

Sorry, I deleted the original post when I realized you were talking about the VSTi keyboard. When I use the SS software, it changes some of the things on my screen for some reason…The record and monitor buttons are enabled when I record/playback—I’ve tried various configurations of those with no luck.

I was speaking of un-checking the All MIDI Inputs box there and selecting the Keystation’s specific port as the input of the track. I have the Prokeys 88 by M-Audio and it requires the Emulated ports if connected via USB.

MashedMitten, when I unselect the “In ‘All Inputs’” box, it renders the Keystation “In” MIDI Port Setup as Inactive. I can’t seem to activate anything unless I select the “All Inputs” again[productfamily]=2

All active means is that the port is selected on a track. If you select the KS as the input, it’s port will show as active. Look to the link above re: Emulated Ports.

Ok this is getting confusing now , with two people posting differenbt things, so sorry, but concerning your last screenshot:
Your MIDI In port is shown as “DirectMusic” Input Port. The use system timestamp-option is checked for “WindowsMIDI” Input Ports only. Did you check with the other option enabled also…?
The MIDI filters are in preferences, but if you´re only recording note information (no controllers), it probably isn´t that.

haha…weird…i was starting to try MashedMitten’s suggestion with the emulated ports…this subject matter seems pretty complicated, so i was just starting to mess around with the suggestions in the FAQ. i was trying some of these suggestions with no initial luck, came back to make sure I got everything from MashedMitten’s post and saw ThinkingCap’s post, so as a brief diversion from MashedMitten’s path, I tried ThinkingCap’s suggestion. The combination of the two appears to have worked. I am now recording MIDI notes in the VST—I probably do not have it completely setup right though since I stumbled into this, but I am very relieved to get this functioning to this level. I’ll continue to explore MashedMitten’s suggested FAQ.

Thanks for the help guys—I found a couple old posts on this forum with people experiencing similar issues, and some of the responses were pretty degrading/demoralizing to the OP. Clearly, this is not an obvious fix—it is something I never would have got by myself, regardless how many times I read the included manuals. Anyways, I think your responses will be useful for future users experiencing this issue.

I realize you said you are getting it to work, but here is an m-audio Knowledge base about the timestamp.