Problem Setting up Roland TB3

Hello,

I could need some of your help. I got myself my first hardware synth, Roland TB-3 and I have some problems setting it up.

  1. How can I send MIDI data from Cubase Sequencer to TB3, for example If I draw midi notes manually or want to use VST sequencer, like Kirnu, to control TB3?

  2. How can I use Extrenal Instrument Inputs and record at the same time?

Now when I switch to External Instrument Inputs, my Stereo In - inputs are disabled, and vice versa.

I made a private video, you can see what I have been able to do. But I have seen videos where TB3 is fully controlled by DAW, but I have no idea how to do it.

I hope you can help me.

https://youtu.be/GalD5UXcqHk

Hi,

The Stereo In is set to Not Connected, therefore you don’t get any signal from Stereo In.

You can use the Instrument track for TB-3 when working on the project. Once you would would export it to final WAV (Export Audio Mixdown), you would export it in real time. The TB-3 signal would be recorded to the mixdown.

Yes. I finally managed to get some sound when I play with On-Screen Keyboard. I had the wrong midi channel selected. I had midi channel 1, as it’s supposed to be 2. Also I noticed that I cannot send and receive midi-note data at the same time to the instrument and from the instrument. That gave me some very interesting sounds from the TB-3 while trying to record. I guess I just need to manually disable any midi sends when recording?

What I mean is I have when I was recording:

MIDI IN: TB-3
MIDI OUT: TB-3

So that creates a conflict. As I turned on sequencer from TB3, that sent data to Cubase, and Cubase sends that data back to TB3. At least that is something I was experiencing. I got double notes and all kinds of funny behaviour. So I guess I need to disable Midi Out while recording. Well,

I am learning. This is my first hardware gear so this is very different from VSTs…much harder unfortunately :laughing:

Anyway, I keep on fiddling with the settings. I learn as I go. At least I got some sound out of it.

Hi,

Set Local Control Off at your TB-3.

At this moment, you send the MIDI data from the TB-3 keyboard to the internal synth engine (thanks to Local Control On) and also to Cubase and from Cubase back to TB-3. So the sound is doubled in TB-3.

Well, I have not tried that yet! Can I still play TB3 with my cubase if I set Local Control Off? Gotta try that! Thanks!

Hi,

Definitely. By Local Control Off you disconnect TB-3 keyboard from its sound engine. So you will not send the MIDI data from TB-3 to the synth directly, you will send it thru Cubase.

I see!

Do you have any tips how to stop TB-3 step sequencer starting every time I press “play” on Cubase Transport menu? So far I’ve always disconnected the external sync - It’s quite a hassle to do it everytime. Like In my arturia keystep, there is “armed” function. So It does not start the sequencer unless I press play on the keyboard as well. But TB3 starts running every time.

Do you know if there is any such funtion or how it could be done in TB-3?

Hi,

Sorry, I don’t know TB-3 at all.

That’s Ok. But now I tried what you suggested and turned off Local Control. And you know what? No more funny behaviour and now I can even easily render audio in place :slight_smile: And thanks to Cubase 11 and improved midi CC “automation”, It’s so easy so do nice smooth filters etc.

Thank you so much for the help!