Problem to load multiple Kontakt instances

Hi there. I recently made a mock-up of the first bars of ride of the valkyries with my sample Modeling and Aaron venture infinite instruments. When I was setting it up, it was playing without glitches. So I think my m1 Mac has enough ram and cpu is strong enough. But when I open it now, it loads forever. When I restart the project (after 30 minutes or more) Dorico crashes. After forcing it to quit a can’t reopen it. It gets stuck in audio initialisation (?). I have to restart my computer. I only managed to open it one time.
All other programs are off.

Is this a known issue? Is there a solution?

You will only get a sensible answer if you upload your diagnostics (Help>Create Diagnostic Report)

Thanks (again).

When should I create the diagnostic report? After the restart? Or when it loads forever?

If it loads to the hub - you can create it from there (it holds data from the last 10 or so starts).

1 Like

Dorico (2.3 MB)
Here it is

It looks like the audio engine is hanging or freezing. I suggest you restart your computer, then run Dorico and see if your project will open. If it won’t, then while it is loading, please create a spindump, zip it up and attach it here:

1 Like

Thanks for the diagnostics.
According to the logs the audio engine is loading something like 20 Kontakt instances for that valkurie piece, is that to be expected?
And how about other, smaller projects, do they play back?

if I understand correctly, when Kontakt uses a lot of instances, rather than using multis within Kontakt, it uses much more RAM. I think this is the (or at least one ) reason why NPPE uses far more memory than loading the same patches either a with smaller number of multis or through something like VE Pro. So I’m wondering what happens if you restructure the project to reduce the actual number of Kontakt instances?

Thanks for the reply, Ulf. Its 24 Kontakt instances. But as I said. once it loads it plays back seamless. When it crashes, I have to restart the computer. Smaller Projects load with no problem.

Meanwhile I figured out, that it might have to do with my apollo interface. When my laptop is plugged of, it loads better.

This report I created, when Dorico loaded for ever…
Dorico (2.8 MB) (466.0 KB)

This I created when I de- and reactivated the project an Dorico didn’t react anymore…

Spindump (322.1 KB)
This I created while Dorico didn’t load at all (was for audio initialization)

Hi Major81,
from the spindump it looks like the audio engine gets stuck because Kontakt is choking on retrieving the plug-in state from the project data.
To prove the point, it would be good to get 2 or 3 spindumps in a row (during loading the project) . Thank you very much.

Should it prove my point, then we better hand over the case to Native Instruments, in order that they can have a look in the debugger.

Additionally, if you send me that project, I can cut out the audio engine part of the data and by that make it loadable again. But it goes without saying, you’d then need to reapply the playback template and you’d lose all the plug-in state information.
Let me know if that is an option for you.

I noticed, that I was using Dorico in Rosetta-Mode, because I was updating it before updating NP. In Native-Mode I had no Problems. But now it takes minutes to load Dorico (doesn’t react in audio initialization) (with no Project).
I created a Pinup, hoping this is of any use for you.

Spindump (549.5 KB)

And how about that project, does that finally load in native mode? We need to work out, if there is only one issue or two or more of them.

O problems since I use it in native mode. Thank you for your efforts

1 Like

Well a solution could be next time to freeze your Kontakt tracks or even render every tracks . I do that all the time to avoid this kind of situation. Especially if you put a project aside for many weeks and the come back it needs to be simple to re enter and continue the work. Well anyway this is what I do I hope it helps for the future. Freezing tracks (or render it) is a good habit I think even if you dont mix right away

i do that in Cubase. Is it possible in Dorico?