Problem w/ flange/phase/hollow recordings.

For some reason, when I playback my recordings in Cubase 6 it sounds hollow/phasey/flangy. Funny part is that WHILE I am recording or simply playing my VST instrument (practicing on a midi board) in Cubase, everything sounds normal. Just the recordings sould off. Another kicker is that if I play notes using the transport control keyboard and record those, the recording is just fine.
I’ve connected different midi controllers and gotten the same problem. I’ve tried different VST’s (Synthogy/EWQL), again same result. I must have accidentally hit some button…
What might I have accidentally done to cause this? I’ve explored all I can on my own and have accepted defeat. I need your help.

Don’t select “All MIDI Inputs” as input for your MIDI/VSTi track, but the precific port your keyboard is connected to.
Another option is to go MIDI Port Setup and make sure you have not selected multiple drivers for your MIDI input on “In ‘All Inputs’” column.

It’s curious that the music sounds OK while you’re recording but not when simply playing back the recorded MIDI track. Usually the kind of sound you describe is due to having the same MIDI data sent twice (almost) simultaneously to the VST instrument. Since this seems to be happening with the recorded MIDI data, but not when you’re doing the recording, that suggests there are duplicated notes during playback but not during recording. If that’s really true, you have to ask where the duplicated notes come from during playback.

Two things I’m wondering about …

  1. Do you change the MIDI track setting from “All” during recording to a specific channel during playback? And is it feasible that your controller is sending the MIDI data on two separate channels. If so, you could have two or more “copies” of your data being recorded (with different MIDI channels), but only one being played by the VST instruemnt during recording; changing the channel to a specific number could then direct all the “copies” to the VST instrument. Look at the MIDI track in list edit to see if all the notes appear twice (with different MIDI channesl).

  2. Are you sending MIDI data from Cubase to your controller, and, if so, is is possible that that’s being routed back into Cubase, causing the notes to be played twice - from the track that’s playing back, and from the looped back MIDI data. Equivalently, is there any other way that MIDI data from playback could be being routed back as an input?

Yup, the MIDI notes were doubled.

I was able to recreate the problem after I knew how to solve it. Your suggestions saved the day and my hairline. In ‘device setup’ I had 2 midi ins set as active. They are ‘fast track pro in’ and ‘3-fast track pro midi in’. I don’t know why there are two ‘ftp’s’ but I turned the ‘3-ftp’ to inactive and individually switched the “All Midi inputs” to “Fast Track Pro” for each track and the problem is no more:).

I’ve got to now go explore the Midi Setup in List Edit to further my understanding.

I appreciate your guidance and thoughtful suggestions. I love this forum!

That’s because Windows has 2 kinds of MIDI drivers: Windows MIDI and DirectX MIDI. If your keyboard has both of them installed, it will show up to applications as 2 keyboards.

More information in this article:
http://www.soundonsound.com/sos/dec07/articles/cubasetech_1207.htm