Problem with audio playback


I just started using a new computer (MacBook Air) and because of that I’m in the process of downloading Dorico again. The program itself and HALion symphonic orchestra worked just fine to download but the Dorico Playback 2 – orchestra library just says error everytime, and the playback (I think because of this) doesn’t work in any projects. I’ve used the Steinberg Download Assistant with all of the three. Any idea why this is?

I don’t know why you would be having problems downloading the content via SDA, but perhaps you could try the direct download link from this page?

Hi! I have Dorico Pro 2, not the latest update. Does the Dorico 3 Sound Installer still work with this update? I downloaded the Dorico 3 HALion sounds and it worked, unlike the one from the Steinberg Assistant, but the playback still doesn’t work. When I press play (P) nothing happens, the green line just stands still.

That with the playback not starting is a different problem. Try going to Edit > Device Setup and in there change the sample rate, wait 3 seconds and switch it back again. Does playback then start?
If not, please choose from Dorico’s main menu Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

1 Like

Thanks! The playback started now! If I choose the Symphonic orchestra in Play-settings there is sound also, but still no sound when I use the HALion Sonic. Why is this?


Please post a diagnostics report. Thanks

Dorico (273.3 KB)

Here it is!

Thanks for the data. When you say that HALion Sonic is not working, you mean the HALion Sonic Playback Template, right?
Because HALion Sonic is also used as a player for the Symphonic Orchestra and that one doe s work for you, as you say.
But I do wonder, because from the log it appears that you have all contents file installed.
If you start a new project with the Solo Piano template, does that sound with you?
Because the piano sound comes from the HALion Sonic library.
And btw, the log file is cut off and incomplete. Could you please create another diagnosics and attach here? Thanks

The Solo Piano template does sound! So maybe it is working now… Here is a new diagnostic anyway:

Dorico (328.7 KB)

From the log I can’t see anything unusual, so let’s assume that it is working now. But shout out again if you find something suspicious, then we’ll have a look again.

Yup, thanks for the help anyways! Will do!

Hi again! I’m having the same problems again with the playback, no sound even if I change the sample rate. Here is a diagnostics report:
Dorico (337.8 KB)

Hi Hugo, please stop Dorico and delete the file /Users/“yourname”/Library/Preferences/VSTAudioEngine2/PortSetup.xml and then restart Dorico. Still the same problem then? If so, please post another diagnostics report. Thanks

OK, thanksWhere do I find this file?


Wrong OS: my bad.

No, that is a Mac path. To get there, open a Finder window and then in one of the Finder menus is the item “Go to”. Click on that and type in “Library” without the quotes, then enter. A new Finder window opens from where you can navigate further to Preferences/VSTAudioEngine2

Couldn’t find the file – but when I started up Dorico again the sound was working. Any idea why it’s so inconsistent? Also, the sound plays from my computers speakers even when I have earphones plugged in… Other sound outputs, for example YouTube videos play fine through the headphones.

Sorry, really can’t tell anymore. You are on Dorico 2, which is already quite old. We fixed many issues in Dorico 3 and 3.5, could be that that runs more the way it should.

Hm, okay, Bummer. So does that mean that the version I have is practically useless? And that I would have to pay for a whole new upgrade in order for Dorico to work?

Presumably you just paid for a whole new computer.
You could try using the 3.5 demo to retrieve your files in case you wanted to save them in XML to transfer them to another program or do audio exports.