Problem with behringer bcf2000 in cubase 8.5

Hi!
I´m new here so I don´t know if this is the right forum but I´ll ask anyway…
I´m having problem with my midi controller in cubase 8.5 artist.
I´m using Behringer bcf2000, i´ve done the installation and everything.
What i´ve done is:
reset the bcf to global settings
choose the bcf in mackie control
The faders, start and stop works fine but the eq is not functioning and probably the other features you can do with it…
I also get sounds/tones from my instruments when I press any bottons on my bcf…
It is probably an easy fix but I could need the help, I´m a musician and not a computer engineer so for me it´s a big problem to solve.
Could anyone help me out?
/Daniel

Hi and welcome,

To be able to control EQ, or other parameters, you have to press dedicated button on the Mackie Control HW. Then the V-Pots control other parameters. I’m not 100% BCF2000 can send these MIDI messages.

This is the template for Mackie Control HW.

If you can hear the Notes, when you press any button on your BCF, you have to remove the BCF MIDI Port from the “All MIDI Inputs”. Do so in Devices > Device Setup > MIDI Port Setup. In the yellow part (inputs), disable the BCF 2000 MIDI port from the “In All MIDI” column.

Hi again,
I got rid of the funny sounds from my BCF when I disabled the “in all midi”, so thanks for that!
I still run my BCF in mackie control mode so the faders works and I figured out how the EQ works on the HW.
The INSERTS didn´t work the way I wanted, so I use “quick controls” in cubase instead, I learned my 8 roterys in the "device setup - Track quick controls, so they all works.
My new problem is that for ex:
I put mix from a reverb to slot 1.
Then I turn the rotery clockwise and it increases the mix, no problem.
When I turn it back to reduce the mix, it goes all the way down to 0. from 100 to 0.
My settings for it in track control mode is:
quickControl 1 - controller - midi ch 1 - adr 16 - max v. 127 - flags R,T,R.
What am I doing wrong?
/Daniél

Hi,

Is the issue with the max value? Would you expect 127?

I´m not really shure I know what that is, no more than the higher value the smoother it gets.
I can tell you this tho if I do exactly the same but with a fader, i´ll get the smoothness i want, 0 - 100% and 100 - 0.
It works perfecly! with the “flags” receive and relative.
When it comes to the encoder ( just learned the right name for it) with the same settings I can turn it about 2 laps to reach 100 with the value of 127.
but when I just touch it in the opposite direction it´s like an off button.
Hard to explain, hope you understand.

Hi,

The question is, what does the encoders really sent. If you are using Mackie template, the V-Pots (encoders) of the real Mackie Control sends just Increment/Decrement. It doesn’t sent the real values, like faders do. Depends on the speed, it sends higher Inc/Dec or lower Inc/dec.

so how would I know what it sends? before I started with the quick controls, the v-pots sent for ex the EQ or PAN as they should.
What I want here is to work like this:
https://www.youtube.com/watch?v=Fi51PyTSyVg
I´ve done exactly how it´s done in the video besides that I need to enable the FLAG Relative.
I don´t think i´m going to solve this with the BCF, maybe it´s limited or something for this kind of function.
I can problebly make my own preset in it to make it work but that is too advanced for me and the manual isn´t of any help.
I just have to make it work as it is. Hahahah

Another question, I´ve connected my BCF with USB cable, does it matter if I use USB or MIDI?

Hi,

To check what data BCF2000 sends use any MIDI Monitor. Then you will see if the real Value i sent or the inc/dec.

I’m afraid you cannot do the same with BCF2000, if you want to keep the BCF2000 faders to act as the Mackie Control.

I would expect, you would connect the MIDI cable to any MIDI> USB Device anyway. Then direct USB is better.