problem with black thumbnails showing in video track

Hello All,
I have a feeling that my problem is something simple, but I can’t search the old feeds and I don’t have the time to go through the archive page by page and I haven’t found an answer with a google search. Anyway, here’s my problem:

I’m for the first time trying to use the video editing functionality of my Cubase LE4. I imported a video clip into the track (about a 30 sec clip, avi @ 24 fps). When I first dragged the clip in, it showed images for about the first 7 seconds and all the other frames were black. I tried to resize the track and all the frames became black as soon as I let go of the mouse. Now, as I resize, I’ll see the thumbnails (for the same 7 sec) and then back to black frames when I let go. I tried changing the video cache size and unchecked (then re-checked) the show thumbnails box in the preferences, but it didn’t seem to change anything. So, please let me know if you know what would cause this. Thank you

(I haven’t re-done my signature yet, but will update w/ operating specs and such soon. I wish I could just copy and paste from, but what are you going to do)