Problem with installing Steinberg related apps, incl. Cubase 11

I am having a problem with installing most of the .exe from Steinberg. The goal is to install Cubase 11 Pro.
I have downloaded eLicenserControlSetup.exe and this installation went fine. Then I downloaded Library Manager; the installation starts and then quickly vanishes with no notification or whatsoever.
The same happens with Cubase 11.0.41 Installer - it starts the installation and then the installation box disappears.
When I tried to handle installations via Steinberg Assistant I immediately got an error as shown on the screenshot.

I’m on Windows 10 Pro, opening all the files as an administrator. Could anyone help? It’s been very frustrating.

Is your Windows 64bit?

Try to uninstall all previous installs of all Steinberg related stuff like Download assistant and elicenser center… reboot your system…then start with Steinberg Download Assistant as fresh install.
This will install eLicenser control center and the Steinberg Library Manager as well.

There is no needto run it as Adminstrator…normally…

Thanks for helping. Yes, it’s Win 64bit. I’ve uninstalled all the products having “Steinberg” in it’s name but not sure about Elicenser, so I’ll do that again and let you know. I have also cleared a Windows registry by some automatic tool that I got from my AVG Antivirus program. No luck either.

No luck. The same error in (…)


I can see Java in the log. Could you try to install Java, please?

I already did before. Didn’t help. I have also installed latest Microsoft Redistributable.

The Download Manager uses it’s own JRE… it worked on my fresh installed Win11 system 2 days ago… there was no Java installed before…
The Steinberg stuff was the second thing I installed, first was Firefox…:wink:

Normally it needs nothing pre installed… did you used the latest binary? I guess you did.

You mean the latest installers? Yes of course.