Problem With Time Stretch

I’ve been using Cubase in one form or another for over 25 years. I’ve used it for writing/editing/processing all stages of music production in several styles of music. The last couple of years, the majority of my usage has been in aligning and correcting timing issues between tracks of my band’s recordings, especially with multi-tracked drums. I’ve become pretty adept at aligning individual drum stems with each other, despite the fact that this is not one of Cubase’s stronger points. However, after my recent upgrade to Pro 9.5, I have run into a problem with Time Stretch that I can’t seem to get around.

I am working with a simple stereo drum mixdown, recorded at a constant tempo, but instead of a constant tempo, I want each of 8 bars to be at a different tempo, with each bar faster or slower than the previous. My process: the desired tempo of each bar is entered in the tempo track; the appropriate number of beats in the drum part is sliced off; the length (timewise) of each bar is calculated based on its tempo; and then the sliced chunk of drum part (both stereo channels) is time-stretched to match the bar length. Works perfectly every time- until one time it doesn’t! The right channel stretches to the correct length, but for some reason, the left channel stretches out past the bar line into the next bar. I have been over it again and again, trying to get both channels to stretch at the same rate, but no matter what I do, one side comes out longer than the other. Then, after a few unsuccessful attempts, Cubase crashes.

Has anyone else experienced an issue like this? I’ve never seen a glitch like this before. I haven’t tried it in a previous Cubase version yet, but my first guess is that it’s related to my recent upgrade. I’ll check it out when I get home tonight, but any feedback from the forum users might also be helpful. Thanks for your input.

Sounds odd, given that this method has worked in previous versions of Cubase. I’d have to try to duplicate your work flow in some fashion to see if I’d be able to reproduce this suspected issue with Time Stretch.

Perhaps completely unrelated, I noticed an odd Time Stretch potential issue. I imported a low-fi voice sample to be used in linear mode, “old radio SFX”," Cubase did “something?” whereby the Time Stretch algorithm altered the pitch of the sample. No matter which Algorithm I used on the file, it just kept have i’s pitch altered (raised higher by some imprecise amount) – it was a linear clip, low-fi radio quality (16/44.1 bit wav file), Independent from Transpose Track, not following chord track, etc.

Anyway, perhaps someone else will be able to more readily duplicate your issue and check this. I’ll do some Time Stretch checking out when I have time. If find anything useful I’ll post. Good luck, sorry I can’t offer more immediate help.

Stephen (and anyone else who might be interested)-

Just to support my complaint:

I retraced some of my steps in C9.5, taking some screen shots in the process. What I described in my first post didn’t happen exactly, but weirdness still occurred. Sorry for the length, but at least there are pictures!

  1. These are the tracks before any editing. The red circle is the area of interest.

  2. I have selected the notes to edit and have sliced off the section.

  3. The unselected remainder has been shifted to the right, to where it should begin.

  4. Time Stretch length has been specified.

  5. Time has been stretched; the part has been extended to the end of the bar. But you can also see that time has now been tacked onto the beginning of the next section at bar 13, shifting everything to the right

  6. So I locate the added piece and slice it.

  7. After erasing, I have a gap at the start of bar 13, right?

  8. So I slide everything back to the left, where it should be.

  9. I locate my next edit and make the slice.

  10. Just for fun, I slide the sliced section down to see what’s behind it- nothing.

  11. I slide it back up and move the remaining section to the right, where it should begin.

  12. I make the Time Stretch, the part runs to the end of the bar. Again, time is added to the beginning of bar 14, shifting everything to the right again.

  13. So just for fun again, I slide the stretched section down, to look behind it. Now there are 2 parts stacked on top of each other. Now, I could see this happening if maybe Cubase left an image of the original source part behind, just to remember where the edit came from. But the image in back is still an edited (stretched) version of the part, so post-edit. Something weird is going on here, unless there’s something I’m not aware of.

I also tried this process in C9. It still has a problem, but in C9, while the time-stretching also pushed the data to the right, it did not leave the second image behind.

I’d really like to know what’s happening here- if Cubase is having a problem, or if the problem is with me.

I think I understand what you’ve posted, but an answer on this is going to have to come from someone with more understanding of the program than I have. As far as Step 13, I’ve never seen doubled images like that.

Shot in the dark on this, but, I was wondering setting the Snap Point within the clips might help with this edit? I’m not sure it would. Anyway, let’s hope someone around the Forums has a look at this and maybe an answer for you.

I’m assuming all your project settings are good and the files imported are all fine in terms of sample rate and bit depth. This is one of those things where I say, “It should just work” and it should. :frowning:

I also assume my settings are good. After the 9.5 upgrade, I forced a reset of my preferences folder, but that didn’t solve the problem, so I reverted. I’ve played with the Snap Point and Start Point, no effect.

In the meantime, I’ve been doing my editing in C9, and it’s only done the “push-to-the-right” glitch a couple times out of 40 edits, and no double image, so at least it’s workable for a while.

Stephen- RE: the 2nd paragraph of your first response to me, it has also been my observation that once an edit is made that glitches, no matter which process is being used to edit, the glitch often recurs, even after undoing the original edit and trying a different process. It kinda feels like Cubase is remembering the glitch and just wants to keep reproducing it, even though it knows it’s been undone. Weird.

I appreciate your concern about my issue. Maybe I will try to post about the problem to the Issues Forum.

I think a post to the Issue Forum would be helpful. The problem is getting the issue identified well enough that someone else can reproduce it.

Sorry I can’t provide a real solution for you. If the kind of edits you were making in Pro 9.0 still work, I don’t see why they should not work in 9.5. :frowning:

Split Events refer to the same audio file. So “New Version” would resolve the issue.

Direct Offline Processing

If you select an event that is a shared copy, and therefore refers to a clip > that is used by other events in the project> , you can decide how to proceed:

Select > Continue > to process > all shared copies> .
Select > New Version > to process > the selected event only> .

This only works if > Open Options Dialog > is selected for the > On Processing Shared Clips > setting in the > Preferences > dialog (> Editing—Audio > page).

Preferences>Editing>Audio>On Processing Shared Clips

Thanks Stephen. I agree, it’s a weird prob.

@ Accel0001: Thanks, but I don’t believe that’s what’s going on here. I’m editing a linear part; none of the content is shared anywhere else in the file. Nor does the problem occur in C9, using exactly the same material.

See picture No.9. Just sliced Event has a “Direct Offline Processed Mark” in the top right corner. This means the Event refers to a processed audio.

“Audio Event” is not an actual audio file. You can’t slice an actual audio file by slicing an “Audio Event”. (Cubase Pro 9.5.30)
Time Stretch “Continue”
Time Stretch “New Version”

Earlier Version (Cubase9.0.40) (Cubase8.5.20) (Cubase8.0.40) (Cubase7.5.40) (Cubase7.0.7) (Cubase6.5.5)

I found that there is a case that shift doesn’t occur in different tempo. So I think this is because internal calculation error.
Another workaround (Without overlap, shift doesn’t occur.)

Personally I always apply “Bounce Selection” and “Replace” to the sliced Event for safety.

I’ve tried most of the above and I’m still getting the exported file extended to the right, well beyond the original. What I’m trying to do is mix together some tracks into the one track. I’ve tried render in place and then doing a mixdown, but to no avail - same problem…

I had an similar issue in my 8.5 pro whereby I also get “extra” content added to audio when I bounce/export and import again eg. a kick drum will bounce and be longer then the orig.
I tracked it down to this - If I put any kind of Eq or filter or Compression on the Low Freqs of my Master Stereo out, it creates some kind of phase issues and makes low frequencies double up. So the kicks sound like 2 kicks badly mixed together.
Of course with a few sounds playing it totally Muddys up the mix.
As long as I do not use any FX on the master out Low Freqs I am ok.
Not very good if I want to actually master any of my tracks, or just mix them with compression or Hi pass. Thanks Cubase lol

I’ve problem with stretch in multi track view of remixing instruments and vocals:
When I stretch a part of song more than usual, I heard a bad noise that makes me to stretch just a little not more.
What should I do?! Is that a limitation?!?!
cubase version Pro 10.5
windows version 10

… save post for other slightly more pertinent thread

no it isn’t a complete sentence