Hello to all,

I am so sorry that my 1st post is sad… though… everything was working fine with my UR22 till today.
The phantom power (+48V) worked properly till i pluged in an electric guitar today and when i turned phantom power on it didn’t light up and the usb light was blinking and it disconnected from my computer.
Now without the phantom power on it doesn’t have any output sound at all.
I am using Windows 8.1, i have checked the drivers (uninstalled and reinstalled), i checked the cable (i changed about 5 cables with no result) and for a DAW i am using ableton and all the settings are ok… PLEASE HELP! :confused:

Thanks in advance!!

:open_mouth: You don’t need Phantom Power for an electric guitar!!!

:astonished: Very possibly you’ve burned the unit out. Normally the phantom power would not cause any problem when plugging in a normal TS guitar cable but if you happened to use a TRS or XLR cable, then you might have short circuited the Power and fried it.

I guess I have the same problem. Is it hard to fix by myself with a little bit of experience about electronic components or do I need to send it for repairing?

Today the same thing happened to my UR22.
I plugged a condenser mike in and switched on the Phantom Power, which led to the UR22 disappearing from my MacBook Pro. I tried unplugging the USB and replugging it. My Mac recognizes the UR22, but there’s no sound except a pulsing thumping sound and a blinking light on the unit.
Same thing no matter what (Phantom/no Phantom, mike/line plugged in, headphones, line out etc). Anybody knows what’s going on with these units?