Probleme mit Vst Instrumenten und Speicherverwaltung

Hallo,

es scheint Probleme zu geben bei Speicherfreigabe und Speicherverwaltung von manchen VST Plug ins. ES betrifft Vst2 sowohl auch Vst3 Versionen.
Wenn ich einige Vst Instrumente geladen habe und möchte dann zB. HalionSe oder HSO, oder GrooveAgent aber auch Arturia Mini vorallen AnalogLab werden diese nicht mehr geladen.(Spur wird erzeugt aber kein VSTi ins Rack) Obwohl der Taskmanager noch über 1 GB an verfügbarem Speicher anzeigt. Dies tritt vor allem dann auf wenn der TaskManager nur einen sehr kleinen Bereich als “frei” anzeigt.

Einige andre Vsti lassen sich anstandtslos bei gleicher Ram Auslastung laden. Ältere Cubase Vsti (Mystic, etc)aber auch Padshop z.B. Zampler dr dann sogar noch brav alle Samples nachlädt lassen sich laden . Dies lässt sich bis zum ausreitzen des Ram (Verfügbarer Speicher knapp bei 200 MB durchführen.

Zuerst dachte ich das es was mit dem ASIO Guard und seinen diversen Einstellungen zu tun hat, aber auch hier keine Veränderung auch beim abstellen des Guards. Allerdings trat dann auch schon mal beim Versuch ein weiteres VSTi zu laden ein Crash mit Runtime errror auf.


Erstaunlich ist auch das wenn dann geöffnete VSTi geschlossen werden um ein Ram Problem auszuschließen werden die neuen dann trotzdem nicht mehr geladen. Erst nach Neustart von Cub. stehen sie wieder zur Verfügung.

Verstärkt wird dies wenn z.B. Arturias AnalogLab geladen war und dann entladen wurde (geschlossen, Spur gelöscht) wird der Speicher offensichtlich nicht wieder freigegeben.
Somit ist das Rendern in place oder einfrieren der Spur leider auch keine Lösung da ja weiterhin nichts mehr geladen wird.
Auch andere speicherintensive VSTi machen Probs. Groove Agent, Toontrack Drummer (EZ und Sup.)

VSTFX lassen sich allerdings auch weiter bis zum Anschlag laden.

Seit 2 Tagen mit Cub8 beschäftigt, keinen Ton gespielt und “etwas” genervt"

Bitte keine keine Tipps wie kauf mehr Ram mach 64bit alles supi, ich möchte dieselben Projekte fahren können wie mit 6.5 . Hier liegt das Prob eher bei der Speicherverwaltung von C8 .
Vielleicht ist das nur keinem bislang aufgefallen der Boliden mit 16GB oder mehr betreibt.


Also an des nur 4 Gb Ram dürfte es nicht liegen denn alles lief unter 6.5 einwandfrei.

Projekte die im gleichen Rechner mit 6.5 kein Problem waren lassen sicht nicht laden, wenn die Vsti Kombi wohl ungünstig war.

Gruß und frohe Ostern

Alle Vsti sind auf dem neusten Stand

Sorry aber…

Du hast ja nur Windows 7 32bit und hast 4GB RAM, aber in der 32bit Welt kann leider jeder einzelner 32-Bit-Prozess nur max. 2GB benutzen.

http://de.wikipedia.org/wiki/4-GB-Grenze

Da hilft nur Win7 64bit und alle Plugins und auf 64bit switchen.

Gerade bei deinen genannten Plugins die halt RAM Intensiv sind.
Cubase 6.5 mit Cubase 8 zuvergleichen halte ich etwas für gewagt.

Zumal Cubase 8 einfach moderne und aktueller ist als Cubase 6.5 vom Kern her und andere Anforderungen stellt.

Wie ich schon geschrieben habe, ich bin mit der Speicherstruktur vertraut. Ich möchte zur Zeit aus unterschiedlichen hier nicht relevanten Gründen noch nicht 64 bit fahren.
Ja es ist mir bekannt dass einzelne Prozesse nur 2gb nutzen dürfen, was hier auch der Fall ist. Laut resmon- taskmanger belegt cubase 1,2 GB. Also muss noch was gehen, was mit 6.5 auch der Fall ist. Es ist vielmehr so dass hier Speicher der belegt war, dann nicht mehr freigegeben wird.
Ein Workaround hier, ein von mir erstelltes freemem VBS scribt beweist es. Wenn ich ich Manuel via scribt Den Speicher freigebe lassen sich munter auch die Querulanten unter den vsti. laden bis zur Schmerzgrenze von 1.8 GB , was für meine Zwecke bislang ausreichend ist und war.
ergo: Cubase8 hat ein Speicherverwaltungsproblem. Und wahrscheinlich mit der Anforderung von verfügbarem Speicher, cub8 greift hier wohl nur auf den freien Speicher zu. Siehe Win7 Speicherverwaltung, hat übrigens was mit superfetch und prefetch zu tun und hier liegt es bei cub8 das Problem.
Ja cu8 ist z.T. im Kern neuer. Neuer und moderner muss nicht heißen verschwenderisch und schlampiger programmiert.

Mit neuer meinte ich halt das Cubase halt andere Ansprüche an das Basissystem stellt.

Haste das schon mal getestet wenn nur Windows 7 in 64bit läuft und die Anwendungen selbst weiterhin in 32bit ?

Haste mal deinen RAM gescheckt mit Memtest86 ?, eventuell hat der je nen defekt ?
Es könnte aber auch sein das eins deiner verwendeteten Plugins irgendwelche effekte im RAM verursacht.

hallo,

puh,… dann müsste ich den ganzen Kram auf einer anderen Platte neu installieren um Win7 in 64bit zu testen.
Zudem dafür eine Registrierungs ID für die Arturia plugs von denen es seit dem neuen Softwarecenter nur noch 5 x eine gibt. :imp: Ich war so zufrieden mit der Donglelösung, waren alle Lizenzen drauf. Alles dabei wenns auf dem Laptop ging. :frowning:
Bin mir nicht sicher, du meinst also Win7 in 64bit (dann eben mit mehr ram 8GB) Cub8 aber in 32bit (damit meine beiden UAD1 Cards und ihre plugs laufen, leider nur Treiber f. die cards in 64bit die plugs nur 32bit) Was dagegen spircht ist das dann Cubase trotzdem nur als 32bit Prozess 2gb Ram zur Verfügung steht. Das tut es ja jetzt auch.
Oder kann ein 32 bit Prozess auf einer 64bit Platform mehr Ram beanspruchen, ich denke eher nicht, denn genau das gibt ja die 32bit Struktur nicht her. Zudem würde das zusätzliche Pozessorlast erzeugen was das Gesamtsystem nicht unbedingt stabiler werden lässt.
Bis auf dieses Speicherproblem bin ja auch erstmal zufrieden. Arbeite eben auch viel mit externen Synths.
Danke schon mal für deine Antworten.

Gruß

Hast du es schon mal mit ausgeschaltetem Asio-Guard probiert? Der könnte durch die VSTi-Pufferung auch für eine größere Speicherauslastung sorgen.

Das ist klar das ein 32bit Anwendung unter dem 64bit BS auch nur seine max. 2 GB nutzen kann.
Wäre halt ein Option die man testen könnte, um es weiter einzukreisen wer, warum wieso…

Aber wie gesagt ist nur ne Idee/Option meinerseits.

Für Plugins die du nur in 32bit hast gibt es “jbridge” ist ein Bit Wrapper, funktioniert 1000x besser als der Interne von Cubase.

Das Arturia das mit dem Dongle Umgestellt hatte fand ich auch etwas doof.
Hab zwar nur den Minimoog V2 aber mit dem Dongle war man doch etwas freier.

Stimmt du kannste auch im neuen Plugin Manager für jedes Plugin (gerade bei Instrumenten) den ASIO Guard Aktivieren/deaktivieren.
Macht voralldingen sinn bei Plugins die mit Samples arbeiten, Kontakt, GroveAgent, HalionSonic usw.

hallo,
danke für die Tipps. Das ausschalten des Asio guards im plugin manager für einzelne vstis ist mir durchgegangen.
Werde es mal testen wenn ich wieder im Studio bin. Hatte nur ganz versucht ihn abzuschalten was aber dann wie beschrieben wenn es eng wird zum crash mit runtimeerror führt.
Bei 32 bit kommt man ja zur Zeit ohne jbridge nicht weiter weiter. siehe issue report von Steinberg:
These plug-ins possibly try to open a window while being scanned, which is not supported by the VST Bridge. Update problematic plug-ins to 64-bit versions or consider using the 32-bit version of Cubase.
Werde diesen test nicht machen ,denn Anfang 2016 kommt der neue Rechner und die neue uad ggf. Apollo.
Ich hoffe dann ist win10 korrekt unterstützt sonst renne ich wieder auf einem grandma OS :wink:

Also falls es dir hauptsächlich um die beiden UAD 1 Cards geht, da mach dir mal keine Sorgen. Die laufen auch in C8 64Bit auf Win 7 64Bit völlig ohne Probleme. Ich habe auch noch zwei UAD 1 Karten am Laufen (Treiber Version 5.80 meine ich, weiss es gerade nicht auswendig). Die werden über die interne Cubase Bridge problemlos “gebrückt”.

Gruss

Hi, Atarifalcon030

sicher? auch unter Cub.8 denn hier in der known issue-list von Steinberg:
These plug-ins possibly try to open a window while being scanned, which is not supported by the VST Bridge. Update problematic plug-ins to 64-bit versions or consider using the 32-bit version of Cubase.

Ich hoffe das wird gefixt denn das wäre prima mir geht es in der Tat nur um die beiden UAD1 denn die reichen mir, verzichten kann ich allerdings mittlerweile nicht mehr drauf.

p.s. den alten Falcon habe ich aus Nostalgiegründen immer noch im Schrank war mein Einstieg ins HD Recording für Unsummen damals 2 SCSI Platten dran und das separate digitale SPDIF und Cubase was auch immer noch daneben liegt :wink: War das damals ein Kampf um kleine Knackser, …aber hat sich ja anscheinend bis heute nicht geändert :wink:
da die Ansprüche ja gestiegen sind. Ersten Einstig war Seq. mit Brotkiste C64 ,…opa-user halt.

Gruß

Also ich habe C8 64Bit aktuell natürlich nur als “Nebenhersystem” am laufen, da ich immer noch als Haupt Cubase 7.5 benutze. Bringe dort erst mal meine Projekte schön zu Ende. Was ich sagen kann (also für mein System), ich habe natürlich schon mal nebenher das ein oder andere Projekt in C8 als Test am laufen. Dort habe ich jetzt nicht alle UA Plug Ins von meinen UAD 1 Cards getestet, aber der dbx 160, die Pultecs, der SPL Transient Designer sowie der LA2A und LA3A und der Fairchild lassen sich bei mir ohne Fehler öffnen. Daher gehe ich mal davon aus, dass die anderen auch laufen. Wichtig ist aber, die Treiberversion 5.80 (ich glaube diese habe ich drauf) zu nutzen. Denn schon in C7.5 hatte ich mit den letzten Versionen für die UAD 1 (6.irgendwas) das ein oder andere Problemchen (nichts wildes, aber 5.80 ist bei mir am besten).

Gruß