Problems with a Cubase 6 upgrade pack


can a mod help out here please?

I recently bought a new upgrade to Cubase 6 but I can’t activate it.

My old Mac G4 died recently and it ran SX2 and Cubase 4.5.2
I decided to buy a used Mac Pro.

I can’t re-load SX2 (I’ve lost the serial number anyway) on the Mac Pro.
So, how do I “prove” I actually bought it back in the day?

I also have Cubase LE4 but can’t register it either.

Only C4 shows on my e-licencer.

Is my new Cubase 6 upgrade now unuseable? Can you help me please?

I see you asked for a moderator but I will offer some help meanwhile. You shouldn’t need to install ANY older versions unless you want to. The upgrade only applies to the license itself. You should be able to install eLicenser control center, insert the dongle, run ELCC, and enter the activation code. It will upgrade the license on the dongle. Then, install Cubase 6 and/or C4 as desired

What exactly is happening? Exactly which upgrade are you using? (I.e. From which version to which version?)

For LE version, it uses a soft eLicenser, to reinstall on another computer, you would need to use the reactivation proces. See the FaQ in the LE/AI forum.

Hope this helps for now.

Hi and thanks for the response.

I found this upgrade on Ebay. It says it will upgrade
to C6 from a wide variety of lower-level/outdated Cubase
products including LE4 and SX2. C4 is NOT included
on the list…but I have both LE4 and I bought the full
retail version of SX2 back in the day.

When I enter the activation code for C6 the LCC
says “there are no available upgrade licences on your
e-licencer”. I don’t even know what that means.

I have downloaded the correct e-licence installer
for Snow Leopard (my OSX). I’ve run sync and maintenance
but I get the same message with each attempt to register C6.

Also, the “My Steinberg” page has been down all day
so I can’t even try to register the LE4 I acquired several
years ago (and which I’ve never used either). The C6 upgrade
box says it will upgrade from LE4, so I was hoping to register
LE4 and see if that would help the C6 activation.

This means that there is not a license for a version that it sees that you can upgrade FROM.
In other words, if you bought an upgrade from Cubase 4/5 to Cubase 6, it must see a license for Cubase 4 or Cubase 5. If it doesn’t see one of those two, it will give this message.

Just curious… What licenses ARE on your dongle?
Also, when you enter the activation code in eLicneser Control Center, it should “identify” what the activation code is for, for example, “Cubase 6 update from Cubase 4/5”.
Does it say something like that?

You shouldn’t need to register the LE4. You should only need to ACTIVATE is so that the license is on the dongle (or, more likely the hard drive). You would then probably need to move the license to the USB dongle, because Cubase 6 will not allow a license on the soft eLicenser (I.e. the hard drive).

Thanks again for your reply.

I have licences for C4 (in use for years now) and for Hypersonic (which I have never used). That’s all that shows on my e-licencer.

The C6 authorization process makes no mention of an upgrade.
It simply requests the Activation Code then tells me no licence is available.

Unfortunately I am automatically required to activate LE4 via the
“My Steinberg” page. I get a message that unless I do so the programme
will not run. Sure enough, it won’t open.

However, as it was yesterday, both “My Steinberg” and “Support” pages are
inaccessible, so I can go no further.

The upgrade box clearly states it will upgrade LE4 to C6 but unless
I can somehow get my copy of LE4 recognized/authorized/activated
it seems I will get nowhere.

Does anyone know why the “My Steinberg” page is down and when
it will be up again?


The activation process DOES state “C6 upgrade from SX…”(the rest of the message
I cannot read as it won’t scroll). The upgrade box says it will upgrade to C6
from SX1/2/3 and LE4 (and many others).

I have SX2 but it does not show on my e-licencer.

I relocated the SX2 box and serial number yesterday, so I CAN
prove ownership.

I tried re-installing SX2 on the Mac Pro but that hasn’t changed
the list of licences on the dongle nor attempts to get the C6
upgrade to be licenced.

Still trying.

“My Steinberg” still not accessible from Safari.

Tried my mobile phone and got it.
Still unable to see any way of using this
upgrade pack. E-licencer shows only C4.

No field for activating LE4.

Wrote an email to the address supplied on the website
but it bounced (postmaster rejection).

Is there anyone at Steinberg who can help me?

Well, I don’t think I can be any more help at this point. It does sound like you will need some help from SB. I hope they respond soon.
Oh… I did try MySteinberg and it works from here. I am in the U.S.A. (Safari)

I got it.

The browser was the problem!

All good with C6 up and running.

Glad to hear it!