Problems with ASIO drivers

Hi there.

I have been using Cubase for a while now. I’ve always had trouble with ASIO drivers and I can’t find any solution. Every time I choose ASIO driver from the device preferance menu, no sound is coming out. Sometimes there is sound on my utput but suddenly it disappears. Five minutes ago I tried the ASIO driver and it played sound for me. When I went out of Cubase and started spotify and went back to cubase again, the sound was gone.

I really want to use the ASIO drivers instead of my normal soundcard driver!! Please help me out.

-Kim R

Hi kim

What system are you using?

Sorry. I’m using Windows 7 x64 with an i7 cpu. My previous computer had the same ASIO issue.
It’s POSSIBLE an user error… I don’t know. I’d appreciate to be enlightened on what I might do wrong

It would be helpful if you stated what make is your soundcard and what asio are you trying to use. Is it your soundcard’s dedicated asio driver or for example asio4all

Hi-sometimes, as i switch drivers for different audio setups (in my experience) even if i have the ASIO drivers set correctly in the DEVICE setup menu,the in and out connections of the driver in the VST connections panel don’t match up and I have to adjust them ( make a template for that driver) and reset them to correspond with the correct driver. 98% of the time they change correctly, but once in a while they don’t, resulting in no sound. you might want to make shure this is not happening on your end. If you are not getting the right choices for your ASIO driver ins and outs in the inspector section of your tracks, that’s probably it. If they are correct, you’ll need to investigate further. :slight_smile:

Hmm I’m not sure. I’m trying to use ASIO4ALL yes. I’m currently using an Edirol FA66. The FA66 driver works, but I want to use the asio driver

Well, the driver that comes with the FA 66 is an ASIO driver, a dedicated one for your interface which should be used. That´s the reason why it works , unlike ASIO4all obviously.

Thanks for the help man. I’ve made sure that all the ins and outs are correct. It even plays sound outside of cubase. But there just isn’t any sound in cubase. I’ve set it right with the VST connection and also the device setup but the sound suddenly disappears. I’ve had this problem for three years now (resulting in me using the FA66 driver).

I’ve had two computers and I’ve had the same issue on both of them. The previous computer I used win xp x86. There shouldnt be any OS related issue or hardware here afaik, but maybe theres is something I don’t understand regarding the ASIO4ALL driver. I’ve been trying to google this issue as well

When you say FA66 driver do you mean the driver for the device as opposed to the ASIO driver made for the unit?

The Edirol FA66 Asio should be your first choice over asio4all. What i haven’t really understood,
these problems occur when using the Edirol Asio driver in Devices>Device Setup>VST Audio System?
Select FA66 Asio and apply (make sure the “release the driver when application is in background” is unchecked) Then underneath at the tab probably named Edirol Asio where you see your ins & outs do you see them as active?
En-suite in Devices>Vst Connections, delete all your in & out busses and create new ones. Assign the Edirol 1-2 to each of them. Create a project and play something. What Happens then…
Also in Windows Control Panel>Sounds and Audio Devices>Audio (at least that’s what it’s called in XP) have you selected the Edirol to handle windows audio?

Thanks for the answers. Yes I’ve tried all of it but still the sound disappears. What I didn’t know was that I should use the FA66 asio instead of asio4all. I thought the asio4all was the first choice…? The reason for me to want to use ASIO4ALL is that it has a lot better latency handling than my normal FA66 driver

FA66 driver = around 5 ms
ASIO4ALL driver = around 3.2 ms

ASIO4 all is only a last resort, as on the whole most manufacturers make fairly decent drivers, it is simply that drivers made for older systems, eg XP do not work well on for example W7.