Problems with beaming, stems and rests

I hadn’t wanted to return here to bother people but I’ve hit problems I seriously can’t find answers to no matter how hard I search.
The three staves in this pic are in 4/4 and top to bottom, treble, bass, bass.

  1. top staff, 3rd beat. The beam across the 3 semiquavers + rest will not split. I can untie the first note, try to split the lot and reconstruct it but without success. I want it like the exemplar beneath on the 2nd stave.
  2. second staff, last beat. Tried to beam the semiquavers together but they end up as shown rather than a joined beam. Same as the first beat of the third staff.
    Also on the second staff, the last note is to be played by both players but I can’t find a way of attaching an upstem and downstem to the same note.
    Ideally it would be beamed from both voices. The only alternative is to write ‘a 2’ above just that one note but that seems inelegant. If I can ‘double stem’ it, of course the rests would need adjusting.

As to rests I’m having loads of trouble inputting rests ‘as I go’. Dorico always wants to do things differently. I wanted to start an empty bar with a crotchet rest but it won’t let me. The shadow rest shows but it won’t stick.
Is there any way of letting me enter rests as I see fit? I spent over 2 hours struggling with a bar a few nights ago, decided finally to delete the music in the bar which I’ll touch in with ink when I get an off-print.
Thank you for any help you can give.

  1. To separate the C# in the top stave, select it (and only it), right-click and go Beaming > Split beam.
  2. Select both notes, right-click and go Beaming > Beam together.

A few fundamental things:

  1. You can change Notation Options > Beam Grouping > Beams and Rests to let Dorico do this stuff for you automatically.
    If you then grab the whole passage and go Edit > Beaming > Reset Beaming you’ll probably end up with exactly what you want without any manual fiddling.
  2. Dorico has fantastic Condensing functionality that will automatically take the music for two players and stick it on a single stave in the score. You can do it by hand if you want, and I’m not sure why you haven’t found a way to beam the same pitch in two directions - you just need to enter the note again in the downstem voice.
  3. If you’re inputting rests by hand, you’re wasting your time. Just put the caret where you want the note, and input the note. Or if you’re clicking notes in, set the rhythmic grid resolution (bottom left corner) to something useful, then use the grid lines above the staff to gauge where in the bar you’re clicking the note. Dorico will handle the rests automatically.
    You can of course enter rests - there’s a rest button in the left panel or you can type comma to toggle it on and off - but generally speaking it’ll only work if you also turn on Force Duration (the clamp in the left panel, or type O), because most of the time Dorico considers rests as implicit padding, rather than explicit things.

Thank you very much for that. The first problem solved easily.
The second one - opposite stems on the same note worked with a bit of trickery. I changed voice to force the stem down then added a new note above as a chord (different pitch). Changed voice 1 to have an upward stem then beamed it; then moved the note down to overlap the D. I could have done it the other way round but was experimenting because I couldn’t find a way to force the stem in a given direction at the point of input.
It works, anyway.
I’m not advanced enough to risk condensing yet. Using this system to edit xml files. I’ll put up an experimental project to try it when I have some time.
Again, thank you.

Let me make you aware that by default quite lot of options are turned on at Preferences (Ctrl/Cmd-,) > MusicXML Import. I tend to keep the bulk of these options switched off.

The way that Dorico works (pretty consistently) is that global rules for notation are defined in one of the Options dialogs (Engraving Options/Layout Options/Notation Options), then when you want to go against the rules you can do so either from the right-click menu (which is a subset of the Edit menu) or from the properties panel (at the bottom of the screen). Importing MusicXML with those various options turned on, is a little like manually overriding everything from the context menu and/or properties panel - basically nothing automatically respects Dorico’s global rules, and no amount of changing the global rules will override that. Edit > Reset Appearance and Edit > Reset Position will put most things back to defaults, but Beaming’s a bit of an outlier (probably because it’s something that you can’t necessarily grab hold of that affects multiple notes at once).

It’s too late for your current project, I guess, but you may find that you can resolve quite a lot of these sorts of things by selecting passages (or even Select All), then Edit > Beaming > Reset Beaming.

Hello again. Sorry to be back. Your beaming solution (unison stems) worked the first time. I tried it elsewhere in the score and can’t make it work a second time.
I was able to beam voice 2

but when I tried voice 1 it got me this:

All AFTER resetting the beaming in Edit.
But the fact is, it works unbeamed and that’ll have to do. It doesn’t look too bad either.
I’ll reload this project under a different name for experiment, and also take your advice about xml import. A couple of days won’t hurt if things can be learned.
Thank you for your help.

I’ve seen something before where reset beaming didn’t work after a note had been moved to a different voice, but otherwise I’m at a little bit of a loss. If you could cut down the project to just these few bars and then upload the (shortened) version of the project then somebody can take a look.

Right. I don’t want to make mistakes so if I can be excused I’ll do it in the morning when I can note down what I’m doing. I’ll presume you want an extract of the full score.
.

Ideally, but you can always delete the notes in the other instruments. Just make sure you’re working on a copy of the project rather than your main working file.

Try choosing the final joint sixteenth and right-clicking to choose voice swap voices from the context menu. It appeared to be in the wrong voice for an upstem in the first drawing, and I fear you complicated matters by making it a chord.

Turn on voice colors to see if that helps make things clearer.

Oh yes, I’ll save the work under a different name.
I can’t help making it a chord. The staff will only allow me to put one note in otherwise. I can’t find a way to force the stem direction in readiness for inputting a second note at the same rhythmic point let alone overlapping the first note.

voices

I split the beam after the first sixteenth of the measure to reproduce what you had; otherwise it would have been connected by default.

Derrek’s advice (and Leo’s before that) to turn the voice colours on is a precious one. My guess is that your problem is mainly due to wrong voices…

Ok, I’ll turn on the voice colours.

pianoleo, unfortunately the forum won’t let me load the extract as a dorico file. It’s 5 Mb according to properties whereas I can only paste a file with 0.5 Mb here. I’ve cut it down to 6 bars and deleted other instrument parts.

Here’s how it looks without beaming and since occasions are few, this will probably do.

(The learning process has brought so many frustrations it may be best to leave it at that rather than incur more for a while. I don’t want to get in a position of dreading firing the program up. The project was probably too complicated for a beginner - and one thing I’ve learned is get the daw piano-roll dead right to the grid before sending its .xml.)

Thank you for all this advice and should there be more you can count on me taking note.

Not sure how to interpret voice colours.
Screenshot 2 (36)

Middle staff: As you can see voice 2 changes from green in the first bar to brown in the second. (The very last note in bar 2 is lighter brown/orange because I selected it.)

Something similar happens in the first beat of bar 2 on the lower (notated) staff with voice 2.

About that middle staff, I tried swapping voices. I then re-entered the notes. Initially it was as a chord, stems down, so I changed the upper note to an up-stem, moved it to overlap the lower voice making the unison, and the result of trying to beam is as shown. I can’t enter the second note without it being a chord. It simply replaces the first note input if I try.
A mystery indeed.

Dear Ivor,
Your picture here confirms that you’ve messed this all with too many voices :joy:
Don’t worry, that happened to all of us (I guess). Please keep using those colours for one week or so, and things won’t be a mistery to you.

You must know that, in Note entry mode (shift-n), shift-V creates a new voice. Every time. v alone lets you navigate between the existing voices (the default one and all the others you created using shift-v). Chances are you’ve been hitting shift-v instead of v (as we all have, at the beginning), while wanting to switch the active voice to another one.

On the second staff, I notice a bar rest in blue on the first bar. Probably because the purple one should have been blue (upstem voice 1 instead of upstem voice 2). The last rest of that second staff is blue (as could be the last upstem 16th note?), so the blue and purple voices live together in that bar. Which could explain the beaming problem.
On staff 3, yellow and blue voices should be only one voice.

You can use the context menu (ctrl-click or right click) on those wrong voiced notes and do Voices>Change voice>upstem voice 1 or downstem voice 1. The music you’re showing here only requires those two voices (and you’ll notice you’ll seldom need a third one, and almost never a fourth one). Hope it helps!

1 Like

(If you apply the Silence playback template before uploading Dorico projects, their file size should be much smaller.)

2 Likes

Further to Marc’s point, you can probably get away with selecting the whole passage, filtering All Upstem Voices, then Edit > Voices > Change Voice > Upstem Voice 1.
The select the whole passage again, filter All Downstem Voices, then Edit > Voices > Change Voice > Downstem Voice 1.

Then try resetting beaming again.

edit: I’m assuming that you’ve not flipped any stem directions manually. Once you’ve filtered, do look carefully at what’s selected and what isn’t!

1 Like

I think it’s worked! Quick, where’s the Lagavulin and aspirins!

I wasn’t sure how many “voices” I’d input so I transcribed the music to paper, deleted it and input it again, noting the way the little crotchet at the caret pointed. I found I could change its direction by clicking shift-v as Marc suggested.
Only mystery was when I first clicked shift-v there was a +3 beside the caret’s crotchet. (If I clicked shift-v again it changed to +4 or something so I left it alone after I’d got it in the desired direction.)

Then I entered the second voice. It worked, beaming the semiquavers at the unison.
As a beginner I feel a bit shaky about this so I’ll practice it on that cut-down project until I get it right first time.

I didn’t flip any of the stems, in fact as a novice I try to explain every step (like a program spec) to how I got myself in a mess!
Thank you.

Edit. Yes, it works. Doesn’t matter which voice goes in first as long as the caret crotchet is pointing the way one intends.

As Marc said, pressing Shift-V adds a new voice, but once you’ve created a voice, just V on its own cycles round the active voices. Here’s some information about inputting into voices, and about the caret in general.

Most helpful, that information. Many thanks. I framed my search query wrongly. IIRC I was looking for stems both directions on a 2 voice unison or something.
Cheers.