Problems with clicks/pops in Cubase

I have problems with clicks/pops when I compose with cubase. I’m unsure if it is hardware or software related. The problems come regardless of whether there are larger or smaller templates. I have debugged by disabling some plugins to see if it helps. The problem is so bad that it is difficult to keep the motivation up to write in cubase. The problem has been there since I bought the PC/Laptop, but the supplier denies that it could be hardware related. It does not matter much if I run lighter audio-only projects or heavier MIDI/hybrid projects projects. Relevant info below

Is there anything more than this I can try or should I think about buying a new PC?

Info about software and hardware:

Laptop stats
64 gb ram
Intel i7 2.59 GHz (6 cores / 12 threads)
Nvidia 2070 GPU + built-in.
2 x 2 TB m.2 nvme
Up-to date bios
Audio interface - SSL 2+

Cubase installation
Buffer setting is at least 512, but I still have problems
Tried both cubase 11 and cubase 12

Task manager
CPU and RAM never exceed 50%

Troubleshooting with latencymon:
I tried formatting the entire C-drive and ran latencymon to check if the PC had some audio processing problems after the reinstall. Even right after I formatted the drive (and before I installed other drivers, applications), it showed problems with audio processing.

I have already tried:

optimized power plan. Have tried both high performance (optimized after research online. no sleep mode etc.) and steinberg power scheme.

Up-to-date BIOS

Changed buffer in cubase
Experimented with asio guard settings
Played through projects with audio tracks only and not heavy MIDI-templates. The problem gets worse when I run heavier projects, but the problem is still there if I run lighter projects with few midi tracks or with few audio traks.
Tried both ssl 2+ driver and built in driver
Purged all instances of Kontact
Disabling tracks I don’t use
Troubleshooting plugins to see if some make the problems worse
The audio processing meter is working actively even when I am not playing . Peak sometimes goes up to 25% in audio only projects without me doing anything.
Has reverb on bus, and not many instances

Making sure that the sample rate in cubase and in the pc sound prefereces matches (48k)

Paused onedrive / dropbox when I use cubase

Closed other apps

Turned off wifi

I’ve not installed 3rd party mouse / keyboard driver after reading on steinberg’s troubleshooting website that it can cause some problemts

Tried to get help from tech support where I bought the PC, but they said that it’s software related.

GPU settings
I don’t have the nvidia game ready application installed. I have the standard nvidia driver.
Tried to enable built-in gpu while using cubase
Tried to enable nvidia gpu while using cubase

Installed and tested reaper instead of cubase. It didn’t help

Other information that might be relevant:
I had an identical laptop before I got this one. I got a new laptop about a year ago because the other one had a battery that expanded. Got exactly the same model on warranty. Both have had this problems.
The laptop isn’t particularly warm

Hi there,
I always had this problem with my DELL laptop. It’s not my working station and it’s there just for emergencies.

It has C10, and I realized the clicks and pops go away when I turn off the internet connection.

It affects other programs too, it is not Cubase in my case.

Try to, disable built-in soundcard, in bios, maybe
this help?!.

My old pc, did allso suffer from this problems
(click and pops), when using tc electronic impact twin firewire, geforce 760gtx graphicscard.
The click and pops only ocurred occasionally.

With my new pc, and my new SSL2+, i have’nt experinced any click and pops in cubase 12.
The SSL+ plays nice, no problems at all, so i doubt
it is the SSL2+ , thats causing the clicks and pops.
Please update SSL2+ drivers.

Sometimes, it is really diffcult to figure out, audio software related problems, and can take time before you can nail down, those audio problems , you experince.

Some suggest, its nvdia graphics card, that causing
audio problems, especially the cudacores, i doubt that!.
disconnect internet , when using cubase , is a good thing.
Disable anti virus, i you have any , except windows builtin anti virus.
What CPU do you have, Intel or AMD?.

Hi Mariell,

Laptops are tricky since most are designed for simple office usage and casual browsing. They may be powerful on paper, but doesn’t have what it takes to handle real-time audio.

One thing you didn’t mention is what audio interface you are using. A good interface with a stable ASIO driver goes a long way. (RME has a reputation of making very stable ASIO drivers for their interfaces.) Also, all ASIO drivers have a “Buffer” setting. In a nutshell,

  • High buffer value = Lower stress on your computer and less audio drop-outs as a result. The downside is a higher latency that you would experience if you monitor through Cubase or use virtual instruments live. (If you are not recording anything, the higher latency doesn’t really matter.)
  • Low buffer value = More stress on your computer but lower latency. (Good for tracking/recording)

What buffer values and sample rate are you using in your projects?

It sounds like you have already done a lot of optimizations in Windows. The power settings are likely the most important ones. I have made my own power plan in Windows. The basic idea is to keep Windows from powering down certain components of the computer when it thinks you are not using them. This doesn’t work well in a DAW application. So make sure all the little settings in the power plan are set to full throttle with no sleeping or napping allowed!
WiFi adapters in laptops can cause issues. Turn your WiFi off when working in Cubase and see if that makes a difference. (Bluetooth may be susceptible as well on certain systems.)
There is also settings in Device Manager in Windows to allow USB hubs to be powered down. Some users have reported that turning this setting off have had a positive impact. You can find this setting here and you would have to change it in all the USB Hub entries.

Have you gone over your BIOS settings? In there you can experiment with disabling Hyperthreading which seem to help a lot of users. In BIOS you can also disable components that are not used (such as on board audio interface) and is recommended.

It might help if you could share the results from Latencymon.

Solid state logic ssl2 plus
usb Audio interface.

This is why I always say get a laptop pc designed for audio. It’s doesn’t answer this question but is a warning for others.

I use a presonus Audiobox USB with my Laptop. Somebody in the presonus forum mentioned that changing the process precision from 32bit to 64bit helped them.

I know you are using the Audio interface - SSL 2+, but sometimes having a look at other users audio interfaces issues with pops/crackles, might reveal a computer tweak solution.

They say this is no longer necessary, but you could test if changing the ‘Set Processor Scheduling to ’ Background services’ would help.

And double check to see if the right ASIO driver is selected in Cubase, and not somehow reverting back to another driver.

Have you tried changing from 48k to 44.1k to see if that improves things.

…Just to add. It maybe a combination of tweaks you have to do, to have the audio playing back properly…

I forgot to ask, are you running of the Battery when using Cubase?

Here’s a couple of YouTube videos that might be useful.

Check this material for system running

Sweetwater have some really good optimisation tutorials for recording which I’ve done with all my laptops. I am using a win 10 HP SSD laptop that’s now probably close to 7 yrs old. It only has 8 gb of ram but is very stable running Elements 11. I sometimes have to increase the buffer size depending on how many midi tracks I have as they seem to be more power hungry.
Hope you get to the bottom of the problem. :hugs:

Thank you everyone! I’ll go through all of the replies and links and see if I can get to the bottom of the problem :slight_smile:

Here’s a screenshot from latencymon. I didn’t take screenshots of the stats/processes/drivers tabs. But if none of the tips above helps, I’ll run a new latencymon test.