Problems with creating title page

I’m still having fun exploring dorico using my orchestra piece as a project and I’ve come to the stage where I need to create title pages for all my parts.
So far, I have inserted a blank page, this will be the title page on the R.H side. This is primarily for pagination purposes.

Before inserting, the “first” page of the part was using the “first” master page and the rest of the pages using the “default”. see picture attached.
Screen Shot 2019-01-20 at 3.42.12 pm.png
Screen Shot 2019-01-20 at 3.42.12 pm.png

Now after inserting the blank page, the “second” page of the part has got unwanted formatting i.e flow title and indentation of the stave.
Screen Shot 2019-01-20 at 3.42.12 pm.png
I’ve searched around and can’t find anything about this issue so hopefully someone here knows!

Is page 3 a direct copy of page 2? Do you actually have two flows called “Part 1”?

It looks to me as though page 3 starts with a new flow, and Dorico’s helpfully added a flow header. You have control over what Flow Headers look like, in the right panel of Engrave mode (it’s like another small Master Page), and you have control over where Flow Headers appear from Layout Options:

Page three is not a new flow, for some reason page 2 has been duplicated onto page 3 after I insert the blank page,I can get rid of the header but can’t work out how to get rid of the page duplication. I’ve checked all my settings and they’re all how they should be.

Perhaps I’m just better off creating a title page in something like Word and bundling it all into a pdf?

Ok,I want the pages to look like this:

But the page that the music starts on, 2, with this flow header (if I’m using the correct words)
Screen Shot 2019-01-21 at 6.21.00 pm.png
I have created a title masterpage in the default parts set. When ever i insert this page, or a blank page. The first page of music duplicates onto the second page as such:

I do need the “Part I” flow heading as there are two movements to this piece and I need to specify each of these.
Hopefully this makes more sense now.

Your middle screenshot shows this:

In your “First” master page, I think you’ve inadvertently unlinked the music frame from the master frame chain. If a flow is assigned to a layout, it generally HAS to appear in the master frame chain. Dorico’s ignoring each time your First master page appears, and is then displaying the music again on the next page. To get around that, double-click on the First master page in the Master Pages section of Engrave mode, then make sure that the filter in the top left corner of the frame is set to MA 1, as follows:

Then scroll across to the right variant of the master page and ensure that it’s updated there, too (this might happen automatically). Then hit Apply and Close at the top of the Master Page Editor.

That should fix the problem of duplicated music, with any luck.

The next bit is to make sure that your Layout Options are set roughly as follows:

I’ve highlighted the important options.

Yes , that has fixed it! thank you so much for your help, much appreciated.