Problems with playing techniques / expression maps

Hey,

I set up different playing techniques with Playback playing techniques, then connected those in the expression maps dialog with keyswitch and controller information for Halion 6 - but it doesn’t work as I thought it would.
The playing techniques in play mode are not the same as in write mode, which triggers the wrong samples.
Did I do something wrong or is it buggy? Is there a way to get the right playing techniques? Would be nice because I want to have playback for many extended techniques.

Thank you :slight_smile:
expression maps question.zip (749 KB)

Make sure you define a mutual exclusion group in your expression map to contain all of your buzz pizzicato playing techniques. The reason the switching isn’t working as you expect is that Dorico doesn’t know that it has to remove the prevailing technique when the next one arrives, but adding them all to a mutual exclusion group will take care of that.

Thank you! Wow that’s cool. Is it also possible to combine articulations? So if I have Arco and then buzz it gets a different Keyswitch compared to pizz and buzz?
So Arco and pizz specific switching of techniques?

Arco is implicit, so buzz alone would be the same as arco+buzz. You can combine the buzz with other techniques, eg muted+buzz, legato +buzz, etc. Just use ctrl-click in the playing techniques menu in the expression map editor to select multiple techniques.

so now I have a new problem. I don’t know why but in a faster sequence, when I change the articualations with each note, not every note is triggered.

Hope you can help me.
expression maps question_2.zip (517 KB)

I don’t have the HALion sample to be able to play that back, so I can’t see what’s happening.

There is one possible problem that you could be running into though, which happens if a note plays before the playing technique change. This can be caused by humanisation, so try setting that to 0 (Playback Options > Timing).

Thanks for your reply, Deactivating humanization doesn’t solve the issue unfortunately. Still some notes are not played back. Here’s a link to the samples.


Cb_open.zip (90.1 KB)

Which notes aren’t sounding for you, specifically, in your example?

I’m sorry, I don’t have the time to install custom sample sets and debug this in depth. Can you reproduce this problem if you delete more notes until there’s just a few left? Can you then describe exactly which notes are played and what you expect to play?

It’s only the buzz notes, but always in a different place. ordinario triggers as expected.
What I expect: (z= buzz, o = ord., s = silence)
z o z o z o etc.
What happens:
1st play: z o s o z o
2nd play: s o z o z o
it’s not consistent.
Even if I click on one note, there’s normally a preview sound, but with the buzz notes it sometimes happens, sometimes not.
When the sound is repeated or was switched before, the articulation triggers as expected so
z o z o z z z z -> s o z o s z z z

Is it possible that there’s something about the way you’ve set up the patch in HALion that might mean that its state isn’t precisely the same every time you start playback?

Actually I don’t know, as I’m not that proficient in using haliion yet. I made different layers and made them switchable using a megatrig with keyswitches and CC ranges.
I tried manually clicking on the keyswitch before the note is played, and that worked as expected and every note in the right articulation was played. is there a possibility to get the keyswitches to be sent a little early?

The keyswitches are sent a few ticks early, so far as I know.

Daniel is correct - the switches should be slightly before the notes (unless the humanisation causes the notes to occur first, though it seems that isn’t the case for you). You can export a MIDI file to load into Cubase or other DAW, and that will create the same keyswitches and controllers as Dorico’s playback, so you can see what’s happening.

Hello dear Team and colleagues,
An idea on this topic which is in my mind from previous experience with DAW and another notation software that has Expression Maps

  1. In Dorico we have two main playback modes in Play - Played Durations and Notated Durations.
  2. Would be nice if we have Expression Maps adjustable Offset, which is still not available in Dorico. This Offsets could be helpful in removing the need of creating Combined playing techniques?!
    The Expression Offset should be appliable to both Played and Notated Durations, depend on which one is selected in Play Mode.

Best regards,
Thurisaz

Just as an update: I changed all keyswitches to mod wheel cc ranges and now everything works as expected. It would be good though to have the possibility to use a lot of keyswitch changes in quick succession.

There is another problem. When I write slurs it changes the playing technique. Like in this example I would expect to see arco ord. in play mode but it changes to the buzz articulation.
And somehow, but I don’t know how to reproduce it without attaching my whole score, it gets stuck in the buzz articulation and doesn’t change back. I don’t know if the two issues are in any way connected or not.
expression maps question_3.zip (435 KB)

Slurs trigger the pt.legato playing technique. You should account for that in your own expression map, or set the ‘Suppress playback’ property for your slurs so they don’t have any effect in playback.

Is there an option to do that per default for each slur, accent and staccato? Preferably just for one instrument? Or do I have to click through each element to set that up?

edit: or alternatively how do I account for that in my expression map?

No, I’m afraid you can’t disable the effect of slurs, accents, etc. by default, and indeed you can’t use ‘Suppress playback’ for articulations in any case as that will mute the note itself.

To account for it in your expression map you’ll need to define the necessary combinations of legato plus your desired techniques and add them to the mutual exclusion group with the other techniques.