Problems with recording MIDI automation from my ROLAND GAIA

My name is Karol and I have some issues with Cubase and my synthesizer. It might be caused by the sound card as well, but I am not sure. That’s why I need help as I do not know what is causing it and how to fix it.
My Gear:

  • Cubase 8 Artist EE
  • ROLAND GAIA SH-01
  • M-Audio Fast Track Ultra
  • Edirol MA-15D
  • Various Free VST
  • Windows 7 64bit
  • 16GB RAM
  • Gigabyte GTX 970
  • AsRock B-75 pro 3m
  • Intel i5 3450 3,1 GHz
  • Sandisk Ultra 240GB SSD (cubase, project files and VST are on this drive)

As a main sound card I use M-Audio. GAIA output is connected directly to Edirol monitors and mono output into M-Audio to record it in Cubase. GAIA is connected to PC via USB. I do not use any MIDI connections. I had almost the same setup before and there were no issues. I used Cubase 5 Artist and Edirol UA25EX with all the rest the same. Problems started when I bought new Cubase.

My basic situation is like this. When I want to use my synth in Cubase and I have melody already I record MIDI notes. I use MIDI track with GAIA as Input on MIDI channel 1. I’m not such a great keyboard player, so I record notes and then quantize them and sometimes alter. When I’m ok with it, I play it back to GAIA as MIDI output, which is routed to and audio track as mono input. So it’s like if Cubase would hit the notes for me.
Problems appear when I want to use any MIDI automation to sync with my synth before recording audio track. I record knobs movement for the same track separately on a new lane. So I have MIDI notes and MIDI automation on 2 lanes. On GAIA I have 2 options to record automation. Either move the knob/slider or use D-Beam. Problem is, that as soon as I record any automation it does not reverse to its previous state. Especially with D-Beam.

What I mean is, for example, I have a patch on GAIA with cutoff set to 60. I record movement from that point to let’s say to 0 and back up to the same point where it was. Then I want to copy this riff to be played few times. But at the beginning of the next repeat cutoff is at 0 instead of original 60. It is before the recorded automation appears in the 2nd repeat of the riff. So I set it on original level and it doesn’t always work, because Cubase doesn’t read that. It’s like if Cubase would choose to override my automation.
This happens as soon as I want to change anything within the original patch. So I choose an option to extract all automation from key editor to track editor. Like Volume, mute, etc. Unfortunately it’s the same.
If I try harder to fix this and overlap MIDI parts, sometimes I might be lucky to remove this issue and have it all as wanted. Rarely.

Very recently my Cubase crashed when I tried to extract MIDI automation. I have Cubase damp files, which were created with this error.

Now with D-Beam it’s even worse. So let’s say I have a patch where D-Beam is setting cutoff at maximum and does a pitch bend. So I record this movement with MIDI automation and have 2 different CC automation tracks. You can clearly see it’s going up and down. And if there is another MIDI part on the same track after the one with recorded automation, the effect stays on! It’s not going back to the original values of those CCs. So I turn off green R button for reading automation, but it’s stil the same. It’s still being active even when automation on that MIDI track is turned of!!! So I double check with the key editor and I see there is no CC automation there at all. Only velocity. I have to reload the patch to have the original values again. Otherwise the whole patch is played like if I would hold my hand over D-beam constantly.

Other issues I have is sometimes when this D-Beam issue happens GAIA and Cubase freeze and you have very distorted noise sent constantly through audio. Also sometimes I cannot scroll view up and down with my mouse. I have to restart the Cubase and GAIA to make it all work again.

Another thing that happens occasionally when I load a patch (and I know how it should sound, cause I designed it) audio input sounds sort of “distorted”. I mean it’s like most of synth parameters would be slightly raised up or enhanced. It’s very similar to the issue described in first topic below.

I have tried to look for solutions for my problem, but I did not know how to describe it, to find related topics. All I found were these two: https://www.steinberg.net/forums/viewtopic.php?f=209&t=7509 https://www.steinberg.net/forums/viewtopic.php?f=226&t=86447
I have tried all the suggestions, but I either could not find how to do it or they did not work. I have spent some time with GAIA settings trying various MIDI settings combinations. Eventually I reset my synth to factory settings. No changes. It has latest firmware. I also tried various different Cubase settings for MIDI, etc. Also without luck. I also set Cubase to factory settings. M-Audio drivers are also the latest and were reinstalled.
I do not know how better I can describe this issue.
Can someone please guide me how can I fix these problems?

I can record a video with these problems if it helps.
Thank you in advance for all your help.

Hi, i have just purchased the Gaia and i am having trouble connecting using only the USB. Does the audio from your Gaia use the USB cable or do you use the analogue audio outs to monitors on the Gaia? I want both the midi and audio to use USB only. My midi works but I can not get audio from the Gaia into the DAW through USB, the Gaia does not show up as an input.