Problems With UR22

Hi,

So I recently purchased a Steinberg UR22, and have been trying to get it working for the past few days. After problems with the inputs and outputs, I have managed to solve a few of the problems I was having, but not all of them.

The main problem is with the input. This happens on all recording software I have tried; Cubase AI, Reaper and Audacity as well. After setting input as mono right, I get the volume from the guitar input, but it is very choppy. The audio stops every few seconds before starting again. This also happens when trying to record, except the recording has chunks of the audio missing, making a skipping effect. This obviously makes recording impossible. Is this problem caused by my laptop’s processing power? I have an AMD quad-core processor, and plenty of RAM and HDD space, running Windows 8.1 with everything updated. I would have thought I would have been okay, but maybe not? When I set the UR22 as my main computer output, the same problem occurs. When getting output straight from the headphone output, the dry guitar signal is totally fine, so the problem must lie within my laptop I believe. Any ideas?

Here’s an example: https://dl-web.dropbox.com/get/UR22%20Test.mp3?_subject_uid=18761818&w=AADPw0VFWpCeQxUkPuEQGMVJinYgLxFIpcZ2HbpD4dOlwQ

My other issue is the output. No matter what I set it to, I only get audio from the left side of my headphones. If I have headphones plugged into either the 1/L output or the 2/R output, set as both stereo or mono, I only get audio in the left ear. I assume this wouldn’t be an issue if I had stereo speakers with one plugged into each output, but I don’t have that option, and often use headphones. Is a stereo output possible with headphones?

Sorry for writing so much. If anyone could provide any help at all, it would be much appreciated.
Thanks in advance,
Ben.

Hello btcorbett,

Regarding the first issue, please take a look at our knowledgebase article on how to optimize your computer for working with a DAW.

You can find it here.

Another thing you should check is the buffer size you have selected.

You can find an explanation regarding this in the UR22’s operation manuel on page 8.

Regarding you second issue, please be aware that the output on the rear of the UR22 are Line outputs, which ARE mono. Therefore you find two of them. One is called 1/L (for left), one is called 2/R (for right).

If you want to connect your headphones to the UR22, please use the phones socket on the front panel.

You can find an explanation of the connection setup of the UR22 on page 10 in the operation manual.

Best regards,
Stefan

Hi Stefan, thanks for the reply!

I’ll definitely have a look at the article regarding optimising my computer.

In terms of the output question, I am now able to get DAW output through headphones. I must’ve routed something wrong before. Just a general question: If monitor speakers are connected as well as headphones, does audio output come through both?

Okay, so now I just need to try and sort out the audio quality issue. I’ll have a go soon and let you know if I have any success or not.

I really appreciate your time. I’m new to USB interfaces so sorry if some of the questions have obvious fixes/answers.
Thanks again,
Ben.

Hi Ben,

Good to hear that now the audio output is working for you.

If monitor speakers are connected as well as headphones, does audio output come through both?

With the UR22 the Line outputs and headphones ouput share the same signal.

But the UR22 has an headphones volume control that is independent from the master ouput.

So the answer to you question is: Yes, but you can control the volume level of both individually.

Best regards,
Stefan

Okay, thanks.

I did everything that the article suggested, and my issue has not been solved. Is there anything else I can try?

Thanks,
Ben.

The dropbox link doesn’t work any more. Could you re-upload the file again and also give some more details on the laptop model you use?
Have you installed the latest driver from here: http://www.steinberg.net/en/support/downloads_hardware/downloads_ur22.html

Hey, thanks for replying.

https://www.dropbox.com/s/kuggfhdggmp82pu/UR22%20Test.mp3

That link should work.

My laptop is a HP Pavilion 15-n278sa. It has a AMD A8-4555M APU processor (quad-core), 8GB of RAM, 1TB HHD, running windows 8.1. All software is up to date. I have just noticed that the 1.8.3 update documentation states a processor speed of 2GHz is required, and my processor runs at 1.60GHz. I’m assuming this is the source of my problem? If I was to upgrade to a processor that runs at 2GHz or higher, do you think my problem will be solved?

Thanks,
Ben.

Thanks for the link! It could well be the system and the system specs but to be on the safe side, I have forwarded this to development. Let’s see what they think regarding the system. Unfortunately, we do not have a similar setup here in support.

Okay, thanks for that!

Ben.

I received the information that it may well the the system and the performance it offers. The crackles sound a bit like it, I have to admit.
Development will continue investigate whether issues with such a system have come up during testing but that is unfortunately all I have at this point.
To rule out the device itself: can you test it on a different system with more CPU resources?

Hey, thanks for all your help!

I tried the interface on an old computer that I have in my house, which has a processor with a speed of 2.00GHz. I had tried to use it before, but the computer wasn’t able to recognise the disc for some reason. This time, however, everything installed correctly at the interface worked perfectly. So the issue the clock speed of my laptop processor. I’m going to look into upgrading and hopefully that should be the end of my problems :slight_smile:

I’m a bit annoyed though to be honest, as the system requirements state a dual-core CPU as the minimal required, but there is no mention of the 2.00GHz clock speed. If I had have known, I probably wouldn’t have purchased it.

Thanks again,
Ben.

Hi I’m having the same problem, is this really the answer to this issue, simply the clock speed of the processor?

I am having exactly the same problem with the UR22, it seems to be fine for a while and then starts dropping out randomly. Doesn’t matter what the buffer size is set to in the driver, just drops out all the time.

Recording is absolutely fine, have had no issues at all with the inputs, it’s just the playback that’s pretty much unusable using Cubase AI (it seems better in AI) or Ableton Live. If I mix the track I’m working on to a WAV file and play it back through Media Player it works absolutely fine however, this using a different driver at this point?

My system is Toshiba Laptop with a core2 duo 1.83Ghz Processor which runs at about 10% during playback/ recording, Physical Memory useage is low and Cubase is not paging. I’ve run all of the suggested optimisations on the help page with no joy and I can’t really believe that throwing more power at it is the answer. (It’s just as likely that the OP’s problem simply went away as he used a different machine that didn’t have the issue).

Please help as this is really bugging me, trying to get back into computer music after quite a long time away, and I’m really missing the simplicity of my Amiga right now! (That always worked, though I might be showing my age now!)

I will forward the suggestion to include a minimum clock speed to the system requirements.

Craigy, the Media player does not use the ASIO driver with significantly lower latencies. Cubase and Ableton do and this requires a higher overal system performance.
As a workaround it could help to increase the buffer size of the UR22 which will increase the latency or switch the ASIO driver to the DirectX Full Duplex driver in the VST audio system settings in Cubase AI.

Hi Ed,

Thanks for the Reply, I thought that might be the case with Media Player. Haven’t had any joy with rebuilding the machine; as a new install with no driver updates it doesn’t work, after updating all drivers it also doesn’t work.

If I run the DPC Latency checker it thinks everything is fine on the machine, just the UR22 that won’t run properly. What is the problem with the clock speed being too low? As I said before the processor is doing next to nothing, I have tried the highest buffer settings which make absolutely no difference. Also if I use the “test Tone” in abbleton which loads the processor to 80%, I get no dropouts at all on the audio even with very small buffer settings.

I don’t know if there’s a driver conflict somewhere that is causing this problem, I guess some chipsets just won’t play nicely with the UR22/ ASIO drivers.

I have it running fine on another machine but this was not the machine I wanted to use (for various reasons),

Craigy

Could you send me an email to info at steinberg . de , put my name in the subject and include a Windows system info file?
We will have to investigate a bit further here…

Thanks!

any resolution?

I haven’t received anything so far…

ED this isn’t actually a new problem is it!

People have been experiencing the same problem since version 7 of the software and that was before UR22 was available.

It would be interesting to know from anyone here if they are using Halion Symphonic Orchestra in any of their projects at the same time?

I have made a very interesting discovery that perhaps Steinberg should look at.

I have already posted this but here today but here goes:

I originally purchased 6.5 as my starting point with Cubase.

I loaded the HSO instruments as a trial and then purchased the licence.

When I upgraded to 7 and 7.5 and all hell let loose with drop outs which has been mentioned thought out this forum at various points (no trolling here please).

Anyway I did some testing with Magix Yellow Tools Independence as I held a licence with them in 7.5. This loaded into Cubase no problem. When I used these instruments no drop outs at all.

Same piece of music using HSO drop outs galore.

Anyway I got the Halion Sonic 2 full package when it was on special offer.

When I change my orchestral instruments from HSO to HS2 instruments I have no drop outs same as the Magix VST.

If I add the HSO instruments back into my project dropouts everywhere.

Now the strange thing is that when you export to lets say MP3 or raw state, you scan hear the instruments plan as day no dropouts. Pretty useless if you want to review in real time?

Which begs me to ask the question is there an issue with HSO in versions 7 onwards. In 6.5 I remember there being no issues.

I note that you need to be careful of which disc to use eg Cubase 5 is a no no but 6 onwards will work.

I never had Cubase 5 to start with so this is counted out in my situation.

Now I am re downloading the ISO as I write this topic.

I know that HS2 has it included as standard, but it still doesn’t work with Cubase 7.5.

Plus I have upgraded to 1.01 of the software.

The reason for not using the Magix product to its full capacity is it cant hold onto notes for more than 5 seconds which HSO can when it wants to work.

But has anyone else experienced the same with HSO basically being pants in version 7 onwards :question:

I think if you or Steinberg address this problem you might find what is the issue with your software not the hardware.

To be honest I was looking at purchasing the UR44. Now I see this, I am thinking what the heck my ESI gigaport HD has another year left in it if I am going to get the same issues.

Hello,

I had the same problem when plugged into usb 3.0. (intermittent glitch/silent)
I plugged the ur44 on usb 2.0 then problem solved. :sunglasses:
I guess there is something wrong with the driver trough usb 3.0 :neutral_face:

I have similar problems with cubase AI7 and the UR22 interface.
I thought this interface would be perfectly intergrating with cubase so I bought it.
It seems that the driver is not very well written, because when I switch to the standard ASIO driver, deliverd by windows 7, there is no problem at all, and everything running smooth !
With UR22 driver, audio dropouts appear, sometimes by opening ONE window of a vst2 plugin.
Dropouts appear when I use ONE window of the EQ curve display.
And NO, there are no performance issues with my PC… only very hard CPU spikes from 10% to 100% (ore more)
Here lies a job for steinberg for revieuw, rewrite and update this driver…