Problems with Yamaha USB midi driver on Cubase 10

I am trying to configure a Win10 PC running Cubase 10 to receive midi data from a Yamaha CP4 keyboard (i.e. use keyboard as midi controller). I am using The Grand piano VST and monitoring while playing. Significant latency makes it unplayable. I have installed the ‘Yamaha USB midi driver’ version 3.1.4. found on the Yamaha website (it shows up as working in Control Panel → programs), however it does not appear in Device Manager (which seems odd).

When I go to the Studio tab → Studio Setup → VST audio system panel, there is a dropdown box that allows selecting ASIO driver. The Yamaha USB driver does not appear as an option in the dropdown box. Only options are ‘None’ and ‘Generic Low Latency Asio Driver’ (built into Cubase). If I choose None, no sound comes out when I play the CP4. When I select the Generic Low Latency Asio Driver, it shows input latency = 20 ms and output latency = 20 ms. Turning on Asio guard seems to add more latency, so I have unchecked it.
I have also tried unistalling the above driver and installing another driver called the Yamaha Steinberg USB driver found on the Steinberg website. file is called Yamaha Steinberg USB Driver 2.0.4
This driver (when installed) DOES appear in the ASIO dropdown list, however when I try to select it from the list, I get a pop error message stating: Device could not be opened. With this driver installed, but generic driver selected, latency remains high.

My questions:
should I be able to choose the Yamaha USB driver v3.1.4 as my Asio driver?
if it isn’t necessary, why am I getting high latency, and why does choosing NONE lead to no sound at all.

I asked some of these questions to Yamaha support, and they told me that ASIO (Audio Signal INPUT OUTPUT) is not relevant in the scenario where the controller keyboard is sending only Midi and not audio data.

If anyone can shed light on this situation, I would be deeply appreciative.

I suppose you are using your computer’s built-in soundcard?

If you don’t have a Yamaha sound card, no.

The generic ASIO driver uses your onboard card. It is expected to exhibit some latency. In your case, playing keyboard, this latency is very noticeable.

You could try downloading ASIO4ALL, a generic driver to be used by your onboard soundcard, and check out how it goes. (my guess is you won’t see much improvement)
Or you could buy an inexpensive external soundcard (USB) that supports ASIO. Most of these have latency of about 6-8 milliseconds, which is considerably better than what you are experiencing now.

Keep in mind that latency also depends on the sample rate used. Higher sample rate = lower latency BUT higher strain on the processor. So, it depends on your system really.

The Yamaha USB MIDI driver is just to get MIDI happening between your piano and your computer… It has nothing to do with latency. So, what you did initially was correct, to install the Yamaha USB MIDI driver.

What you are looking for in the ASIO dropdown list, however, is your AUDIO device, but you haven’t stated what that is yet. How are you hearing the sound coming from your computer? Through what device? THAT’s the audio device you want to select in that list. It looks like you will need to install an ASIO driver like ASIO4ALL, as ggmanestraki said.

And then once selected, you want to click on the control panel button there (I think that’s what it’s called) which will take you to a place where you can change your Audio buffer settings. Change it to something like 256.

Profound thanks to ggmanestraki and shagazulu!
My audio is just the internal soundcard of the Win10 machine, routed via HDMI to a SONY tv which then is routing sound to a Yamaha YSP 2700 music cast sound bar via HDMI ARC output.
I have installed ASIO4ALL v2, however, when I switch to it as my ASIO driver, no sound comes out. It does show reduced latency (drops from 20ms with the generic driver to 13ms with ASIO4ALL).
Not sure what to do with that, but perhaps I would get better results if I bought an external USB sound card that supports ASIO (as you recommend)? Do you think that might solve my latency issue (and perhaps produce better quality sound)? Also, perhaps it would be better if I didn’t route through the TV? Can either of you recommend an external USB device that would work for this setup?

Ah… but this changes everything!

So let’s make it clear, shall we?

Are you using the SONY TV as a computer monitor + Speakers? If that’s the case, what’s coming out of your computer (HDMI port) is from yet another driver, probably a “High Definition Audio something something”.

The ASIO driver is about your computer’s internal soundcard, probably a REALTEK something, and the sound is expected to come out from the lime colored mini-jack, or the phones jack, on your computer’s case. Try to connect it to the TV with a minijack to RCA pair and see how it goes. 13 ms of latency is still on the high side (for me). However, you can open the control panel and adjust the buffer size and see how your card response. You may get lower latency without problems, or it might choke. Remember to test this (ASIO4ALL, or Generic Low Latency driver but with Realtek selected) using even inexpensive buds you have laying around. (a phone handsfree will do in a pinch, just to make sure you’re getting sound)

A fairly standard USB interface is Focusrite 2i2 @ about 150€.
A cheaper alternative is Behringer UMC202HD @ about 70€.

Both will offer good performance, but in both cases you will have to connect them to your TV utilizing analog connections. Both cards output 2 TRS jacks that you’ll have to bring over to your TV either by means of 2 TS->2 RCA, 2TRS->Mini stereo jack, all depends on what your TV offers.

By the way, I too use my Displayport to send sound to my monitor, but when I want to play or record music, I connect my audio interface. Or if I’m in a rush to test something quick and dirty, I just plug-in my phones to my computer case’s PHONES in (and thus use the onboard REALTEK, which is good enough for this quick and dirty doodling)

Hi ggmanestraki,
thanks so much for your assistance!
I will take your advice and order the Focusrite 2i2. I will have to figure what sort of cabling I will need.
Your suggestion regarding headphones is spot on! No delay whatsoever.
1 more question:
when I get the Focusrite, should I bypass the tv and try to connect the pc directly to my soundbar?

I’m afraid the soundbar needs the TV to play. From what I’ve seen they have an HDMI arc in, and an optical in. You can’t send either of them from your computer. What you can do, right now, without ordering a soundcard, is:

Figure out which cable you need to connect the computer’s green out to your TV, and then play with the ASIO buffer setting. You may well get acceptable performance out of what you already have.

If you decide to go with a USB interface, you’ll need to do the exact same exercise (when it comes to figuring out and buying cables), you’ll gain some (but not tremendous) sound quality, and the only thing that you’ll buy into that you don’t have right now, is a way to connect 2 microphones, or 2 instruments (guitars, basses, keyboards etc). You can also completely free yourself from the TV (when it comes to sound) and hook up some small studio monitors instead.

It’s your call, if you want the ability to connect up to 2 microphones, instruments etc, go ahead. If you just want to send your sound to your TV+soundbar with less latency, I’d suggest that you stick with it a bit more, and try to squeeze what you might out of what you already have!

Hi, working on your suggestions. Your advice is invaluable. I reduced the buffer size to the minimum possible and it reduced my latency to 4ms! so perhaps you are right and I don’t actually need to buy a focusrite unless I get ambitious and try to add in live instruments like voice or guitar. Can’t thank you enough!
Now I am scratching my head because previously I was able to play Cubase through my headphones (plugged into the pc) but now I have screwed something up so when I switch the pc to headphones, all apps play through the headphones (browser, vlc, etc) except Cubase. for some reason I can’t route Cubase to the headphones (maddening!). So that is my next challenge to sort out. But at least my piano is playable so I am very happy :grinning_face_with_smiling_eyes:

oh btw, my soundbar does have 2 rca inputs, so maybe I can bypass the tv. but it may be more trouble than its worth.

That’s lovely! Regarding the soundbard’s RCA, make sure it’s actually an analog RCA and not some digital SPDIF. If it’s a plain analog RCA input, you can bypass the TV.

Regarding Cubase, double check your connections at the audio connections window (F4 key). That’s if you’re not getting sound at all. If the sound gets intermittent and cuts out, then you’ve probably gone too far with lowering the buffer, and your CPU finds it hard to keep up. (I doubt it since we’re talking just one instrument here, but I’m saying it anyway.)

I’m very glad you sorted it out! :+1:t3:

Hi, here’s some additional info in case someone out there is reading the forum, maybe I can spare them some grief.
ASIO4ALL worked to reduce my latency to 4 ms. I know that’s quite low, but to be honest, I still feel it when playing rapid piano parts, especially with rapid rhythmic changes.
So I think I will still do much of my recording with headphones which have no latency at all.
Having switched to the ASIO4ALL driver, I became baffled when I could no longer route the audio to my headphones. When you go into the Control Panel for ASIO$ALL (inside the driver setting in Studio Settings), there is an option to switch to the headphones, but for some reason, it doesn’t work in ASIO4ALL. No sound comes out of the headphones or speakers.
However, if I switch back to the Generic driver, sound is routed nicely to the headphones with 0 latency. :smiley:
So I guess my solution is to play with headphones + generic driver, unless I want to play live for someone, in which case I will have to switch to the speakers, with the ASIO4ALL driver and accept a 4ms latency (which is noticeable but still viable).
Thanks again for your wonderful insights!