Programe Change doesn't work on Yamaha MODX

Hello! I’m not being succesful at sending PC to my MODX. I’m doing it through a layer in each part of the song where I change the sound of the MODX to play.

I have set the layer as follows:

  • Instrument to MODX-1 (Midi Port)
  • Midi Input: I’ve tried nc, VM1 and MODX-1
  • PRG CHG: 36 (is an example of one of the presets)
  • On the quick controls I’ve set up:
    1st one to MSB (CC00), and value to 64 (which is the value that MODX shows me to select the preset)
    2nd one to LSB (CC32), and value to 32 (which is the value that MODX shows me to select the preset)

But nothing happens on MODX. Can you tell me if I’m doing anything wrong? As far as I know, this is the way…

PD: I’ve also tried to enter the MSB and LSB values on Layer Controller Map, but it doesn’t work anyway


First, make sure to have the latest version. Seconds, the MIDI Program Change/Bank Select triplet is sent whenever you activate (select) a Part, so did you try to toggle Parts (switch back and forth)?
If you have a MIDI Interface, you can also use the built-in MIDI Monitor to see what VST Live sends. If your audio interface has MIDI in/out, you might try and connect in and out with a MIDI cable and send to its oputput and set MIDI Monitor (Devices menu) to that input. You should see Pgm Chg and Bank Select messages then.
Found this, maybe it helps…

Hi! Thanks a lot for your quick support.

Answering to your questions, I have tried everything without success. No Midi transmission from the PC to the MODX or through UR44 interface.

I have read the link you sent it and tried to trigger Livesets instead of Performances with MSB and LSB at 32 and 0 respectively, but also without success.

I’m quite lost with this. I have used Cubase for live since ever and never had an issue triggering performances on my modx. I don’t know why with Live I can’t get it….

Do you have any other idea to try?

Thanks again

Yes. Please create a Layer with the built-in Halion Sonic SE (HSSE). Open the HSSE editor, go to options and there, with “Program Change”, set to “GM Mode”.
Now while the editor is still open, change Program Change in the Layer and see how the first HSSE slot reacts, right?
Those messages are likewise sent to the selected MIDI Output when you choose that instead of HSSE in Layer/Instrument. Note that the output MIDI channel matters. If set to “Any”, it will send to channel 0.
Furthermore, your UR44 has physical MIDI Input and MIDI Output ports. Connect those 2 with a 5-pin DIN MIDI cable, and open Devices/MIDI Monitor. In there, select UR44 In, and if your Layer Instrument is set to UR44 MIDI Out, and PGM CHG is set to anything but (nc), you should see what the Layer sends in the MIDI Monitor. This is what is sent to any other plug-in or physical MIDI output selected in Layer Instrument whenever you change PGM CHG, or activate its Part (select another Part, then select that Part again).
Hope that helps.

Thanks again!

I’ve tried with Halion and yes, it worked.

Then I connected 5pin midi cables to UR44, and again, I could see the PC messages on the Midi monitor.

But when I put MODX-1 as midi output on the layer, nothing happens and there is no activity on the midi monitor. I tried it again with “any” and “1” as midi channels.

Just if it helps, on the layers the midi input is set to (nc), maybe should I put any other thing?

Sure, you send to MODX-1 instead of UR44, so nothing is sent to UR44 and thus, nothing is received on UR44 in for the MIDI Monitor to show.
Layer → Ur44 out - > MIDI Cable → UR44 In → Midi Monitor
Layer → MODX-1 out: no more connection to UR44 In (where Midi Monitor listens).

I don’t know the MODX-1 sufficiently to get a clue about what is going wrong. But the setup with the Midi Monitor proves that the Layer is sending correctly, so the problem must be with settings in the MODX-1.

Let’s check one more thing: Layer output (Instrument) set to MODX-1, Layer Input set to “Virtual Midi 1”, open “Devices/Virtual Keyboard” and tick “Seq” and/or “Chords”. Does the MODX-1 play? If not, there isn’t even a connection to the MODX-1. Maybe you selected MODX-1 input instead of output in Devices/Connections (don’t know if that’s possible)?

Hi! I’ve tried it with the virtual keyboard and it sounds, so there’s a midi connection between Vst Live and the Modx. But still no luck with program changes… I keep on investigating….
Pd: by the way, connections are ok. Modx1 is only on output
Thanks for your help!

Hi again!

I have just discovered that if I create a Midi Track (which output is set to modx-1 port), and draw a midi event, and then select that event and open Midi editor, I can write there MSB and LSB values as control changes, and one program change.

I have tried this and then the modx change to the right program!

But it must be in the right order:

  1. MSB
  2. LSB
  3. PC

If you put PC before MSB for instance, then it doesn’t work. Maybe is here the problem with the layers, so PC is being sent before MSB and LSB?

I could do it in this way as an emergency solution but I think it has no sense to work in this way and not through layers. Let’s say this is the same way I work with Cubase in live gigs.

Is this giving you any clue?

No, it should send it exactly like so: BS MSB, BS LSB, PGM CHG.
And that is what you do, right?
I cannot check it currently, but if you try the UR44 MIDI cable shortcut with MIDI Monitor, it should show you what it sends and in what order?

Question: which MODX version do you use?

I don’t remember the order when I did it today, I will check tomorrow and let you know

It’s a MODX 8, with the last update (2.52, I double checked…)

It’s quite strange than with Midi events the Midi messages work, but not with the layer…

Hello! I have made a few more tests:

  • I have used VST Live with a Macbook on the MODX instead of PC. Same results.
  • I have connected VST Live from PC to a NORD keyboard through USB, and with the NORD all the program changes work perfectly.

Still I don’t know what happens with MODX… keep on investigating

Might be a timing problem. We’ll try to get hold of one.

Thanks! If you get it, pls let me know. Just as additional info in case it helps, I’m running the Demo version of VST Live (since I wanted to check before buying). Maybe is just the same version than the full licence, just in case…

PD: I’m also asking on MODX Forums to know if anything else has had this problem and found a solution

We may have found a problem that explains your report: pls check in “Layer/Layer Controller Map” if cc#32 is mapped to cc#0. That’s a bug (when trying to convert older projects), will be fixed with the upcoming version (soon), sorry.