Project Logical Editor: How do I Select 'In Loop'?

Hi

I’m trying to set up some Project Logtic Editor presets so I can quickly select say muted parts inside a loop, unmuted parts inside a loop etc.

I’m having a problem with the ‘position’ parameter in the editor. There is an option for ‘inside cycle’ but this only selects parts which start inside the loop locators, not all parts inside the loop. By contrast, the normal select->In Loop parameter in the edit menu, correctly selects parts which start or finish or run across the loop area.

So, short question, in the Project Logical Editor, how do I select everything inside the loop?

Many thanks for any help, and sorry if the explanation above isn’t terribly clear.

Jules

The Position filter really means Start Position, which is different question from ‘does something exist at this timeline position?’ You could perform this command with a macro if you wanted though, such as

Select in loop
<PLE ‘select muted’ preset>

Hi Steve

Many thanks for the tip.

Just so I’m clear, I would create a macro that ‘selects in loop’ and then runs an LPE preset which, for example, selects unmuted parts from those already selected. Is that roughly how it would work?

Thanks again.

Jules

Yes.

Unless I’m doing something wrong, it doesn’t work properly here.

I’ve created a macro which ‘selects inside loop’ and then runs the PLE which is set to 1. Container type: Parts 2. Property - Not Set - Muted 3. Property - Set - Selected. Along with the appropriate ANDs and brackets. This should select the unmuted parts among those selected. In combination, the macro should just select the unmuted parts within the loop locators.

What happens here is that the muted parts are not deselcted until you move the cursor over them - meaning that if you run the macro and then grab what’s selected, you’re grabbing everything within the loop.

Could be I’m missing something, but the way the muted parts become unselected as you move the cursor over them (no clicking) seems to suggest there’s something wrong either with the PLE or the GUI.

Any thoughts very much appreciated. All I need is a quick and easy way to select all unmuted parts inside the loop locators.

Thanks again for your help Steve.

Jules

Does look like a redraw bug, the parts seem to not actually be selected.

A workaround for the time being could be to add two “Invert Selection” commands to the end of the macro. That worked here.

Steve you’re a legend - thank you!

At the risk of taking advantage of your knowledge, could I possibly ask two other really quick snap/grid related qeustions, whcih I can’t find a solution to?

  1. When I copy and drag, snap functionality is overriden, meaning I have infinite movement and can’t easily line copied clips up to bars/beats. If I just drag, snap works fine, ditto if I use constrained copy, but just standard copy always overrides the snap functionality. Am I missing a setting to enable copy and dragging whilst retaining snap?

  2. If I set a loop, and then use the hand to move that loop, is there any way of doing the opposite to the above, and overriding snap, so I can drag it say just a few ticks before the bar start? I’ve tried every combination of modifers, but whenever I drag the timeline loop, it always snaps?

Sorry to impose and thank you so much for your help.

Jules

Did you change the modifier key settings in prefs? There is a suspend snap function hardwired to command/ctrl.

Please add a sig with your OS etc.

I changed the copy modifier from alt to cntrl. I’m looking at prefs -> Editing-> Tool modifiers-> Drag and Drop and don’t see a modifier for ‘suspend snap’. I just see:

Constrain Direction
Copy
Shared Copy

Sig added.

Yeah, it’s not documented, or configurable. You’d have to change your copy modifier back to alt.

Thanks Steve.

I changed the copy modifier back to alt and it enables me to copy using snap. However, the snap suspend does not work when dragging/moving the timeline loop locators - either dragging with the hand tool or moving locators individually. I always set my loops to just before the beat so they pick up notes I’ve had to move forward. Do you have any ideas how I would do this?

Sorry if this is documented somewhere - I promise I have looked.

Thanks again for all your help.

Jules

It doesn’t, and It’s not. You have fully understood. :wink:

You can use macros for that, using transport nudge and locator commands .

Many thanks Steve - I’ll look into it and leave you in peace.

Using macros and nudge to shift locators seems kind’a clunky, but I guess no software is perfect …

Thanks again.