Project setup: Negative start time that is smaller than -1 00:00:00:00

I am working with an old project. I tried to reinsert media at origin time. But it’s telling me the origin time is before the project start time. So I look in the pool and it says something like origin time is -

I read you can set a negative project start time, so I try, but the only way it works is if I enter a negative number at the very beginning, which seems to mean negative X days or something like that. (I’m not sure how to read the timecode–is it hours, minutes, seconds, frames? Hours, minutes, seconds, hundredths of a second? Couldn’t find a clear explanation in the help files.)

I can’t enter - 00:00:01:00, for example. Only -1 00:00:00:00. So then everything in the project gets pushed way over to the right and I’m dealing with a huge timeline that goes way beyond the two to five minutes I actually have audio on.

Is this a bug or am I missing something?

Yes that’s right. -1 00:00:00:00 is 24 hours before the zero time. If you add hours and minutes, you come back to the zero time.
-1 23:55:00:00 is five minutes to midnight. :wink:

1 Like

Do you know of a way to do just a few seconds negative, or at most a minute? Because it won’t retain the negative for anything less than that full day I gave as the example–it keeps the number, but gets rid of the negative sign as soon as I hit enter, making it a positive value.

Ok, well, after examining my old project files in Cubase LE 1.07, I discovered that although it doesn’t show any negative values for the origin time in the project pool, if you click on one of the cells you indeed do see a negative value, at least as long as you keep the cell active with your mouse cursor–as soon as you let go, it disappears.

And since Cubase LE 1.07 was showing me seconds and Cubase 12 was showing me bars and beats, it wasn’t obvious how things related. So I switched the timecode displays in both to seconds to see what was happening.

Turns out Cubase LE 1.07 shows the origin time as, for example, -00:00:00.211. Meanwhile, for the same track and take, Cubase 12 shows it as -1 23:59:59.789. Add 211 milliseconds to 789 milliseconds and you get 1000 milliseconds, aka 1 second, and it appears what is happening is Cubase LE 1.07 is doing negative numbers relative to 0 like you’d normally expect, while Cubase 12 is say, if you were starting the day before 0, this is the timestamp within that day where that file’s origin time would fall.

As usual, all of that was CLEAR AS MUD from the help files Steinberg provides, the terminology they use, etc., and I only found it by fiddling and experimenting and scrutinizing.

This is a big part of why I started using Reaper–when they meant “takes”, they said “takes”, not “events” and “lanes” and whatnot. Ugh. Much of the battle with these programs is just trying to guess whatever the developers were thinking and decipher what they mean by the words they use. And then of course dealing with bugs they overlooked.

So there you have it…if you want your timeline to start at negative 2 seconds, for example, you need to go to Project > Project Setup > Project Start Time, double click until the whole field is selected and turns white like a free text field to save yourself the headaches of trying to edit it starting with a single left-click (try and you’ll see what I mean), and punch in -1 23:59:58:00.

And for -211 milliseconds like that example I gave, well, your guess is as good as mine. Whatever Steinberg means by the two digits after the last colon, it does not appear to be milliseconds. Frames maybe? Couldn’t find a clear explanation in the help files, so I gave up.

Another option of setting a negative start time and one I use in all my projects, is to use the command Set Timecode at Cursor from the Project menu.

You mean this?

This is what st10ss wrote a few hours before. Not sure why you think you had to find it yourself when the answer was given to you prior.