Properties panel text input windows ALT-codes with zeros losing focus

When entering text in the properties panel (eg. Tempo>Text, Dynamics>Suffix) it is currently not possible to enter any characters using Windows ALT-codes that contain a 0 such as an em-dash ( , ALT+0151)

I presume that Dorico is interpreting the ALT+0 and ALT+Num0 key combinations as a global shortcut which then causes the text box to lose focus, mid ALT-code.

These characters are obviously still supported by Dorico in these properties as it is possible to copy-paste them from elsewhere (including Shift-X text and popovers).

Yes, your diagnosis is correct. Alt+0 is a key command that returns the focus to the music area.

Can this be remapped/disabled? I’ve searched Preferences>Key Commands dialog for the relevant command to no avail.

Given that this conflicts with a global feature of the Windows OS, I’d suggest that Dorico either use a different default key binding, or at least disable it in when in “active” text boxes.

You can disable it manually, yes. You’ll need a decent text editor and a strong enough nerve to manually edit JSON files. (You can check that your edited JSON is still valid by pasting it into e.g. here.)

Look in %APPDATA%\Steinberg\Dorico 5 and find your keycommands_en.json file. Open it up in your favourite text editor and insert the following somewhere in the kGlobal context:

				{
					"UI.SetFocus?Value=kScoreView": [ "DELETE:Alt+0" ]
				},

Save the file, check it’s still valid, and then restart Dorico.

1 Like

Thanks! That works perfectly.