PSP Audioware Twin-L vst effect crashing Cubase

I recently bought the Twin-L plug in from PSP Audioware and the VST 3 version of the plugin is causing Cubase Pro 10 and Cubase pro 9.5 to hang on start up. The plug in is a full license (not a demo) and I have activated it in iLOK. I have contacted PSP Audioware and they seem adamant it is something on my machine that is causing even though when I delete the Twin-L VST 3 file and run Cubase it starts fine. I am sick of developers trying to pass the buck. Has anyone else bought this brand new plug in and had any issues? I am using Windows 10 Pro 64 bit 1809.

I have the same problem with the Vst3 version in Cubase 9.5 and 10… also on Windows 10 Pro 64 bit (two different versions inc. 1809).

Thank you for clarifying, Have you also done what the developer is suggesting which is to update your iLOK software? I did this (even uninstalled the iLOK, and then restarted my pc, downloaded the latest version of ILOK and installed a clean version). It made no difference whatsoever! Like I said all my other VST3 plugins (including several PSPaudioware ones) are fine. They need to sort this, particularly given that Steinberg are not supporting the SDKs for the older VST plugins moving forward.

This is the only time I have had any problems with this developer’s software in all the years of being a customer and I am confident it will be sorted in due course. PSPaudioware are an excellent developer. In the mean time, the VST 2.7 version of the plug in seems to work OK.

This is a new plugin and these are just teething problems. I (as you can probably detect from my tone!) am just feeling frustrated as you expect things to work and it is disappointing when they don’t, especially knowing how hard you have to work to pay for things! (cue the world’s smallest violin! :mrgreen: )

Yes… Latest iLok manager software here…

And yes, the first time I have had any problems with any of their plugins.

If you are happy to can you PM me with your system build and I will do the same back, just to see if there we have something in common that could be causing this. According to the developer there are no issues their end (but then I would expect them to say that!) however another user is having the same issue on this forum
https://www.gearslutz.com/board/namm-2019-show/1247202-psp-audioware-introduces-twin-l-dual-algorithm-classic-limiter.html

Is anyone here able to run the VST3 version of Twin-L in Cubase 9.5 or 10? Just curious. Please check the version of the plugin you are running before posting as the installer also installs a VST 2 version. I am interested in VST3

Tech-Dance - Carvin Man - it’d be helpful to others if you included your computer setup in your sig.

Done

Hi,

no problem with any of PSP plugins here

And to clarify you don’t work for PSP Audiiware and are running Twin-L and the VST3 version installed. Please check it is in your VST3 folder

I’m not certain of enough clarity in your request…
Anyway… It is as I stated but I run Cubase on Win7, maybe that’s one of your problems.

cheers


trito

I’ve found the VST3 support from PSP not mature yet. In my particular setup, Vintage Warmer 2 VST3 is also misbehaving, with very long starting times. If I were you, I’d stick to the VST2 versions for now, until PSP iron out the bugs.

No probs with Vintage Warmer 2 or any of my PSP Audioware plug ins other than the VST3 version of Twin-L here. I agree the support hasn’t been great so far but the guys at PSP seem to be suffereing from from jet lag from being at NAMM in North America. NAMM finished a couple of weeks now however! My current advice to everyone is to try out the demo before placing an order for this plugin. The VST 2 version of the plugin thankfully works fine here. Make sure you’ve activated the plugin in the latest iLok software. It didn’t make a difference here but has apparently worked for some people and should be done as a matter of course anyway.

I agree. I also own several PSP plugins (Noble Q, Echo, SpringBox, Vintage Warmer 2). They all have been working flawlessly for years in their VST 2 versions. The only one that was recently updated to VST 3 was Vintage Warmer 2 and, as I said above, Cubase doesn’t seem to like the way the VST 3 port was implemented (it hangs for several seconds when instantiating the plugin). However, the VST 2, which also uses iLok in this latest version (2.7.3), still works fine.

With Twin-L it hangs and hangs forever in my case! Until I hit CTRL-ALT-DELETE that is!

In addition to my previous post…
I use almost all of PSP plugins both VST2 (because of past projects) and VST 3 - for the present ones and never encountered any problems. I don’t use iLock key versions though.

Tech-dance, I really dont’t want to force You to use Win 7 which is sooo old (but serving me well), only inform You about it. So: no problems witn VST3 but in Win7 and I’m not affiliated with the PSP company maybe except for country of origin… :wink:


cheers and peace

trito

I have no problems in Windows 10 (64) running VST3 plugins bar Twin-L. This is a very odd one! And trito I take it you are from the land of that lovely fellow Mr Tusk, Poland! If you see him thank him for his kind words about the UK recently :slight_smile:

He’s still Your fellow until Brexit… I don’t get Your point of view, so sorry, be safe.


cheers

trito