Punch out not operating as expected

If I have a cycle / loop setup, it doesn’t automatically mean I want takes. So how do I stop that?

When I record the first loop, I want record to disable but the loop should still play. Im holding a guitar or bass and I don’t want to press key commands or crap like that or a foot switch to start and stop. And I don’t want the loop to stop just because I am done recording.

I tried disable and enable punch in and out, but no matter what I try, I get these stupid ***** multiple overlapping takes. I don’t what that. I should be the person in control of that no?

I’ve ran into some situation where I wanted this as well, as I often work with cycle enabled, and I’m curious if there’s a solid way to do this as well.

Just to clarify your situation above… I assume you have a section you want to loop, and you set your punch-in at the start of said section, and punch-out at the end.
Hit play some time before the loop section, and as it enters the section, record starts as expected, but when the loop restarts you want it to punch-out, right?

I’d like a convenient way to set this up as well if there is a way.

@Michael_Stram : could you post a screenshot of how you set your loop and punch in/out points up?
@Shor : what do you mean by convenient way? Why don’t you use the way you described it? Is there sth wrong or is it to complicated?

Oh no, it doesn’t actually punch-out when you use a loop like that.
It starts recording on punch in, but never punches out.
We want it to punch out at the end of the loop marker.

This is kinda kludgy but I think would work.

  1. Set your loop punch points the way you want
  2. For both the Punch In & Out points use the Info Line to move them 1 Tick earlier (i.e. a super tiny amount)

Now your recording will actually start just before the Loop Start and Punch Out before looping back. But when it does loop back it will be to just after the Punch In point so that won’t get triggered on the second and subsequent loops.


Have PUNCH IN and PUNCH OUT on the SAME BAR / BEAT. Set your cycle how you want.

Example :

Loop / Cycle Bars 1 to 5. Setup Punch In and Punch Out on the END of the cycle / loop. Boom…it takes the transport OUT of record, and loops back to the cycle / loop start and there you go!

Hacky. Not Ideal. Weird. And now I need to make a macro that turns off input monitor when its out of record.

I’m not actually sure how you got this to work? Did you mean like this? It’s not working for me in Cubase 11 Pro.

Also for your input monitor off when out of record, you should check out auto-monitor settings under Preferences->VST
I have mine set up as tapemachine style which sounds like what you want.


Yeah so in Nuendo 11, its working this way. And yeah you have it setup where the punch in and outs are on the same bar. I don’t have the punch lock engaged. And when the loop goes back to the start of the cycle, it takes transport out of record for me.

Ahh okay… that’s actually pretty neat.
It doesn’t work in Cubase 11 unfortunately. It doesn’t punch in.