Qt platform plugin could not be initialized

Hello everybody,
Just purchased and installed the Special Edition (synchron-ized) from VSL, and dowloaded the playback templates from MyVSL. This is what happens. Have anyone had this problem? I’m on Windows, of course (sorry about that). Attatchin a project wont help I suspect, since this happens when cretaing a new, blank projekt as well as using an existing one. BBC SO works fine, HSO too, and so on. Suggestions?

Dorico works fine on all other aspects, and I can use all the samples from VSL via the Synchron Player outside of Dorico (sounds great), but not in combination with the templates.

I’m grateful for any input.


1 Like

VSL Helper only gets invoked if something needs to be converted from eLicenser to iLok. Since you downloaded the templates from MyVSL, I suspect that is the problem.
Files from MyVSL are for eLicenser. You need to get all the iLok files (including the templates) using Vienna Assistant.

VSL helper should convert in any event, but you need to either have your eLicenser key connected (assuming you have one with an appropriate license) or be connected to the internet for the VSL Helper app to work.

OK, thanks. I will have to contact VSL then, because I have everything on iLok. Didn’t know that I could dowload the Dorico-templates via the VSL Assistant, but when I did on your suggestion, it did not solve the problem.

Music should be fun, and not filled with these problems.

Have a great day, dlb!

A quick update if anyone else get this problem. Andreas over at VSL solved it after a few rounds, and the cause is the Vienna Ensemble being installed after the Synchron Player. They will issue an update for VE to fix this.

The solution is to just re-install Synchron Player.


I just got this error today, so guess they haven’t fixed it yet. Yarblek’s solution did the trick.

1 Like

I’ve just had exactly the same after being asked to update Vienna Ensemble and the Synchron player. Despite reinstalling Synchron player, I’m still stuck. What’s the latest here? I have everything on iLok as well

UPDATE several uninstalls and reinstall later, it’s finally working again. I don’t know why VSL updates have become so flaky over the past year or so – they used to be rock solid.

1 Like