Quantizing Issue, Steinberg Support has been unable to help

About a year ago I sent in a support ticket to have this issue get fixed. That ticket led to me upgrading to Cubase only to have the problem still not solved. I purchased an entire upgrade to see if the issue would be fixed, and my problem has persisted. I’ve reinstalled Cubase, AND reformatted my computer, but nothing. For the last 8 months, I have waited to hear back from Steinberg and every time I try to get an update on this issue, the response is “We are still waiting to hear back from our team in Germany”. Normally, I wouldn’t mind so much, but this issue is making Cubase annoying, and slowing down my workflow immensely. I have projects that I need to have done, and deadlines that I need to complete!

Basically, nothing in my project is quantizing properly unless I zoom into the grid 100% and move everything close to the grid I want. Below are a few videos of how MIDI, Automation and audio react in Cubase. I am running Windows 10 64bit and Cubase Pro 9. You can see in these video how when zoomed out, some of the clips appear to be quantized properly, but when I zoom in, you’ll notice they are slightly off. This becomes a problem when I’m arranging a track, because by the end of the track everything is out of sync.

MIDI / Automation
https://streamable.com/82wbz

Audio
https://streamable.com/zq4vl

Here on Cubase PRO 9.5.10 ik works fine, no problem

mate, look at your settings here

for SNAP could work perfect you need this setting. Not only automation out of grid in you stream but the other parts too. You have “relative” setting, try only grid, no iterative quantize (what is that, btw?!) and audio warp quantize. I have this plain settings and never fall into issues.

Also I check Info field to know for sure that everything is on the grid. Sometimes type values in manually.

Also for quick moving parts or automation dots use “move to cursor” hot key.

And yes, upgrade to 9.5, its automation fabulous now.

also be aware of this setting, “snap to zero crossing” it can do evil tricks while changing audio file’s clip start and end position. Read and understand this feature, it’s cool, but in the right hands.

I have tried all of this but nothing is working. None of my MIDI bars or audio clips are quantizing to the grid. It’s always SLIGHTLY off…
I’ve also tried disabling Zero-Point Crossing, but nothing.

You have iterative quantize turned on. Turn it off and set snap to Grid.

There is nothing for SB to fix here, as far as this post goes. If there was there would be scores of reports for these commonly used functions.

Oh, well, if steve says you have not a problem…

With the absolute greatest of respect, I have been doing all sorts of tech support for donkeys years - and this timeline will not snap to any quantize point. NOTHING FOR SB TO FIX HERE? That’s an astonishingly arrogant thing to say, please don’t put people down like that, it’s really awful.
I tried snap on, I tried quantize on or off, it’s in Steinberg’s own Cubase 9.5 version’s free sample demo project, plus there is the little minor update they have for you to put on top of 9.5.

I have windows 7, SSD 2TB drive, and a K410 Lenovo tower PC. I tell you what’s really wrong - this worked fine in 1988 with my Atari ST and the Cubase version I had then. That’s 30 years of development to get us to a broken SNAP to QUANTIZE function. I don’t know if they really call it that, but it’s what I wanna do.

I could be wrong, and the other guy with a similar problem could be wrong - but the hideous reaction to customers who have paid a large sum of money for a software app from a massively respected provider of dacades-long standing, simply does not do.

My best regards - hey, I really hope it’s me - then I will have a fix in no time. Please, please, let it be my stupid fault!

I’m just not that lucky.

Further testing - ‘set the grid type to use quantization’ says the Udemy Trainer man…Nope, changes nothing, whether grid type set to bar or quantize. …
If I were dumber, I’d have an answer to a problem by now darn it!

Best to all.

Last test for tonight…clicking the left mouse button to position the cursor, also works in the purple bar ruler horizontal area I mentioned, that sits atop the tracks in the big grey area.

This is a notable improvement - because even when I roll the tracks upward to get to one of the tracks lower down, this purple bar, is still present, unlike the pink one.

However - and this bit could be my user error or dodgy mouse button pressing or double clicking - the purple bar has been made to change colour in this process, which I did not want.

This is the discrepancy I now believe. None of you people saying there’s not much of a problem, or offering solutions you no doubt genuinely expect to be the cure for Rovon’s issue, expect to click in that main area where the tracks are, and for the quantization to work - is that correct please?

Then there IS a problem, as compared to how I expect making the SNAP to QUANTIZE function work. It’s just that you can work around it by never expecting to click right there in the track of interest, in that big grey area in the middle. Instead, you have to precisely move the mouse cursor location way up to the top each time, and precisely click in the tiny bit of purple where the BAR measures are, and it will then snap the cursor to the quantized point nearest.

Not a good way to work - which is why I did not think to try it. To all intents and purposes, we are dealing with a CAD type graphical interface - and I wouldn’t expect to keep having to go up to the bar/measure 1/16 markers at the top of the screen, just to click to the nearest quantize vertical line, I can full well see right where my cursor is in the track I am presently working on.

Maybe, there is some reason why it works this way - but it’s not apparent to me now and nobody has made it clear what that might be. In the absence of a good reason, this is a fiddly way to operate.

So, to recap by this newbie here is one way to work:
Set GRID to QUANTIZE
Set SNAP to GRID
Set Quantize to 1/16 (or whatever)
ONLY click up there in the top ruler bar areas (seconds on mine is a pink horizontal bar, and bar/measure 1/16 is the top purple horizontal bar).

I would call this resolved now. the way it makes you work is unnecessarily long-winded, requiring a lot of extra movement, and unnecessary precision. IE it’s a pfaff.

So, the people saying it’s not requiring a fix - no, it isn’t, if you don’t mind running on flat tyres just because you happen to have runflats.
To the people like me and Rovon who find it a problem, it surprises me the more seasoned vets couldn’t just point out what I did above, about only expecting the snap to quantize to work in those two little skinny horizontal bars at the top of the track area.

Unless of course, those seasoned vets, have system versions where it actually DOES SNAP to QUANTIZE in the track area somehow? Then, we are back to it being an all-out problem I would say, that’s been introduced accidentally in the latest software. Is it possible, the different compilations of the Cubase Pro software (eg Mac, 32 bit vs 64 bit) are actually different versions slightly of the Cubase program? That might occur I suppose, on occasion.

Hopefully Rovon - that’s enough of a workaround for you for now?

Hopefully, the others who contributed above in good faith, can confirm whether they too can only get snap to quantize, in the skinny top two horizontal bars?

Thank you all, and my trainer,it’s at least not impossible. That, is a long way from saying, there is nothing for SB to fix.

In 10 years using Cubase I’ve never had to work this way. I’ll join the voices saying that there is some Cubase/project setting that is amiss on your system because snap and quantize always work as expected for 99.99% of people traversing the forums.

Just curious: when you said you reformatted your system, did you backup the Cubase Preferences folder and replace it after reformatting, or did you install Cubase fresh and set each preference up manually from inside Cubase? I know in weird scenarios, sometimes deleting all the Cubase prefs and installing Cubase can cure strange behavior.

Also, does this snap issue happen in a totally blank new project?

When you double-click in the bars/beats ruler, your locator range changes color and turns to a cycle range (it loops back to the start once playback reaches the end of the cycle). This has no effect on quantizing, snapping or the grid. You can toggle this with the Loop button on the transport.

Mate, specially for you I am ready to set up TeamViewer and see what is going on at your machine. Would you like to do that?

In your videos, you have the settings snap-to Event, Relative Grid, and Cursor activated. The behavior you describe is exactly what one should expect with those settings active.

You might not really love my next comment, which is to suggest you have a look at the manual to better understand the various snap functions. If you do that, you’ll have a better grasp of the functions and terminology used, and possibly this will solve the issue.

https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/project_window/project_window_snap_types_r.html