Question about horizontal spacing


I have a question regarding the way Dorico spaces systems horizontally. In my orchestral score, there are pages that have little going on, so there sometimes can be two or three systems in a page. My problem lies with the fact that because (I THINK) the instrument names of the staff labels are causing alignment problems. This results in some systems being more “indented” than others. Any help would be greatly appreciated! Thanks!

You could always use abbreviated names which minimizes the differences. But yes, if you have names on some staves and not others, they will (by necessity) be indented differently.

Perhaps, if you have a reduction part, or some other part that never changes, you could add some dummy spaces to its name to force it to be as wide as necessary so that all other names would fit within that (or a smaller) width, which would then mean that the indent would always be ________ wide.

As always, a picture is worth a thousand words.

Dorico allows some systems to be indented more/less according to the maximum requirements of the staff labels on that system.

You can change the minimum indents for all systems in a layout; you can use trial-and-improvement to work out what value you need to line up all the systems but of course this setting will also apply on pages with only one system that doesn’t have very wide staff labels (although hopefully single-system pages contain most or all staves, and therefore also include the longest labels).

You can override this for individual systems using the Note Spacing tool in Engrave mode.

Thanks to you both for the reply. It just seems odd that it wouldn’t value the alignment of systems over the staff label text. Would justifying them make any difference?

There are situations where the extra space allowed by shorter staff labels is desired.

I’m fairly sure it’s been requested before to align systemic barlines on the same page, even if they have different lengths of staff labels; the minimum indent setting more-or-less gives you that option but on a per-layout rather than per-page basis.

1 Like

This is very interesting. The issue is that you’ve condensed the strings and there is an extra “bracket” to indicate this pairing. That is what accounts for the subtle difference.

As I said, if you add one or two spaces (if regular spaces don’t work, try alt+space) to the front of Orgue it should solve this particular issue.

I would probably recommend using the layout option for minimum indent rather than adding spaces to instrument names, because that option is more directly linked to the functionality.