Question about midi recording with VST Connect

I know…everyone using VST Connect uses it to record audio from a singer or guitar player. But I want to use it mainly to record midi.

So lately I’ve been experimenting with ‘VST Connect SE/Performer’. The audio part works great but I’m mainly interested in recording the external midi signal of the performer.

So I’m the host. But on the performers side the midi keeps echoing back to the performer and back. So when he hits a drum pad during recording he gets the note echoed back via midi.

After intensive investigating I finally gave up and decided to turn off midi thru on my side in preferences and that works. No more midi echo to the VST Connect performer.

But now I can’t play any VST or external instrument anymore.

I know, VST Connect is not meant as a ‘jamming’ tool and I don’t intent to use it like this. But I would like to be able to use at least a VST instrument to give some musical feedback. And I know I can do that when midi thru is enabled.

So now if I want to do that I have to switch back and forth between midi thru active/inactive between sessions. Not very convenient.

I’ve found a temporary workaround by turning my master keyboard (Piano) to ‘local on’ so I can hear what I play and record my notes to a midi track that sends the midi to a VST instrument that is similar to what I hear. And then playback the track to the performer. But of course this is not ideal.

I also can’t find anything in the manual about having to turn ‘midi thru’ off if you want to record midi via VST Connect?
And I must say there is actually no info about recording midi via VST Connect at all! It’s all focused on the performer using a microphone, not a midi instrument. I only saw a very recent video of DOM using this
https://www.youtube.com/watch?v=IdPMFu4LZTI
And there it seems to work seamlessly out-of-the-box for them? (Of course!) And of course they don’t mention any settings and such. It all works great!

Am I missing something or is this a bug in VST Connect? Because it seems to me by default it should not echo back midi notes? And disabling midi thru should not be necessary? This should be handled by the application itself IMO?

I have some more issues? Like why is the send reverb to the microphone channel still active and controls the input volume of the microphone while the microphone channel is muted? Maybe this tool should be set up for 3 different purposes? Recording midi or audio or both? Not important for now but something to think about for the future!

Monitoring is off on the track. Only record enabled is on. Because he has to record of course. 
Using the latest Cubase pro 10.5.12 and Connect SE/Performer 4.0.43 on latest Windows 10 v1909.

Also tried to create a completely fresh project but this has the same issue. Midi notes keep echoing back to the performer!

Maybe I’m missing some setting? Hope someone can help me in the right direction?

There is no MIDI echo here and I don’t even know how to reproduce it. I’d suspect MIDI track monitor, but you mentioned that you have that off. How and where do you set “MIDI thru”? Also, if his MIDI plays some plugin on your end, the audio of that may bounce back to him, or his own audio. Don’t engage track monitor for Performer audio tracks. Can you check that?

“why is the send reverb to the microphone channel still active and controls the input volume of the microphone while the microphone channel is muted?” Don’t get that. Are you talking about Performer? I set a mic channel there, add reverb, talk, mute: all off. Could you be more specific so we can reproduce your issues?

Also, if his MIDI plays some plugin on your end, the audio of that may bounce back to him, or his own audio.

I guess this is happening. It seems logical to load the same vst instrument in Cubase and record midi to this track. If you turn off cue send it should fix it for perfomer but it will still echo in Cubase. Because you also hear the performer audio.

I think the easiest way is to record midi to a midi track which is not connected to anything.

My drummer has a yamaha dxt 12 with its own tone generator. All sorts of sync and echo problems went away after i switched off midi thru in the preferences. This is not much work because i could define a key shortcut for the midi thru on/off toggle.
After i press that keycommand a short message shows the status.
HTH
Karel

He’s only playing BFD3 on his end. No plugins here on my side. But I finally figured it out. When you create a midi track in a VST connect session it will only connect the output to the “Cue(VST Connect)” so the performer can hear want I play back on the midi track. But in order for the performer to be able to record you need to connect the “VST Connect: Ins…” on the input. Otherwise there is no incoming midi. So if you have these both active it will echo everything back what the performer puts into the track with a second delay or so. So it’s either remove the Cue (output) every time the performer wants to record or switch off midi thru in preferences. I think the last is more convenient because it’s easy to assign a key to do this on the fly.

Forget about this remark. It’s the result of running in circles and not seeing a solution. I mixed up a few things.

Thanks for the heads up!

Thanks for the tip! I also think it’s the best option to create a key command to quickly be able to toggle midi thru on/off in preferences.