question about non-metered bars

My unmetered bars in my project seem not to be infinite (as I expected). They seem to basically be measured according to the previous bar, with the option of expanding said bar. Is that how these work? I just found myself running out of beats in unmetered bars.

To add 100 beats, Shift-B, 100q.

Unmetered bars are not “measured according to the previous bar”, but they don’t automatically change length if you add more notes in insert mode.

Either delete the old bar lines and put new ones where you want them, or insert more “time” into every staff in the score, as Dan Kreider explained.

Hello all. I’m trying to get rid of time at the end of an un-metered Flow. Even if I use the bars pop-over and -1000q it doesn’t shift (and I’m sure I didn’t insert that amount of time). Thanks in advance for advice!

Have you tried inserting a new bar line, and then deleting the final empty bar?

Or select something in that flow and choose Write > Trim Flow (or enter “trim” into the Shift-B popover).

1 Like

There are no ‘bars’ as such with non-metered music, but I’ve tried yes.

If you have any barlines after that, you’d want to click on the later bars (unmetered though they are) and type Shift-B, -1 without the q.

Thanks, but I’ve tried that. All I get is a pop-up giving me instructions about how to add a time signature if I want to add bars.

Have you tried my suggestion of trimming the flow (a few comments above, I think I replied just before you did so you may have missed it) ?

Thank you Lillie, I hadn’t seen that. So I’ve tried it now, and the remaining bit got shorter (the rest there is now valued at 2q rather than 4q), but it hasn’t gone.

The common problem when you can’t delete everything at the end of flows is that there is something that exists at that position - if not a hidden item of some kind, then it could be that a previous item has duration that extends to the end (like a pedal line).

If signposts aren’t shown (View > Signposts), show them and check for hidden items indicated by signposts. Additionally look at previous items in the flow and check whether they have duration.

I’ve had this happen before. Usually brute force works: add a time signature to that odd bar, or add some final barlines, or… eventually I’ve been able to get rid of it, but when it happens, it’s odd.

Can you post the project here and let one of us take a whack at it?

Thank you. I followed Lillie’s suggestion and deleted a frame break. It worked, but created a new problem. Is there a way of making this final stave stretch across the page, as it does when there is a framebreak and time afterwards? It’s now shrunk to one side and is squashed up. I believe this would also happen if Dan’s suggestion worked.

Ah, solved, I found this in Engrave.

Thanks to you both for your time!

1 Like

The default setting for the horizontal justification of final systems is here - you’ll find that much more comfortable than moving their ends manually!

1 Like