Question on brackets/barlines for grand staff

Hi,

In a piano part I am working on, the first 25 (or so) measures are written with notes in both hand. In this section, brackets and barlines looks fine.

After this there is a fairly long period of slashes with chords, in which I have let Dorico hide the LH staff. Also this looks fine. In one particular place I want a two hand chord to be played so I notated this with notes in both hands. Dorico reacts correctly on this and shows both LH and RH staves around this chord. But for some reason, both bracketing and “connected bar lines” fail.

I haven’t made any changes to anything that has with bar lines to do. Also there are no meter changes along the way to the later point.

Any suggestions?

Thanks
/DT

At first glance I’m not sure how it happened, but if you have Pro, you can easily make a manual bracket/barline change to fix it.

I think I’d try forcing Dorico to recalculate before resorting to a manual bracketing change. Try turning off the Bracketing option within Layout Options to show the bracket when only one stave of a grand staff instrument is shown, then try turning it back on. Or save the project and reopen it. Or put in a System Break at 234 and then delete it.

OK thanks @pianoleo for ideas.

Closed the project yesterday and reopen this morning - no difference

System break at 234 - no change. Remove this system break - no change.

Changed this setting
image
first to “Do not draw brace”. All “single” braces disappeared, but the barlines did not change.
Changed back to “Draw brace” which led back to initial situation: single brace and barlines not drawn across staves.

/D

@dankreider I dit not have the time to try your proposal yet, I will do that later. Will it solve the barline problem? This is more important, without barlines across staves, this 1 to 2 staves change is even more difficult to see when sightreading (at least it would to me).

If you previously manually drew in the brace on the single staff, you might have remaining bracket and barline change signposts that are preventing Dorico automatically updating. If your layout options are set to what you want, remove all unnecessary bracket and barline signposts. (Make sure signposts are shown, they’re the brown ones.)

@Lillie_Harris nope no manual actions in relations to this.

@dan.h.tillberg the bracket/barline tool allows you to draw or delete barlines across staves as desired, yes.

If you’re still having problems with this, please cut down the project itself to the minimal material required to reproduce the problem, then attach it here. It’s much easier for us to help if you attach a project.

Ok took it up now after some days travelling; and found a “bracket and barline change” signpost that I haven’t observed before. I really have no idea how it ended up there, but was the problem. Case closed. Thanks all ///D

1 Like