Question on Key Editor!

Hi All!

:question: Could anybody assist, please?

I want to know if it is possible to have the key editor of a track open, while playing (and hearing) an instrument on another track. (Without using the “smaller-view” In-place editor).

Thank you.

Yes, it’s possible, so long as it is the Project window that has the focus, and the track whose Part is open in the Key Editor isn’t record/monitor-enabled.

  1. Open the Part that you wish to see in the Key Editor
  2. Click back in the Project window and select that track of the Instrument you wish to hear, making sure that the track whose part is open in the Key Editor is de-selected. (you can even record the on the new MIDI track, without affecting the Key Editor window… so long as the Key Editor window doesn’t have the focus.)


Thank you for your speedy reply!

:exclamation: However, …I’m sorry, I have now become slightly frustrated…

:exclamation: I have tried as you said (and I’ve always tried it) , but it does not work that way. I’ve even minimized the key editor slightly to ensure it does not have any “focus”. The other instrument track is selected (and even record enabled).

:question: Is it not a setting somewhere that has to be changed!?

Preferences (somewhere)-> Enable record on selected tracks…!?
and maybe
Prferences (somewhere) - Link editors
Both should probably be unchecked. And you maybe should post your used Cubase version

Thanks “Thinking Cap” & “Vic”

:smiley: You where a great help, your time and your speedy replies! :exclamation:

:exclamation: Yes, 1st, under “**Preferences/**Record/MIDI” I de-selectedSolo Record in Editor”. (“Of Course!” :blush: )

However, then the solution was only 1/2-way, because now both instruments played at the same time!

:exclamation: So, eventually in “Preferences/Editing/Project & Mixer” I also de-selectedSelect Track/Channel on Edit Settings”.

Now it works fine - I can play and instrument on one track (and hear it), while I’m viewing the “Key Editor” of another.

By the way I have Cubase 5.5.3.

:bulb: I I hope this helps somebody that might have the same hick-up one day…

:blush: OK, sorry guys… :blush:

:confused: It still does not work as I want it to!!! :confused:

I confirm, I would like to play an instrument from another selected track, while I have the “Key Editor” open of another instrument (which it’s track has not been selected in any way) during playback.

My “initial problem” was I could not hear the instrument I played at all while the “key Editor” of the other instr was open.

My “problem” now is that both are playing at the same time! But “interestingly”, if I open the mixer (F3) then only will the instrument I play be heard alone!

If any body “figures it out” one day, I will dearly appreciate the solution!

Thank you…

When you say “both are playing at the same time”, do you mean that they are both playing what you are playing live, or both playing what is inside the Key Editor, or that they are playing independently (which would be correct… you never said anything about not wanting to hear what was in the Key Editor… so long as it is at least playing the correct instrument :wink: ).
In fact, none of those Preference options should make a difference (not even “Solo Record in MIDI Editors”, because, if the focus is correct, you aren’t in the Editor!), so long as you first select the Part to open in the Key Editor, then select the other MIDI track (and double-check which tracks are record/monitor-enabled… “off” for the Key Editor track, and “on” for the live track).
What happens if you hit Record?
(I can’t get it to misbehave here :wink: )


:slight_smile: Tx for your patience, but now I’m totally confused (maybe because I’m tired as well).

:unamused: I “mean that they are both playing what you I am playing live” - the pad and the piano the same notes that I play. Instead, only the piano should play, while I have my “eye” (not just my ears) in the Key Editor of the pad for my timing.

:exclamation: :open_mouth: When I press record, as you asked, it starts to record in the Pad-track not the Piano! The Pad-track is not even Record-enabled, the Piano is! :astonished:

But important as I said, each time I open the mixer (while in the Key Editor of the Pad), everything is fine - only the notes I play live on the Piano is played. (the Pad is silent in the Key Editor, which also is not what I was “expecting”.

:bulb: Any idea’s :bulb: , or is my initial expectation: “…that I would like to play an instrument from another selected track, while I have the “Key Editor” open of another instrument… But only the instrument I’m playing should sound the notes I’m playing, not the one of the Key Editor”… wrong :frowning: .

:neutral_face: Well, for now I’m off to bed to get some shut-eye…

(The Mixer shouldn’t even be a factor here :confused: )
Do you have your windows arranged so that you can see the Project window’s Tracklist? Which track(s) are showing MIDI activity when you play?
With Preferences>Editing>Project & Mixer>“Enable Record on Selected Track” active, and your Piano track selected…
If you click in the Key Editor window, do you see the Record button in the project window switch to the Pad track, and back to the Piano again when you click back in the project window?


:neutral_face: OK, here is how is stands…

I’ve set everything to default.

If I open the pad’s Key Editor, slightly minimized so I can see the tracks in the Proj Window, (I’ve “highlighted” the piano track in the Proj Window) the pad track gets record-enabled. (I suppose because “Solo Record” is enabled :wink: ). Then, I only hear the pad play my notes.

:astonished: Ok, when I hit “F3” (to bring up the Mixer), the Piano gets record-enabled (the Pad not anymore!), and only the piano responds to my notes I play - :smiley: just as I wanted it all along! ( :wink: I initially thought its because because “Sync Proj & Mixer selection” is enabled in Pref’s, but evben if I de-select it the status quo remains :astonished: ).

(I confirm, all the other midi activity is normal - all other tracks (including the pad) are playing their own midi notes.)

What “bothers” :confused: me is why it is necessary to enagage the mixer. However, that’s what I now do accept. :neutral_face:

:question: But as you say, the mixer should not play a roll here! :confused: However, it may be an indication :arrow_right: of where the “possible problem” in my set-up is.

(For interest sake, I was always wondering why my scrub funtion was not working in the “Wave Editor”. From an old internet-forum I learned that I had to disable the control room function. Then it worked!)

:exclamation: So, any more inputs, if you have the time (and energy) are very welcome…

What platform do you use?
I’m beginning to wonder if there might be some corruption in your Preferences folder (on Mac here, but I believe the PC equivalent is inside the AppData folder).
Temporarily, set that Cubase folder aside (and any folders from previous versions of Cubase that might stiil be there), so that, on next launch, Cubase will rebuild them from scratch (rather than re-importing them from an earlier version, if there is one).
Obviously, you’ll lose some settings, but does it fix this particular situation?


Ok, I :open_mouth: reluctantly did what you requested - remove the Cubase 5 folder from App Data/Steinberg. (I’d normally rather not fiddle with stuff I know normally you should not!)

:astonished: Well it took a while to “rebuild”. However the status quo still remain.

As a matter of fact the mixer has always been open. :exclamation: :exclamation: :exclamation: However it has to be on TOP of the other windows. (If it is not on top or I close it, the pad gets record-enabled again immediately, dis-engaing the record of the piano, and I only hear the pad sound to the notes I’m playing. :exclamation: All the time the Piano is highlighted in the Project window.

:exclamation: In all, I have the Proj Window, Key Editor of Pad, and the Mixer open on TOP to get the result I want - to hear only the piano, while wacthing the progress bar in the pad’s Key Editor with it’s midi notes.)

:slight_smile: Thanks for your time and interest. At least I get the result I want, although it’s a bit “unconventional”. However the “glitch” is gnawing my brain.

:wink: More suggestions always welcome…

I’ll kick myself when I eventually discover what simple thing is causing this! :blush: :slight_smile: , but, for the moment, I am completely stumped by it.